LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 13.1 beta1 "Cannot open ConsoleKit session: Unable to open session..." (http://www.linuxquestions.org/questions/slackware-14/slackware-13-1-beta1-cannot-open-consolekit-session-unable-to-open-session-807586/)

fl0 05-13-2010 08:28 AM

Slackware 13.1 beta1 "Cannot open ConsoleKit session: Unable to open session..."
 
Hi,

i do a clean install of slackware64 13.1 beta1 with KDE and switch default runlevel to 4 in /etc/inittab.

I try to login in kdm, I always come back to the login....

I try this with default runlevel 3 and an .xinitrc with "ck-launch-session startkde" .. works without problems, so I switch back to default runlevel 4, now i can login and only get the error "Cannot open ConsoleKit session: Unable to open session..."

here are some logs

syslog

Code:

May 13 14:45:12 hydra kdm: :0[1989]: Cannot open ConsoleKit session: Unable to open session: Launch helper exited with unknown return code 127
kdm.log

Code:

X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Slackware 13.1 Slackware Linux Project
Current Operating System: Linux hydra 2.6.33.3 #2 SMP Fri Apr 30 23:50:51 CDT 2010 x86_64
Kernel command line: BOOT_IMAGE=Linux ro root=fd01 resume=/dev/cryptlvm/swap vt.default_utf8=0
Build Date: 05 May 2010  01:59:51AM
 
Current version of pixman: 0.16.6
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu May 13 14:45:05 2010
(==) Using default built-in configuration (30 lines)
(EE) Failed to load module "fbdev" (module does not exist, 0)
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                  Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
QFont::fromString: Invalid description 'Serif,20,5,0,50,0'
QFont::fromString: Invalid description 'Sans Serif,10,5,0,50,0'
QFont::fromString: Invalid description 'Sans Serif,10,5,0,75,0'
arguments to ck_connector_get_cookie() were incorrect, assertion "connector != NULL" failed in file ck-connector.c line 583.

any idea?

rfernandez 05-13-2010 09:16 AM

Hi. I had the same problem with my installation. What I did was edit rc.local and rc.local_shutdown (thought this one I think it's not necessary) to load ConsoleKit-Daemon before log in to KDE. This is how it looks like:

rc.local:
Code:


PIDFILE=/var/run/ConsoleKit/pid

if ! ps axc | grep -w console-kit ; then
        rm -f $(dirname $PIDFILE)/*
        if [ -x /usr/sbin/console-kit-daemon ]; then
                echo "Starting ConsoleKit-Daemon:  /usr/sbin/console-kit-daemon"
                /usr/sbin/console-kit-daemon 1>/dev/null
        fi
fi

unset PIDFILE

rc.local_shutdown
Code:

PIDFILE=/var/run/ConsoleKit/pid
if [ -e "$PIDFILE" ]; then
        echo "Stopping ConsoleKit-Daemon..."
        pid=$(cat $PIDFILE)
        kill $pid 1>/dev/null 2>/dev/null
        killall console-kit 1>/dev/null 2>/dev/null
        rm -f $PIDFILE
fi

unset PIDFILE

And everything should work fine. This idea has been taken from rc.messagebus, by Robby Workman.

fl0 05-13-2010 09:37 AM

Thx @rfernandez, but this solution don't work for me, but I have found my fault.

I not installed eggdbus, but ConsoleKit needs eggdbus.


All times are GMT -5. The time now is 05:26 PM.