LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 08-31-2010, 04:15 AM   #16
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 5,953

Original Poster
Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496

I have a thread about this on phoronix.com, where I have the ear of a developer from AMD. Rather than wasting 2 sets of people's time, I have decided to pursue that one, as it is likely to lead further.
http://www.phoronix.com/forums/showthread.php?t=25805

I'm going to take Robbie up on his 2.6.35 kernel. I think I have to. I can lock this one by enabling modesetting, and modprobing the radeon module while in runlevel 3. In fact, the 'radeon.modeset=1' boot parameter is fairly lethal to this box.

If I can duplicate that with 2.6.35, I'll have to file a kernel bug :-((.
 
Old 08-31-2010, 04:19 AM   #17
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,087

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Well it sure looks like a bug to me, quite possibly AGP related. I'd try disabling AGP as I previously suggested. If you are not using KMS, you can disable AGP by setting the BusType option to PCI in the Device section of xorg.conf (see the 'radeon' man page). If you are using KMS, you would pass radeon.agpmode=-1 to the kernel.

Adam
 
Old 08-31-2010, 05:30 AM   #18
55020
Member
 
Registered: Sep 2009
Location: Yorks. W.R. 167397
Distribution: Slackware
Posts: 272
Blog Entries: 4

Rep: Reputation: 256Reputation: 256Reputation: 256
Quote:
2. You guys have messed up the GB keyboard big time
You need to create a file named /etc/hal/fdi/policy/10-keymap.fdi containing the following text:

Code:
<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keys">
      <merge key="input.x11_options.XkbLayout" type="string">gb</merge>
      <merge key="input.xkb.variant" type="string" />
    </match>
  </device>
</deviceinfo>
And remove the "xorg.conf keyboard stuff in xorg.conf". The xorg people changed the way of configuring your keyboard. What you are seeing is not so much a "messed up" GB keyboard, more a totally unconfigured one.
 
Old 08-31-2010, 05:28 PM   #19
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,904

Rep: Reputation: Disabled
Quote:
Originally Posted by business_kid View Post
So, Everything should work on a bog standard slackware-13.1, you say.

Any thoughts on the problems in post #1? further testing has allowed me to add 2 more

1. Even allowing a screensaver to function freezes X, although If I just have move to a blank screen in X with just the background, I can dodge quickly to a console and back.
First I've seen of any problem like that.

Quote:
2. You guys have messed up the GB keyboard big time. Here's some of the mistranslations (should be = actually throws up)
\=<;|=>;@=";poundsign=#;euro=missing;~=|;#=\;"=@.

I'm based in Ireland, I need a euro, and it's handy to have a poundsign and a $. The xorg.conf keyboard stuff in xorg.conf is copied directly from slackware-12.0 where it produced a sane keyboard, with piles of keys on Right_Alt. Right_Alt doesn't seem to function now, and many keys are repeated.
We didn't mess up anything, if it's even messed up at all. See CHANGES_AND_HINTS.TXT on your installation media for the proper way to configure keyboard layout.

Quote:
I chased up the link, Robbie, and saw stuff about new xorg packages, kernels, ati, nvidia, & nouveau drivers, & 64bit stuff, (which is not relevant to this box). Excellent Work. Are you suggesting I update 13.1 in favour of the newer packages? I went off the beaten track before, and it didn't go well, and proved a time thief. If someone tells me that slackware-13.1 actually doesn't work on ATI graphics (which is blindingly obvious over here), and I need to fix this and that, well then, I'll go for it. But I'm hoping for clarity from somewhere from those with some knowledge of the stuff before diving in with git and gcc.
I'm not suggesting that anyone do anything (I *am* providing newer X stuff for *testing*), nor am I telling you ATI cards won't work on 13.1 (some subset of ATI cards indeed might not work, but I have no experience with that - both of mine work fine).
 
Old 09-01-2010, 05:02 AM   #20
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 5,953

Original Poster
Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
Thanks for the keyboard hints. It seems to work well.

Kernel 2.6.35.4 is 75% better video wise. I've lost the automatic total crash, and have more ability (but not freedom) to move between consoles.
Disabling agp worked better, but gave no meaningful output in startx > file 2>&1.
I tried disabling agp fast writes, and reducing speed to 4x and these were disastrous - immediate kernel oops.
Running on 8x with fast writes and the default setting for latency clocks(32)also worked (i.e. I could start X without a crash). There are some obvious problems
(II) [KMS] drm report modesetting isn't supported.
(EE) RADEON(0): [dri] RADEONDRIGetVersion failed because of a version mismatch.
[dri] This chipset requires a kernel module version of 1.17.0,
[dri] but the kernel reports a version of 2.5.0.[dri] If using legacy modesetting, upgrade your kernel.
[dri] If using kernel modesetting, make sure your module is
[dri] loaded prior to starting X, and that this driver was built
[dri] with support for KMS.
[dri] Disabling DRI.

Disable CRTC 1 success
mc fb loc is 00bf00b0
(EE) RADEON(0): Acceleration initialization failed
Output UNIPHY1 transmitter setup success

What's that dri module version stuff about?Is it (1) disabling kms and reverting to legacy and then (2) disabling legacy modesetting over this version thing?
 
Old 09-01-2010, 09:54 AM   #21
TSquaredF
Member
 
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 488
Blog Entries: 1

Rep: Reputation: 55
Quote:
From #15:
The timing of loading modules isn't an issue here, I think, because I boot to runlevel 3. initdefault is always 3 here. Then I log in, and type startx if I want X. Modules load at that point, and modules.dep looks after the order of loading.
I think it is an issue.
Quote:
From #20:
[dri] If using kernel modesetting, make sure your module is
[dri] loaded prior to starting X, and that this driver was built
[dri] with support for KMS.
[dri] Disabling DRI.
I am using an older chipset than you are, but I have made no modifications beyond that listed in my post #3.
Regards,
Bill
 
Old 09-01-2010, 10:25 AM   #22
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 5,953

Original Poster
Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
Smile

Well, I finally found the solution to this. It was the agp bus, and the kernel.

http://lists.freedesktop.org/archive...st/003373.html

Some update made use of a (pcie-only) table and broke compatibility with agp boards, which don't have this table. The patch, I believe writes a table for agp. People with pcie radeon boards could test slackware to death and it would be fine. Along I came with trailing edge technology, and hit trouble.

I have 2.6.35.4 based on Robbie's config (with thousands less modules built), and it works reasonably well - a little inclined to oops if I don't behave myself, but I'm going away to try and use it, and will post afresh if that produces hard faults.

Lastly I would not recommend slackware's (or any) stock 2.6.33.4 for agp buses, as that version had other faults which 2.6.35.4 fixed.

I also run X with 64 console-kit-dae processes. Is that kosher?
 
Old 09-01-2010, 10:52 AM   #23
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,904

Rep: Reputation: Disabled
Good to hear that all is (mostly) well now. The consolekit processes are fine - they're actually just threads. It's a cosmetic non-issue :-)
 
Old 09-02-2010, 03:35 AM   #24
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 5,953

Original Poster
Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
Quote:
Originally Posted by rworkman View Post
Good to hear that all is (mostly) well now. The consolekit processes are fine - they're actually just threads. It's a cosmetic non-issue :-)
Good. Thanks to all who contributed here.
KMS just sets 1440x900 and leaves it set. The weirdness I am left with does not appear to be a Slackware specific issue.

1. First boot into X in the morning goes wrong. Yesterday it was a kernel oops. Today, I was kicked into some test cycle on the monitor, which was showing as switched off but was cycling White, Red, Green, Blue, Off, every 5 seconds or so. I tried Ctrl_Alt_Backspace, and tried switching the monitor on (or mebbe off again & on); I had the console there, so I hit up arrow and return, and X loaded :-/. Every kernel oops switches off the monitor, but the monitor is a pretty robust thing, doing 62khz at least.

2. It runs the 'atlantis' screensaver now with no issues. If I leave it for an hour or two and start hopping to consoles or hit Ctrl_Alt_Backspace, results are unpredictable. I got a kernel oops from Ctrl_alt_backspace. I also got weirdness by jumping to console terminals and back. Last night & this morning, jumping to a console loses me the Alt_F7 vt. I started this session with X on Alt_F7. I jumped to a console, read a file, and jumped back. Now Alt_F7 is blank, and X is on Alt_F8 :-/.

3. Starting X without the radeon module loaded is also likely to produce a kernel oops. From my ssh terminal I gather this crash was in the radeon module. I have circumvented that with a 'modprobe radeon' in rc.local.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New to Slackware & having problems with graphics bpcHitMe LinuxQuestions.org Member Intro 0 09-11-2009 06:46 AM
ATI on-borad graphics & Nvidia PCI graphics together? PClOStinspace Linux - Hardware 5 04-28-2009 04:30 PM
Bad graphics: ATI raedon graphics card and slackware shady_Dev Linux - Hardware 1 05-22-2008 06:00 AM
64 BIT SuSE 9.3 Pro & ATI Radeon Xpress Graphics Conflict Be.Gurmeet.Be Suse/Novell 0 08-02-2005 09:00 AM
Slackware 9.0 & Radeon 9700 Pro - Can't install drivers Rav Slackware 16 05-22-2003 02:22 PM


All times are GMT -5. The time now is 06:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration