LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-03-2009, 05:00 AM   #1
theget
LQ Newbie
 
Registered: Sep 2009
Location: Spain
Distribution: Slackware64 13.1 Multilib
Posts: 8

Rep: Reputation: 0
Slackware 13.0 x86 & x86_64 - trouble with xkb layout


hi all, ive just installed 13.0 in both variants on 2 pc's, all works fine, but i've edited the lang.sh to fit my language needs just to
LANG=es_ES.UTF-8
also the xorg.conf is in "es" for spanish,
but anytime i startx, manually or by telinit 4 mode, the xkbmap is default in "en"

i've read near about that the actual version of Xorg didnt need conf? (maybe i'm wrong)
where i can change those values to get it spanish on default?

many thanks

Regards

get

Last edited by theget; 09-03-2009 at 05:01 AM.
 
Old 09-03-2009, 05:06 AM   #2
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,517

Rep: Reputation: 90
Hi theget,

welcome to LQ.org! Please read the CHANGES AND HINTS text file on the Slackware CD. This is about HAL, you will have to copy a hal policy file to /etc and modify it to use the Spanish keyboard layout. xorg.conf should not be necessary, you should remove the keyboard line AFAIK if you use the HAL file.
 
Old 09-03-2009, 06:16 AM   #3
theget
LQ Newbie
 
Registered: Sep 2009
Location: Spain
Distribution: Slackware64 13.1 Multilib
Posts: 8

Original Poster
Rep: Reputation: 0
my fault, i didn't read it before, and yes, that's just what i need.

Many thanks
 
Old 09-03-2009, 09:02 AM   #4
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,517

Rep: Reputation: 90
No need to apologize, you're welcome
 
Old 09-14-2009, 09:33 PM   #5
salemboot
Member
 
Registered: Mar 2007
Location: America
Distribution: Linux
Posts: 159

Rep: Reputation: 36
I'm sure there is a way to put a kernel parameter which will automate all of this.

Quote:
If you need to use a non-US keyboard layout, then copy the file located at
/usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi to /etc/hal/fdi/policy
and edit it to suit your needs. Have a look at the contents of that file
for an example and more information. If you prefer to do this the "old" way
using /etc/X11/xorg.conf, then you can use "X -configure" or "xorgsetup" to
generate an xorg.conf, then add the following lines to the "ServerFlags"
section to disable input device hotplugging via HAL:
Option "AllowEmptyInput" "false"
Option "AutoAddDevices" "false"
Option "AutoEnableDevices" "false"
This is also relevant if you prefer to disable HAL completely for whatever
reason.
Quote:
Input methods for complex characters (CJK, which is shorthand for Chinese,
Japanese, Korean) and other non-latin character sets have been added. These
input methods use the SCIM (Smart Common Input Method) platform.
The environment variables for SCIM support are set in /etc/profile.d/scim.sh
The requirements for getting SCIM input methods to work in your X session
are as follows:
(1) Use a UTF-8 locale. Look in /etc/profile.d/lang.sh for setting your
language to (for instance) en_US.UTF-8. As a word of warning: maybe you
should leave root with a non-UTF-8 locale because you don't want root's
commands to be misinterpreted. You can add the following line to your
~/.profile file to enable UTF-8 just for yourself:
export LANG=en_US.UTF-8
(2) Make the scim profile scripts executable. These will setup your
environment correctly for the use of scim with X applications. Run:
chmod +x /etc/profile.d/scim.*
(3) Start the scim daemon as soon as your X session starts. The scim daemon
must be active before any of your X applications. In KDE, you can add a
shell script to the ~/.kde/Autostart folder that runs the command
"scim -d". In XFCE you can add "scim -d" to the Autostarted Applications.
If you boot your computer in runlevel 4 (the graphical XDM/KDM login)
you can simply add the line "scim -d" to your ~/.xprofile file.
This gives you a Desktop Environment independent way of starting scim.
When scim is running, you will see a small keyboard icon in your system tray.
Right-click it to enter SCIM Setup. In 'Global Setup' select your keyboard
layout, and you are ready to start entering just about any language
characters you wish! Press the magical key combo <Control><Space>
in order to activate or deactivate SCIM input. The SCIM taskbar in the
desktop's corner allows you to select a language. As you type, SCIM will show
an overview of applicable character glyphs (if you are inputting complex
characters like Japanese).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware-Current x64 & x86 + Nvidia SqdnGuns Slackware 7 05-24-2009 10:34 AM
Process Memory Layout on x86_64 kailas Linux - Kernel 3 08-16-2008 11:25 AM
problem creating custom xkb layout drobert Linux - Desktop 3 06-28-2008 08:21 PM
SDL_image for both x86 & x86_64 architectures Last Attacker Linux - Software 1 12-04-2006 05:33 AM
xkb layout changing Ipolit *BSD 3 02-03-2004 03:12 PM


All times are GMT -5. The time now is 01:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration