LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-09-2009, 03:10 PM   #1
compul
Member
 
Registered: Aug 2009
Distribution: debian testing / slackware 13.0
Posts: 30

Rep: Reputation: 15
slackware 13.0 wont start X - waiting for X server to shut down


hey,
I got a brand new SlackWare 13.0 running on my PC. It so happens that, suddenly, the x server didnt want to start anymore :P

$startx
xauth: creating new authority file /root/.serverauth.7125

[...]

waiting for X server to shut down

$

There is no Error-message or anything that could give me some kind of clue. Just the screen becomes black for some seconds and then i see the output above.

Any ideas?

thx
lg,
compul
 
Old 09-09-2009, 03:14 PM   #2
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Well the first thing that comes to mind that you should never, ever, ever run X as root.

Try it as a normal user. If it fails, show us the full output of the command and the /var/log/Xorg.0.log file that was generated.

Adam
 
Old 09-09-2009, 03:46 PM   #3
compul
Member
 
Registered: Aug 2009
Distribution: debian testing / slackware 13.0
Posts: 30

Original Poster
Rep: Reputation: 15
because i have no X and am pretty unexperienced in pure console use, it will take long time for me to copy the file to my usb-stick and put it on the internet with my laptop.... :P

so, hope this is enough. i will do my very best in between:

with my user "compul":

$startx
xauth: creating new authority file /home/compul/.serverauth.6676

X.Org X Server 1.6.3
Release Date: 2009-7-31
X Protocol Version 11, Revision 0
Build Operating System: Slackware 13.0 Slackware Linux Project
Current Operating System: Linux slackDesktop 2.6.29.6-smp #2 SMP Mon Aug 17 00:52:54 CDT 2009 i686
Build Date: 03 August 2009 06:51:50PM

Before reporting problems, [...]
Markers: [..]
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Sep 9 22:26:54 2009
(==) Using config file: "/etc/X11/xorg.conf"

waiting for X server to shut down

$

with a new user "testuser"

$startx
xauth: timeout in locking authority file //.serverauth.6528
xauth: timeout in locking authority file //.Xauthority
xauth: timeout in locking authority file //.Xauthority
xauth: timeout in locking authority file //.Xauthority
xauth: timeout in locking authority file //.Xauthority

X.Org X Server 1.6.3
Release Date: 2009-7-31
X Protocol Version 11, Revision 0
Build Operating System: Slackware 13.0 Slackware Linux Project
Current Operating System: Linux slackDesktop 2.6.29.6-smp #2 SMP Mon Aug 17 00:52:54 CDT 2009 i686
Build Date: 03 August 2009 06:51:50PM

Before reporting problems, [...]
Markers: [..]
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Sep 9 22:26:54 2009
(==) Using config file: "/etc/X11/xorg.conf"

waiting for X server to shut down

xauth: timeout in locking authority file //.Xauthority

$

# cat Xorg.0.log | grep EE
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER

#

# cat Xorg.0.log | grep WW
[...]
(WW) NVIDIA(GPU-0): Unable to read EDID for display device CRT-0
(WW) NVIDIA(0): Unable to get display device CRT's EDID; cannot compute DPI
(WW) NVIDIA(0): from CRT-0's EDID.
#

--edit-----

ok here is the full Xorg.0.log:


X.Org X Server 1.6.3
Release Date: 2009-7-31
X Protocol Version 11, Revision 0
Build Operating System: Slackware 13.0 Slackware Linux Project
Current Operating System: Linux slackDesktop 2.6.29.6-smp #2 SMP Mon Aug 17 00:52:54 CDT 2009 i686
Build Date: 03 August 2009 06:51:50PM

Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Sep 9 22:44:44 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "X.org Configured"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/local" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/CID" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/local" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/CID" does not exist.
Entry deleted from font path.
(**) FontPath set to:
/usr/share/fonts/TTF,
/usr/share/fonts/OTF,
/usr/share/fonts/Type1,
/usr/share/fonts/misc,
/usr/share/fonts/75dpi/:unscaled,
/usr/share/fonts/100dpi/:unscaled,
/usr/share/fonts/75dpi,
/usr/share/fonts/100dpi,
/usr/share/fonts/cyrillic,
/usr/share/fonts/TTF,
/usr/share/fonts/OTF,
/usr/share/fonts/Type1,
/usr/share/fonts/misc,
/usr/share/fonts/75dpi/:unscaled,
/usr/share/fonts/100dpi/:unscaled,
/usr/share/fonts/75dpi,
/usr/share/fonts/100dpi,
/usr/share/fonts/cyrillic,
built-ins
(**) ModulePath set to "/usr/lib/xorg/modules"
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0
(II) Loader magic: 0x1de0
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 5.0
X.Org XInput driver : 4.0
X.Org Server Extension : 2.0
(II) Loader running on linux
(--) using VT number 7

(--) PCI:*(0:1:0:0) 10de:0391:1458:3427 rev 161, Mem @ 0xfd000000/16777216, 0xc0000000/268435456, 0xfc000000/16777216, I/O @ 0x00009c00/128, BIOS @ 0x????????/131072
(II) Open ACPI successful (/var/run/acpid.socket)
(II) System resource ranges:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[5] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.6.3, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.6.3, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Server Extension
(II) NVIDIA GLX Module 185.18.36 Fri Aug 14 17:50:12 PDT 2009
(II) Loading extension GLX
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 1.6.3, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
compiled for 1.6.3, module version = 1.1.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Video Driver
(II) NVIDIA dlloader X Driver 185.18.36 Fri Aug 14 17:24:40 PDT 2009
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01@00:00:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
compiled for 1.6.3, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(II) Loading /usr/lib/xorg/modules//libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
compiled for 1.6.3, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(II) resource ranges after probing:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[5] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(WW) NVIDIA(GPU-0): Unable to read EDID for display device CRT-0
(II) NVIDIA(0): NVIDIA GPU GeForce 7600 GT (G73) at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 131072 kBytes
(--) NVIDIA(0): VideoBIOS: 05.73.22.39.01
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 7600 GT at PCI:1:0:0:
(--) NVIDIA(0): CRT-0
(--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-0
(==) NVIDIA(0):
(==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
(==) NVIDIA(0): will be used as the requested mode.
(==) NVIDIA(0):
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
(WW) NVIDIA(0): Unable to get display device CRT-0's EDID; cannot compute DPI
(WW) NVIDIA(0): from CRT-0's EDID.
(==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
(==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[5] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Setting mode "nvidia-auto-select"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(II) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(==) RandR enabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing extension GLX
(II) config/hal: Adding input device Macintosh mouse button emulation
(II) LoadModule: "evdev"
(II) Loading /usr/lib/xorg/modules/input//evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
compiled for 1.6.3, module version = 2.2.5
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 4.0
(**) Macintosh mouse button emulation: always reports core events
(**) Macintosh mouse button emulation: Device: "/dev/input/event0"
(II) Macintosh mouse button emulation: Found 3 mouse buttons
(II) Macintosh mouse button emulation: Found x and y relative axes
(II) Macintosh mouse button emulation: Configuring as mouse
(**) Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
(**) Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE)
(**) Macintosh mouse button emulation: (accel) keeping acceleration scheme 1
(**) Macintosh mouse button emulation: (accel) filter chain progression: 2.00
(**) Macintosh mouse button emulation: (accel) filter stage 0: 20.00 ms
(**) Macintosh mouse button emulation: (accel) set acceleration profile 0
(II) Macintosh mouse button emulation: initialized for relative axes.
(II) config/hal: Adding input device CHESEN USB Keyboard
(**) CHESEN USB Keyboard: always reports core events
(**) CHESEN USB Keyboard: Device: "/dev/input/event4"
(II) CHESEN USB Keyboard: Found keys
(II) CHESEN USB Keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "CHESEN USB Keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"
(II) config/hal: Adding input device CHESEN USB Keyboard
(**) CHESEN USB Keyboard: always reports core events
(**) CHESEN USB Keyboard: Device: "/dev/input/event3"
(II) CHESEN USB Keyboard: Found keys
(II) CHESEN USB Keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "CHESEN USB Keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"
(II) config/hal: Adding input device Razer Razer Copperhead Laser Mouse
(**) Razer Razer Copperhead Laser Mouse: always reports core events
(**) Razer Razer Copperhead Laser Mouse: Device: "/dev/input/event2"
(II) Razer Razer Copperhead Laser Mouse: Found keys
(II) Razer Razer Copperhead Laser Mouse: Configuring as keyboard
(II) XINPUT: Adding extended input device "Razer Razer Copperhead Laser Mouse" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"
(II) config/hal: Adding input device Razer Razer Copperhead Laser Mouse
(**) Razer Razer Copperhead Laser Mouse: always reports core events
(**) Razer Razer Copperhead Laser Mouse: Device: "/dev/input/event1"
(II) Razer Razer Copperhead Laser Mouse: Found 12 mouse buttons
(II) Razer Razer Copperhead Laser Mouse: Found x and y relative axes
(II) Razer Razer Copperhead Laser Mouse: Found scroll wheel(s)
(II) Razer Razer Copperhead Laser Mouse: Configuring as mouse
(**) Razer Razer Copperhead Laser Mouse: YAxisMapping: buttons 4 and 5
(**) Razer Razer Copperhead Laser Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Razer Razer Copperhead Laser Mouse" (type: MOUSE)
(**) Razer Razer Copperhead Laser Mouse: (accel) keeping acceleration scheme 1
(**) Razer Razer Copperhead Laser Mouse: (accel) filter chain progression: 2.00
(**) Razer Razer Copperhead Laser Mouse: (accel) filter stage 0: 20.00 ms
(**) Razer Razer Copperhead Laser Mouse: (accel) set acceleration profile 0
(II) Razer Razer Copperhead Laser Mouse: initialized for relative axes.
(II) Macintosh mouse button emulation: Close
(II) UnloadModule: "evdev"
(II) CHESEN USB Keyboard: Close
(II) UnloadModule: "evdev"
(II) CHESEN USB Keyboard: Close
(II) UnloadModule: "evdev"
(II) Razer Razer Copperhead Laser Mouse: Close
(II) UnloadModule: "evdev"
(II) Razer Razer Copperhead Laser Mouse: Close
(II) UnloadModule: "evdev"

lg,
compul

Last edited by compul; 09-09-2009 at 04:09 PM. Reason: forgot something
 
Old 09-09-2009, 03:55 PM   #4
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
As your user, try this:

xinit /usr/bin/xterm

And see if X starts with just an xterm.

Adam
 
Old 09-09-2009, 04:55 PM   #5
compul
Member
 
Registered: Aug 2009
Distribution: debian testing / slackware 13.0
Posts: 30

Original Poster
Rep: Reputation: 15
it actually does!

so now?
 
Old 09-09-2009, 05:28 PM   #6
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Did you install KDE and XFCE when you installed slackware 13? Does /usr/bin/startkde and /usr/bin/startxfce4 exist?

Adam
 
Old 09-09-2009, 05:30 PM   #7
compul
Member
 
Registered: Aug 2009
Distribution: debian testing / slackware 13.0
Posts: 30

Original Poster
Rep: Reputation: 15
there is startxfce4 and startfluxbox

i did not install kde

goodnight (im from germany)

Last edited by compul; 09-09-2009 at 05:33 PM.
 
Old 09-09-2009, 05:54 PM   #8
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
As your user, try this:

$ echo "/usr/bin/startxfce4" > ~/.xinitrc

Then try starting X with:

$ startx

And see if X starts up with xfce4.
 
Old 09-09-2009, 10:12 PM   #9
el_b
Member
 
Registered: Apr 2009
Distribution: Slackware 13.0
Posts: 48

Rep: Reputation: 17
Maybe it's the graphics drivers!
It also happened to me, it's the nv driver at xorg.conf. I installed NVIDIA's propietary driver...

Last edited by el_b; 09-09-2009 at 10:13 PM.
 
Old 09-10-2009, 12:40 AM   #10
compul
Member
 
Registered: Aug 2009
Distribution: debian testing / slackware 13.0
Posts: 30

Original Poster
Rep: Reputation: 15
it starts with xcfe !

i think that should exclude the nvidia error for now?

can i just do the same with fluxbox ?

and then, when i am in flux, how to switch to xfce? when x is termined he just tells me couldnt connect to x and when its started it says no display cuz its directly started with flux (it was that way before i had my problem...)

lg
 
Old 09-10-2009, 03:40 AM   #11
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
To start fluxbox instead, put the line '/usr/bin/startfluxbox' in your ~/.xinitrc. TO switch between flubox and xfce4, you'll need to modify this file.

Adam
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Waiting For X server to shut down" Damn Small Linux, (e)JWM tombom62 DamnSmallLinux 1 05-04-2009 05:00 PM
x wont start on slackware berrance Linux - Laptop and Netbook 2 11-28-2004 11:31 AM
x wont start on slackware berrance Linux - Laptop and Netbook 2 11-28-2004 11:02 AM
slackware wont start xquizit Slackware 9 09-13-2004 11:57 AM
*error mess* Waiting for X Server to shut down Tasha v71 Linux - General 9 10-19-2001 09:45 PM


All times are GMT -5. The time now is 02:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration