LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-19-2007, 09:08 AM   #1
Slackovado
Member
 
Registered: Mar 2005
Location: Burnaby, BC, Canada
Distribution: Slackware 14 32bit, Debian, Arch
Posts: 213

Rep: Reputation: 27
Slackware 12 - wireless with 2200bg and wpa


I have Slackware 12 installed on my laptop (Tecra M2) and am trying to set up wireless.
The intel 2200bg wireless chip works fine.
My access point uses WPA so I understand that I have to use wpa_supplicant.
I got all that working from command line.
I start wpa_supplicant first with
wpa_supplicant -B -ieth1 -c/etc/wpa_supplicant.conf

I have the configuration for my AP entered in wpa_supplicant.conf and that part works fine now.
Next I just obtain an IP address with
dpcpcd eth1
That's it. I'm connected and networked.
Now, what I don't know is how do I automate it all?
I use rc.local to start wpa_supplicant for now
and then run dhcpcd from cli manualy.

KDE's wifi manager is useless as it doesn't work with wpa.
Any suggestions?
In particular, at point during boot and from where do I start the wpa_supplicant?

Thanks.
 
Old 07-19-2007, 11:34 AM   #2
randomsel
Member
 
Registered: Oct 2006
Location: Wilmington, DE
Distribution: Slackware 11
Posts: 201

Rep: Reputation: 30
might want to put all those commands together in a script, and run it from rc.local from background, that way the commands will work one after the other and won't slow down the bootup process.

I think rc.local is a fine place for placing those.
 
Old 07-19-2007, 12:08 PM   #3
etienne
Member
 
Registered: Jul 2007
Location: Belgium
Distribution: Slackware
Posts: 43

Rep: Reputation: 18
This is how I did it and works well for me :
  • Edit the file /etc/rc.d/rc.wireless.conf
    You have to put here the configuration of your wireless card.
    I have something like this :
    Code:
    *)
        INFO="My Network"
        ESSID="MyESSID"
        ;;
    The important thing here is the ESSID. If you need more option, the file is well documented.
  • Edit the file /etc/rc.d/rc.inet1.conf
    You set here the configuration for each of your network interface. If you use eth1 you should have something like this :
    Code:
    IPADDR[1]=""
    NETMASK[1]=""
    USE_DHCP[1]="yes"
    DHCP_HOSTNAME[1]=""
    WLAN_WPA[1]="wpa_supplicant"
    WLAN_WPADRIVER[1]="wext"
    USE_DHCP="yes" says that you get your IP address by DHCP.
    WLAN_WPA="wpa_supplicant" says that you use wpa_supplicant for authentification.
    WLAN_WPADRIVER="wext" is the WPA driver for Intel 2200BG.
    There are others configuration attributes but I don't use any of them (see the file itself for all possibilities).
  • Be sure that /etc/rc.d/rc.inet1 and /etc/rc.d/rc.wireless are "executables" and at the next boot your connexion will be automatically up
 
Old 07-19-2007, 04:53 PM   #4
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
Or you could just add a couple lines to your /etc/rc.local file as mentioned above:
Code:
iwconfig ath0 essid "YOUR_NETWORK"
ifconfig ath0 up
wpa_supplicant -iath0 -c/etc/wpa_supplicant.conf &
dhcpcd ath0
That's all I have and my laptop, using madwifi and the 'ath0' interface, starts just fine.
 
Old 07-19-2007, 05:30 PM   #5
Slackovado
Member
 
Registered: Mar 2005
Location: Burnaby, BC, Canada
Distribution: Slackware 14 32bit, Debian, Arch
Posts: 213

Original Poster
Rep: Reputation: 27
Thanks to all for your replies and help.
The rc.local solution is certainly an option but the downside is that any services that depend on a network interface being up and running will not function correctly.

So I like etienne's solution best and I think it's how Slackware meant for the network to be configured.
I will test it later today and see if it'll work for me.

Maybe suitable for a new thread, and if so let me know, but I'll ask anyway.
I've used wpa_gui for the first time and see that it has the ability to update wpa_supplicant.conf if run as root.
Is it something that would be useful when connecting to public wifi AP, or any AP outside of my regular network?
How do people with Slackware scan for wifi AP's? And subsequently connect to them?

Thanks again for your help.
 
Old 07-21-2007, 03:34 PM   #6
Slackovado
Member
 
Registered: Mar 2005
Location: Burnaby, BC, Canada
Distribution: Slackware 14 32bit, Debian, Arch
Posts: 213

Original Poster
Rep: Reputation: 27
Well, it's working great.
I followed etienne's advice and entered the settings there.
I did have wpa_supplicant.conf configured beforehand though.
The only thing I had to do is download and install the firmware.
Now when I boot, I'm automaticaly connected to my wireless AP.
However, dmesg doesn't show any info, ip, mac etc, like it used to for regular wired connection, but I can live with that.
Thanks all for your help.
 
Old 07-21-2007, 05:00 PM   #7
randomsel
Member
 
Registered: Oct 2006
Location: Wilmington, DE
Distribution: Slackware 11
Posts: 201

Rep: Reputation: 30
Wasn't it ifconfig and iwconfig that showed the ip/mac of the interface?
 
Old 07-22-2007, 03:20 AM   #8
windrose
LQ Newbie
 
Registered: May 2003
Posts: 9

Rep: Reputation: 0
I'd like to share my solution here which is to edit rc.wireless.conf. The original rc.wireless.conf after a clean installation is a case driven script. I think it too complicated for my need. So I just replace it with my own one:
Code:
    INFO="Intel ipw2200"
    # ESSID (extended network name)
    ESSID="mywifi"
    NWID=""
    # Operation mode : Ad-Hoc, Managed, Master, Repeater, Secondary, auto
    MODE="auto"
    # Frequency or channel : 1, 2, 3 (channel) ; 2.422G, 2.46G (frequency)
    FREQ=""
    CHANNEL="6"
    # Sensitivity (cell size + roaming speed) : 1, 2, 3 ; -70 (dBm)
    SENS=""
    # Bit rate : auto, 1M, 11M
    RATE=""
    # Encryption key : 4567-89AB-CD, s:password
    KEY=""
    # RTS threshold : off, 500
    RTS=""
    # Fragmentation threshold : off, 1000
    FRAG=""
    # Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
    IWCONFIG=""
    # iwspy parameters : + 01:23:45:67:89:AB
    IWSPY=""
    # iwpriv parameters : set_port 2, set_histo 50 60
    IWPRIV=""
    # WPA support, set KEY="" above
    WPA="wpa_supplicant"
    # wpa_supplicant driver
    WPADRIVER="wext"
 
  


Reply

Tags
intel, wireless, wpasupplicant


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
scripts (kommander and command line) to start wireless devices with wpa/wpa2/wpa-aes Fluxx Linux - Wireless Networking 4 06-28-2010 02:51 AM
Get WPA working on 2200bg in Slack 11 DrCurl Slackware 3 12-06-2006 01:19 PM
Intel Pro/Wireless 2200BG + WPA in Ubuntu frijolie Linux - Wireless Networking 1 11-30-2006 05:27 AM
Wireless (Intel PRO/Wireless 2200BG) network problems using FC5 kernel 2.6.17 TempleOwl1999 Linux - Laptop and Netbook 14 08-26-2006 02:57 AM
Strange problem with Slackware & Intel Pro/Wireless 2200BG TADsince1995 Linux - Wireless Networking 2 04-25-2005 07:01 PM


All times are GMT -5. The time now is 04:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration