LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 08-13-2007, 03:43 PM   #1
TL_CLD
Member
 
Registered: Sep 2006
Posts: 342

Rep: Reputation: 34
Slackware 12, Opera, slackbuilds.org


Using the slackbuild script here:

http://slackbuilds.org/repository/12.0/network/opera/

For some odd reason $opera -fullscreen wont work. Opera just opens up in "normal" mode.

Using F11 from within Opera works like a charm, so the basic fullscreen functionality seems to be working fine. It's just the CLI command that wont stick.

I have a Kubuntu and an OpenSuse box, and it works fine on those two. When issuing the $opera -fullscreen command, Opera opens up in fullscreen, as intended.

My Slackware 12 install is a complete install. Only thing I've done is changing the kernel from huge to generic.

Anybody else experiencing this issue? Is it a know problem with Slackware/Opera/the slackbuilds.org script, or is it perhaps just me being my usual unlucky self?

I hope someone can shed some light on this. I desperately need my -fullscreen option!

Sincerely,
Thomas
 
Old 08-14-2007, 04:32 AM   #2
Eternal_Newbie
Member
 
Registered: Jun 2005
Location: The Pudding Isles
Distribution: Slackware 13.37
Posts: 573

Rep: Reputation: 58
Works fine on my machine, same slackbuild. The slackbuild shouldn't be a much of factor anyway, as it just repackages the opera shared QT build as a Slackware package. IMHO, It is more likely to be an oddity of your X or window manager settings.
 
Old 08-14-2007, 05:46 AM   #3
TL_CLD
Member
 
Registered: Sep 2006
Posts: 342

Original Poster
Rep: Reputation: 34
Quote:
Originally Posted by Eternal_Newbie View Post
Works fine on my machine, same slackbuild. The slackbuild shouldn't be a much of factor anyway, as it just repackages the opera shared QT build as a Slackware package. IMHO, It is more likely to be an oddity of your X or window manager settings.
Ok, seeing as it works with F11 from within Opera, I can probably rule out issues with X right?

That leaves problems with window manager settings.

What could possibly have gone wrong? It's a clean Slackware 12 install, with no manual tweaking done to anything, except installing of software (nVidia driver, Krusader, Opera, Kompare and htop) and switching from huge to generic kernel.

Hmm, that's not entirely true come to think of it: I also changed my mouse settings in xorg.conf.

But besides that, nothing been done to the system. KDE is in pristine condition.

Any suggestions as to how I might be able to fix this very weird issue?

Sincerely,
Thomas
 
Old 08-14-2007, 09:48 AM   #4
erklaerbaer
Member
 
Registered: Mar 2006
Posts: 381

Rep: Reputation: 30
make an exception for kwin: right-click on the title bar -> advanced -> special application settings. there should be a "fullscreen" checkbox somewhere
 
Old 08-14-2007, 11:16 AM   #5
TL_CLD
Member
 
Registered: Sep 2006
Posts: 342

Original Poster
Rep: Reputation: 34
Quote:
Originally Posted by erklaerbaer View Post
make an exception for kwin: right-click on the title bar -> advanced -> special application settings. there should be a "fullscreen" checkbox somewhere
This wont do, as the fullscreen I'm looking for has nothing to do with KDE, and everything to do with Opera removing all of its toolbars (navigation, bookmarks and so on) from view.

This is all so very weird.


Thomas
 
Old 08-14-2007, 06:16 PM   #6
Eternal_Newbie
Member
 
Registered: Jun 2005
Location: The Pudding Isles
Distribution: Slackware 13.37
Posts: 573

Rep: Reputation: 58
I agree, it is wierd. I've checked with XFCE, KDE and fluxbox and Opera starts fine fullscreen with all of them in my case. Is this a new install of Opera or an upgrade? My Opera 9.22 was upgraded from 9.21, also packaged using a slackbuilds.org script.

PS: the only difference between the slackbuilds for the two was values for the VERSION and DATESTRING variables and the values in the opera.info files.
 
Old 08-15-2007, 03:44 AM   #7
TL_CLD
Member
 
Registered: Sep 2006
Posts: 342

Original Poster
Rep: Reputation: 34
Quote:
Originally Posted by Eternal_Newbie View Post
I agree, it is wierd. I've checked with XFCE, KDE and fluxbox and Opera starts fine fullscreen with all of them in my case. Is this a new install of Opera or an upgrade? My Opera 9.22 was upgraded from 9.21, also packaged using a slackbuilds.org script.

PS: the only difference between the slackbuilds for the two was values for the VERSION and DATESTRING variables and the values in the opera.info files.
This is a new install.

I guess I'll just have to wait for someone patching either Opera or Slackware, and hope it fixes this weird issue.


Thomas
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slim pkg from slackbuilds.org symatic Slackware 3 07-14-2007 02:53 PM
[slackbuilds.org] slackware repository idea arcanex Slackware 5 05-19-2007 09:19 PM
Use SlackBuilds.org or my own hosting to offer up SlackBuilds? hollywoodb Slackware 6 11-30-2006 08:56 PM
SlackBuilds.org Frozen Bubble not working... Lufbery Slackware 7 11-07-2006 01:54 PM
Opera problem with LQ.org -- ad placement sometimes goes awry vharishankar LQ Suggestions & Feedback 1 10-06-2006 01:30 PM


All times are GMT -5. The time now is 03:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration