LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 12, Opera, slackbuilds.org (http://www.linuxquestions.org/questions/slackware-14/slackware-12-opera-slackbuilds-org-576829/)

TL_CLD 08-13-2007 03:43 PM

Slackware 12, Opera, slackbuilds.org
 
Using the slackbuild script here:

http://slackbuilds.org/repository/12.0/network/opera/

For some odd reason $opera -fullscreen wont work. Opera just opens up in "normal" mode.

Using F11 from within Opera works like a charm, so the basic fullscreen functionality seems to be working fine. It's just the CLI command that wont stick.

I have a Kubuntu and an OpenSuse box, and it works fine on those two. When issuing the $opera -fullscreen command, Opera opens up in fullscreen, as intended.

My Slackware 12 install is a complete install. Only thing I've done is changing the kernel from huge to generic.

Anybody else experiencing this issue? Is it a know problem with Slackware/Opera/the slackbuilds.org script, or is it perhaps just me being my usual unlucky self? :)

I hope someone can shed some light on this. I desperately need my -fullscreen option!

Sincerely,
Thomas

Eternal_Newbie 08-14-2007 04:32 AM

Works fine on my machine, same slackbuild. The slackbuild shouldn't be a much of factor anyway, as it just repackages the opera shared QT build as a Slackware package. IMHO, It is more likely to be an oddity of your X or window manager settings.

TL_CLD 08-14-2007 05:46 AM

Quote:

Originally Posted by Eternal_Newbie (Post 2858294)
Works fine on my machine, same slackbuild. The slackbuild shouldn't be a much of factor anyway, as it just repackages the opera shared QT build as a Slackware package. IMHO, It is more likely to be an oddity of your X or window manager settings.

Ok, seeing as it works with F11 from within Opera, I can probably rule out issues with X right?

That leaves problems with window manager settings.

What could possibly have gone wrong? It's a clean Slackware 12 install, with no manual tweaking done to anything, except installing of software (nVidia driver, Krusader, Opera, Kompare and htop) and switching from huge to generic kernel.

Hmm, that's not entirely true come to think of it: I also changed my mouse settings in xorg.conf.

But besides that, nothing been done to the system. KDE is in pristine condition. :)

Any suggestions as to how I might be able to fix this very weird issue?

Sincerely,
Thomas

erklaerbaer 08-14-2007 09:48 AM

make an exception for kwin: right-click on the title bar -> advanced -> special application settings. there should be a "fullscreen" checkbox somewhere

TL_CLD 08-14-2007 11:16 AM

Quote:

Originally Posted by erklaerbaer (Post 2858538)
make an exception for kwin: right-click on the title bar -> advanced -> special application settings. there should be a "fullscreen" checkbox somewhere

This wont do, as the fullscreen I'm looking for has nothing to do with KDE, and everything to do with Opera removing all of its toolbars (navigation, bookmarks and so on) from view.

This is all so very weird.

:)
Thomas

Eternal_Newbie 08-14-2007 06:16 PM

I agree, it is wierd. I've checked with XFCE, KDE and fluxbox and Opera starts fine fullscreen with all of them in my case. Is this a new install of Opera or an upgrade? My Opera 9.22 was upgraded from 9.21, also packaged using a slackbuilds.org script.

PS: the only difference between the slackbuilds for the two was values for the VERSION and DATESTRING variables and the values in the opera.info files.

TL_CLD 08-15-2007 03:44 AM

Quote:

Originally Posted by Eternal_Newbie (Post 2859073)
I agree, it is wierd. I've checked with XFCE, KDE and fluxbox and Opera starts fine fullscreen with all of them in my case. Is this a new install of Opera or an upgrade? My Opera 9.22 was upgraded from 9.21, also packaged using a slackbuilds.org script.

PS: the only difference between the slackbuilds for the two was values for the VERSION and DATESTRING variables and the values in the opera.info files.

This is a new install.

I guess I'll just have to wait for someone patching either Opera or Slackware, and hope it fixes this weird issue.

:)
Thomas


All times are GMT -5. The time now is 06:59 PM.