LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   slackware 12 freeze on log out or switch to virtual terminal (http://www.linuxquestions.org/questions/slackware-14/slackware-12-freeze-on-log-out-or-switch-to-virtual-terminal-602100/)

kentish_lad 11-24-2007 10:48 AM

slackware 12 freeze on log out or switch to virtual terminal
 
Hi,
I'm a long time linux user and have recently installed slackware for the first time to see how it goes having tried many and particularly liking Debian and ubuntu but attracted to the simplicity and legendary solidness of slack. So far I have been impressed and had no probs getting the system configured including wireless / wpa, the docs are good and so are the tools so kudos to the slackware team.

My problem, I have a compaq nx9030 and have used a default install and am using the default kernel. On install I edited the inittab file to set runlevel 4 on boot to get a kdm login and kde desktop. all good so far, then I discovered logging out my user session caused a hang, black screen and no keyboard response very unusual and having to use a hard reset to get out of the problem. shutting down works fine. Trying to switch to a virtual console (ctrl alt f1-8) also causes the freeze.
I switched the default runlevel back to 3 in case this might help but I still have the same problem. I have also tried another wm and used 'startxfce' from the console but still have the freeze on logout.
I've been searching for a solution but it seems it's not a common problem, anybody have any ideas please?

TIA

Wayne.

onebuck 11-24-2007 12:14 PM

Hi,

Welcome to Slackware & LQ!
I'm wondering if using a generic kernel will help you out here.

You should read the CHANGES_AND_HINTS.TXT, RELEASE_NOTES and UPGRADE.TXT to get some helpful information. As PV states, you should try to use one of the smp kernels if possible.

Code:


excerpt from Slackware 12;

CHANGES_AND_HINTS.TXT;
It is recommended that you use one of the generic kernels (either the plain
  kernel-generic or kernel-generic-smp) for daily use.  For most systems,
  you should use the generic SMP kernel if it will run, even if your system
  is not SMP-capable.  Some newer hardware needs the local APIC enabled in
  the SMP kernel, and theoretically there should not be a performance penalty
  with using the SMP-capable kernel on a uniprocessor machine, as the SMP
  kernel tests for this and makes necessary adjustments.  Furthermore, the
  kernel sources shipped with Slackware 12.0 are configured for SMP usage,
  so you won't have to modify those to build external out-of-tree modules
  (such as NVidia or ATI proprietary drivers) if you use the SMP kernel.


How did you setup your 'X'? Setup using a frame buffer?

H_TeXMeX_H 11-24-2007 01:14 PM

Could you post what kind of video card you have and what driver you are using for it (in '/etc/X11/xorg.conf').

kentish_lad 11-24-2007 01:38 PM

Quote:

Originally Posted by onebuck (Post 2969434)
Hi,

Welcome to Slackware & LQ!
I'm wondering if using a generic kernel will help you out here.

How did you setup your 'X'? Setup using a frame buffer?

I believe it is a generic kernel, uname -a:
Linux darkstar 2.6.21.5-smp #2 SMP Tue Jun 19 14:58:11 CDT 2007 i686 Intel(R) Pentium(R) M processor 1.70GHz GenuineIntel GNU/Linux

my xorg.conf initially was using the vesa driver which I changed to the intel i810 as I have an onboard intel 82852/855GM chip,

During the install I chose to enable frame buffer console could this be the problem?

Code:

bash-3.1# cat /var/log/Xorg.0.log |grep -i fb
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
bash-3.1# cat /var/log/Xorg.0.log |grep -i framebuffer
(**) intel(0): Depth 24, (--) framebuffer bpp 32
(--) intel(0): Linear framebuffer at 0xE8000000

Thanks,

Wayne

H_TeXMeX_H 11-24-2007 01:46 PM

No, 'fb' should NOT be loaded, go to your '/etc/X11/xorg.conf' and remove the line containing it from the "Module" section. If that still doesn't fix it, post your 'xorg.conf'.

onebuck 11-24-2007 05:02 PM

Hi,

I agree with H, that is why I asked about the frame buffer. You should post the 'xorg.conf' for us to diagnose.

You are using the '2.6.21.5-smp' kernel.

kentish_lad 11-25-2007 03:10 PM

Thanks, I have tried removing the frame buffer settings and this did not help.
I then tried using a working xorg.conf file from debian on this same machine and still the same problem. I then set up the supplied generic kernel with an initrd image and this has cured the problem, strange as I would not have thought the kernel would affect the video to this affect anyway it's working now so thanks for the help.

Regards,
Wayne

blue900 10-16-2008 09:31 PM

problem solved
 
Made usable with posts above and some other googleing,
- Slackware 12.1, nvidia GeForce2 MX/MX 400 AGP card using Nvidia Driver
x86-96.43.07, Generic smp kernel.
X was hanging at logout with a black screen and an unblinking cursor at the top left of screen, keyboard frozen, required a hard shutdown at run level 4. I tracked it down to the Nvidia driver, worked fine without it at run level 4. It also worked fine with /etc/inittab at run level 3 with or with out the driver installed.
To get logged out without lockup in run level 4, I edited /etc/kde/kdm/kdmrc and added 'TerminateServer=true' under the heading [x-*-Core]to force kdm to restart X-server on logout. I just added it to the top of that section.
Now at Logout X is forced to restart and every thing is good and 3D works.

empcrono 10-16-2008 10:19 PM

Quote:

Originally Posted by blue900 (Post 3312882)
Made usable with posts above and some other googleing,
- Slackware 12.1, nvidia GeForce2 MX/MX 400 AGP card using Nvidia Driver
x86-96.43.07, Generic smp kernel.
X was hanging at logout with a black screen and an unblinking cursor at the top left of screen, keyboard frozen, required a hard shutdown at run level 4. I tracked it down to the Nvidia driver, worked fine without it at run level 4. It also worked fine with /etc/inittab at run level 3 with or with out the driver installed.
To get logged out without lockup in run level 4, I edited /etc/kde/kdm/kdmrc and added 'TerminateServer=true' under the heading [x-*-Core]to force kdm to restart X-server on logout. I just added it to the top of that section.
Now at Logout X is forced to restart and every thing is good and 3D works.


That is cool. Thanks for the help on that. I too was having trouble with this as well, in my case I traced it back to the driver which was also a Geforce 2 mx/mx 400 AGP. However this is additional help for the future.


All times are GMT -5. The time now is 09:08 PM.