LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-14-2007, 06:40 PM   #1
Coyote34
LQ Newbie
 
Registered: Oct 2007
Posts: 13

Rep: Reputation: 0
Thumbs down Slackware 12 and Mysql nohup problem


Hi, there!

I have installed Slackware 12 with LAMP. I have started my tables using mysqld_intall_db. But when I start mysql I have notice the following error:

nohup: ignoring input and redirecting stderr to stdout

I have noticed there is no /etc/my.cnf. So I have copied my-huge.cnf to /etc/my.cnf after the command mysql_install_db.

Do you have any ideas?

Last edited by Coyote34; 10-14-2007 at 06:42 PM.
 
Old 10-15-2007, 01:06 AM   #2
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
That's just a warning message, it doesn't mean it's running or not.
First check if it's running with:
Code:
ps -A | grep mysql
If it's not...
Did you run mysql_install_db as mysql user? You can easily check that by checking database directory owner:
Code:
ls -l /var/lib/mysql
If it's not owned by mysql user, execute
Code:
chown -R mysql.mysql /var/lib/mysql
By the way, that procedure is explained in /etc/rc.d/rc.mysqld, remember to execute mysql using that file instead of manually running mysqld.

Another problem you may be having is that you're trying to connect using a network connection, you need to comment the SKIP line at /etc/rc.d/rc.mysqld in order to allow that.

Last edited by gbonvehi; 10-15-2007 at 01:33 AM.
 
Old 10-15-2007, 03:02 AM   #3
tamtam
Member
 
Registered: May 2004
Distribution: Slackware.
Posts: 314

Rep: Reputation: 30
As gbonvehi says, have a look at rc.mysqld in /etc/rc.d/. All is explained there in.

Quote:
#!/bin/sh
# Start/stop/restart mysqld.
#
# Copyright 2003 Patrick J. Volkerding, Concord, CA
# Copyright 2003 Slackware Linux, Inc., Concord, CA
#
# This program comes with NO WARRANTY, to the extent permitted by law.
# You may redistribute copies of this program under the terms of the
# GNU General Public License.

# To start MySQL automatically at boot, be sure this script is executable:
# chmod 755 /etc/rc.d/rc.mysqld

# Before you can run MySQL, you must have a database. To install an initial
# database, do this as root:
#
# su - mysql
# mysql_install_db
#
# Note that step one is becoming the mysql user. It's important to do this
# before making any changes to the database, or mysqld won't be able to write
# to it later (this can be fixed with 'chown -R mysql.mysql /var/lib/mysql').

# To allow outside connections to the database comment out the next line.
# If you don't need incoming network connections, then leave the line
# uncommented to improve system security.
#SKIP="--skip-networking"
You will notice that the line...
SKIP="--skip-networking"
is commented out above.

at the terminal as root open up pico
# pico /etc/rc.d/rc.mysqld

edit the file by placing a # before the said line.
Ctrl + x to close making sure you say yes to saving the file.
 
Old 10-16-2007, 02:51 PM   #4
Coyote34
LQ Newbie
 
Registered: Oct 2007
Posts: 13

Original Poster
Rep: Reputation: 0
Hi!!!!

I have done everything suggested in the posts:

- chown mysql.mysql
- Skip-networking

In fact, mysql starts but always showing the message:

nohup: ignoring input and redirecting stderr to stdout

But mysql is very slow.
 
Old 10-18-2007, 03:11 AM   #5
tamtam
Member
 
Registered: May 2004
Distribution: Slackware.
Posts: 314

Rep: Reputation: 30
This maybe because you created the databases previously and never recreated them before trying mysql again.

Retrace your steps.
Sounds to me as though mysql is already running.
If you changed permissions on rc.mysqld to start at reboot then it will start everytime you boot your machine.
You will have to stop the running instance of mysql.
As root.
Quote:

/etc/rc.mysqld stop
Remain as root...
make sure Skip-networking is commented out before hand.
Recreate your databases...should destroy current databases and create new ones, will also destroy any previous accounts including passwords. It will also recreate the root acount but blow away the password you previously set.
Quote:
su - mysql
mysql_install_db
Now restart mysql
Quote:
/etc/rc.d/rc.mysqld start
Now try this...no password should be required...
Quote:
$ mysql -u root
If mysql starts okay - you should get the prompt
Quote:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 9
Server version: 5.0.37 Source distribution

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql>
Try to connect to the mysql database...and some query.
Quote:
mysql> use mysql;
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
mysql> show tables;
+---------------------------+
| Tables_in_mysql |
+---------------------------+
| columns_priv |
| db |
| func |
| help_category |
| help_keyword |
| help_relation |
| help_topic |
| host |
| proc |
| procs_priv |
| tables_priv |
| time_zone |
| time_zone_leap_second |
| time_zone_name |
| time_zone_transition |
| time_zone_transition_type |
| user |
+---------------------------+
17 rows in set (0.00 sec)

mysql> select user from user;
+------+
| user |
+------+
| |
| root |
| |
| root |
+------+
4 rows in set (0.00 sec)

mysql>
If all goes well your in...
Think about setting a password for root now.

Hope this helps...if not let us know.
 
Old 10-18-2007, 01:44 PM   #6
Coyote34
LQ Newbie
 
Registered: Oct 2007
Posts: 13

Original Poster
Rep: Reputation: 0
nohup: redirecting stderr to stdout

Tamtam, thanks a lot. Mysql is working, but I still seeing the message nohup: redirecting stderr to stdout every time I start mysql.

My installation is using the kernel vmlinuz-huge-2.6.21.5.

Bye
 
Old 10-18-2007, 02:56 PM   #7
Carpo
Member
 
Registered: Aug 2003
Location: Somewhere
Distribution: Gentoo (for now)
Posts: 364

Rep: Reputation: 30
its not an issue, it did that to me on .37 and the .45 mysql package i made, and all runs fine, i have gallery2 and vcddb running fine and rather fast, even phpmyadmin works fine
 
Old 10-18-2007, 03:57 PM   #8
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Coyote, that's just a warning message, mysql will run fine. If you want to avoid seeing it, you can redirect the messages to a log file or just to /dev/null.
If you want that, edit /etc/rc.d/rc.mysqld and change the line:
Code:
/usr/bin/mysqld_safe --datadir=/var/lib/mysql --pid-file=/var/run/mysql/mysql.pid $SKIP &
to
Code:
/usr/bin/mysqld_safe --datadir=/var/lib/mysql --pid-file=/var/run/mysql/mysql.pid $SKIP 1> /dev/null 2> /dev/null &
or
Code:
/usr/bin/mysqld_safe --datadir=/var/lib/mysql --pid-file=/var/run/mysql/mysql.pid $SKIP 1> /some/file 2> /some/file &
I don't recommend you to redirect output to /dev/null since you won't be able to see if something is wrong directly in console.
 
Old 10-19-2007, 02:04 PM   #9
tamtam
Member
 
Registered: May 2004
Distribution: Slackware.
Posts: 314

Rep: Reputation: 30
Hi Coyote34, glad you got it working.

I also see the nohup: redirecting stderr to stdout message.

Nothing to worry about, and I would rather see error messages on stdout the console, anyways.
 
Old 10-28-2007, 09:25 PM   #10
FreakboY
Member
 
Registered: Jun 2002
Location: TX, USA
Distribution: Slackware 13 64bits
Posts: 374

Rep: Reputation: 31
make sure your directories have mysql permissions on it...

chown -R mysql:mysql /var/lib/mysql/
and
chown -R mysql:mysql /var/run/mysql/
 
Old 03-15-2008, 03:15 AM   #11
hottdogg
Member
 
Registered: Aug 2004
Location: aisenodni
Distribution: slackware 64bit ,debian 64bit
Posts: 202

Rep: Reputation: 30
Quote:
Originally Posted by tamtam View Post
If all goes well your in...
Think about setting a password for root now.
How?

Code:
mysql@aquarius:~$ passwd mysql
Changing password for mysql
Old password:
it asks old password. AFAICR, I've never set mysql root password before.
This is my first time to run mysql.

Sorry for the dumb question.
 
Old 03-15-2008, 04:46 AM   #12
tamtam
Member
 
Registered: May 2004
Distribution: Slackware.
Posts: 314

Rep: Reputation: 30
Have a look at

http://www.cyberciti.biz/faq/setup-m...ount-password/

explains it all really
 
  


Reply

Tags
sql


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
To use or not to use nohup entz Linux - Server 9 04-07-2007 04:52 PM
Slackware 11 + MySQL 5 boot problem Unknownlq Slackware 7 10-28-2006 05:59 PM
problem with nohup command and nohup file size vbseeker Linux - General 1 09-17-2006 11:36 AM
nohup & bittorrent-console problem txm123 Linux - Newbie 2 02-25-2006 07:31 AM
Slackware 10.1 and MySql Problem? bullium Linux - Networking 3 04-07-2005 10:46 AM


All times are GMT -5. The time now is 01:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration