LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 12.2 internet connection via WiFi problems (http://www.linuxquestions.org/questions/slackware-14/slackware-12-2-internet-connection-via-wifi-problems-693424/)

legeipsnelU 12-28-2008 07:23 AM

Slackware 12.2 internet connection via WiFi problems
 
Hi guys.
Can somebody, please, help me? I'm trying to set up the internet connection from this distro for a week without any results. Network: my host is connected to the router via WiFi, router is connected to a DSL modem from ISP.

From Ubuntu 8.10 Live(where connection works and is set up automatically) I get the values of my host IP, gateway IP, DNS IP. They all have the same values 192.168.0.1. I set them in Slackware 12.2 either by using netconfig or manually by editing "rc.inet1.conf" and "resolv.conf". Still I have no connection. Firefox says "unknown host", ping says nothing.

I also tried to use DHCP by dhcpcd wlan0, but it just does broadcasting without any results.

My WLAN card is Intel WiFi Link 5100. I can see from the lspci in Sackware. I get connected to the wireless network by using kWiFiNetwork. To be sure I use iwconfig in Slackware and see that I'm really connected since it shows me the access point, signal strength, network name etc. Slackware 12.2 uses the same 2.6.27 kernel as Ubuntu 8.10(where I can use internet), so I guess the hardware part and drivers work.


Please help.

Didier Spaier 12-28-2008 07:44 AM

Don't you need an encryption key (WEP or WPA) ?

- if that is the case, you should edit your /etc/rc.d/rc.inet1.conf accordingly (and /etc/wpa_supplicant if it's WPA)
- otherwise try as root:
dhcpcd <your_wireless_interface_name>

I make the assumption that you have a dhpc server -- if not the dhcpcd command is not relevant, of course.

And please send the outputs of "ifconfig -a", "iwconfig" and "iwlist scan" (in the latter case, only the relevant cell(s) if there are many).

[EDIT] If not already done I suggest you read this article from AlienBob:
http://alien.slackbook.org/dokuwiki/...ckware:network

legeipsnelU 12-28-2008 09:38 AM

Quote:

Don't you need an encryption key (WEP or WPA)?
After activating the interface I use kWiFiManager to scan for avaliable wireless networks. After it lists the networks I select the one I need and enter the key in WEP field. Then I press "Switch to Network" and I get connected. It's just a GUI.
Quote:

I make the assumption that you have a dhpc server -- if not the dhcpcd command is not relevant, of course.
I suppose that DHCP is enabled on the router. Since my Ubuntu 8.10 Live gets host IP, gateway, DNS automatically set after login without any configuration from my side. However in my Slackware 12.2 it doesn't work. After connecting to the network with kWiFiManager I use "dhcpcd wlan0" and it just stucks broadcasting DHCP_DISCOVER until I press CTRL+C. The same happens after reboot if I use netconfig to set DHCP option. It writes "broadcasting DHCP_DISCOVER" and after some time says "timout while ...". Then it proceeds with loading the OS. Howcome?
Quote:

And please send the outputs of "ifconfig -a", "iwconfig" and "iwlist scan" (in the latter case, only the relevant cell(s) if there are many).
Quote:

root@MyHost:~# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:03:0d:a1:cf:8a
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:19 Base address:0xc000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:308 (308.0 B) TX bytes:308 (308.0 B)

wlan0 Link encap:Ethernet HWaddr 00:16:ea:a3:b3:a2
inet6 addr: fe80::216:eaff:fea3:b3a2/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:19 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:1844 (1.8 KiB)

wmaster0 Link encap:UNSPEC HWaddr 00-16-EA-A3-B3-A2-77-6C-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Quote:

root@MyHost: iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11abgn ESSID:"jonas101"
Mode:Managed Frequency:2.412 GHz Access Point: 00:21:91:33:FF:0F
Bit Rate=48 Mb/s Tx-Power=15 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:696C-3166-3433-6132-3030-3030-30 Security mode:open
Power Management:off
Link Quality=100/100 Signal level:-77 dBm Noise level=-127 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
Quote:

root@MyHost: iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wmaster0 Interface doesn't support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:21:91:33:FF:0F
ESSID:"jonas101"
Mode:Master
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=52/100 Signal level:-77 dBm Noise level=-127 dBm
Encryption key:on
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=0000000637172acd
Extra: Last beacon: 2488ms ago
Quote:

If not already done I suggest you read this article from
Thank you I'll start right now.

Didier Spaier 12-28-2008 10:34 AM

Thus, as long as you stay at reachable distance from "jonas 101":

- Edit your /etc/rc.d/rc.inet1.conf so it includes:
USEDHCP[4]="yes" (just uncomment that line, IFNAME[4] will do)
IFNAME[4]="wlan0" (idem)
WLAN_WPA[4]="wpa_supplicant" (idem)
WLAN_ESSID[4]="jonas 101" (This is your essid, I guess. Uncomment that line too)

- As you need WPA, edit your /etc/wpa_supplicant.conf so it includes:
ssid="jonas 101"
proto=WPA
key_mgmt=WPA-PSK
pairwise=CCMP TKIP
group=CCMP TKIP WEP104 WEP40
psk="Your_WPA_Key_Here"

For more info, see the file :
/usr/doc/wpa_supplicant-0.5.10/wpa_supplicant.conf.sample

Now, make sure following files be both executables (or chmod +x <file_name>) :
/etc/rc.d/rc.inet1
/etc/rc.d/rc.wireless

Now reboot : you should get the wireless connection at boot time.

PS1: Don't use kwifimanager, it is useless with Slackware
PS2: Don't bother yourself with /etc/rc.d/rc.wireless.conf : you don't need to edit anything in it.

onebuck 12-28-2008 11:49 AM

Hi,m

You should look at 'Configuring your network in Slackware'.

This link and others are available from 'Slackware-Links'. More than just SlackwareŽ links!

legeipsnelU 12-28-2008 03:18 PM

Still doesn't work. I'v done all you've said. While loading OS it writes(that error was before also): error for wireless request "SET Nickname" Set failed on device wlan0. Operation not supported. Then it stops, like doing something(writes nothing). Then suddenly the same scenario: broadcasting DHCP_DISCOVER. Then "timeout while ...". Then proceed loading the OS.

GlenDobbs 12-28-2008 04:08 PM

Slackware wireless connection problem
 
Quote:

Originally Posted by legeipsnelU (Post 3389709)
Still doesn't work. I'v done all you've said. While loading OS it writes(that error was before also): error for wireless request "SET Nickname" Set failed on device wlan0. Operation not supported. Then it stops, like doing something(writes nothing). Then suddenly the same scenario: broadcasting DHCP_DISCOVER. Then "timeout while ...". Then proceed loading the OS.

If you have setup /etc/rc.d/rc.inet1.conf properly you shouldn't see the "Set Nickname" stuff unless your system is trying to connect to an unencrypted AP, but you can check that when you come up with ifconfig. If it has tried to connect to an unencrypted AP, you will see the wrong AP in the ifconfig output and possibly a wrong ip address. There are two things you need to check when the system has booted, iwconfig to see if you are connected to the right AP and ifconfig to see if wlan0 is up with the right dhcp address stuff. If the wlan0 interface isn't up, no amount of trying to get an address will work.

clw54 12-28-2008 06:14 PM

I went through the same thing a couple days ago and finally got it to work. Didn't take many changes to do it, but figuring out the changes was tricky.

In /etc/wpa_supplicant.conf I did this:

ssid="YOURACCESSPOINT"
psk=5k5k39c9dfk4... (whatever your key is)



In /etc/rc.d/rc.inet1.conf I did this to the wlan0 section:

IFNAME[4]="wlan0"
USE_DHCP[4]="yes"
WLAN_ESSID[4]=YOURACCESSPOINT
WLAN_WPA[4]="wpa_supplicant"
WLAN_WPADRIVER[4]='wext"


Then /etc/rc.d/rc.inet1 restart


You can get that long hex key and store it in a file named key by doing this:

wpa_passphrase YOURACCESSPOINT password > key


This is all it took. I left everything else in those two files intact. Good luck.

Foress_89 12-29-2008 12:01 AM

I'm having the exact same problem. I set up Slackware 12.2 yesterday, everything looks like it's working fine except the wireless internet. If I plug the ethernet cable in, it works just fine, but as soon as I unplug it, it stops. (that implies that I go into Network settings to enable/disable wireless/wired) I set up my wireless with KwifiManager with the hex password and everything, but still not working. But the thing is, I do connect to the network, since I can go in the router options... I just can't get to the internet... I even get an IP... I tried it with two differents network, mine and my friend's... So I don't know what to do I tried to modify the two files in /etc but nothing else happens... I really don't know what to do. It's my first wireless experience with linux.

onebuck 12-29-2008 06:11 AM

Hi,

You should look at 'Configuring your network in Slackware'.

What files did you modify in '/etc'? You should make your system changes from the 'cli' instead of your desktop. If you make changes system wide as root then you can restart the 'inet' from the 'cli' by; '/etc/rc.d/rc.inet1 restart'.

This link and others are available from 'Slackware-Links'. More than just SlackwareŽ links!

grissiom 12-29-2008 06:24 AM

As you are using 12.2, I recommand you try wicd in testing/. It can automatically probe wireless network as well as wired ones. Remember to edit /etc/rc.d/rc.inet1.conf according to http://ftp.linux.cz/pub/linux/slackw...ADME.SLACKWARE . This small tool can help you a lot. ;)

legeipsnelU 12-30-2008 08:02 AM

Here are the files. With this configuration it does the following. On executing rc.inet1 during boot it gets stuck for a minute then writes "broadcasting DHCP_DISCOVER", then after some time it writes "timeout while waiting for valid DHCP response". Still no connection...

rc.inet1.conf
Code:

# /etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# You can configure network interfaces other than eth0,eth1... by setting
# IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
# or empty, it is assumed you're configuring eth<interface>.

# Several other parameters are available, the end of this file contains a
# comprehensive set of examples.

# =============================================================================

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

## Example config information for wlan0.  Uncomment the lines you need and fill
## in your info.  (You may not need all of these for your wireless network)
IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
#WLAN_ESSID[4]=BARRIER05
#WLAN_MODE[4]=Managed
##WLAN_RATE[4]="54M auto"
##WLAN_CHANNEL[4]="auto"
##WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
##WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="wext"

## Some examples of additional network parameters that you can use.
## Config information for wlan0:
#IFNAME[4]="wlan0"              # Use a different interface name nstead of
                                # the default 'eth4'
#HWADDR[4]="00:01:23:45:67:89"  # Overrule the card's hardware MAC address
#MTU[4]=""                      # The default MTU is 1500, but you might need
                                # 1360 when you use NAT'ed IPSec traffic.
#DHCP_KEEPRESOLV[4]="yes"      # If you dont want /etc/resolv.conf overwritten
#DHCP_KEEPNTP[4]="yes"          # If you don't want ntp.conf overwritten
#DHCP_KEEPGW[4]="yes"          # If you don't want the DHCP server to change
                                # your default gateway
#DHCP_IPADDR[4]=""              # Request a specific IP address from the DHCP
                                # server
WLAN_ESSID[4]=jonas101          # Here, you can override _any_ parameter
                                # defined in rc.wireless.conf, by prepending
                                # 'WLAN_' to the parameter's name. Useful for
                                # those with multiple wireless interfaces.
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=thekey"
                                # Some drivers require a private ioctl to be
                                # set through the iwpriv command. If more than
                                # one is required, you can place them in the
                                # IWPRIV parameter (separated with the pipe (|)
                                # character, see the example).


wpa_supplicant.conf
Code:

# See /usr/doc/wpa_supplicant-0.5.10/wpa_supplicant.conf.sample
# for many more options that you can use in this file.

# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

# WPA protected network, supply your own ESSID and WPAPSK here:
network={
  scan_ssid=0
  ssid="jonas101"
  proto=WPA
  key_mgmt=WPA-PSK
  pairwise=CCMP TKIP
  group=CCMP TKIP WEP104 WEP40
  psk="xxxxxxxx"
}

# Plaintext connection (no WPA, no IEEE 802.1X),
# nice for hotel/airport types of WiFi network.
network={
  key_mgmt=NONE
  priority=0
}


rc.wireless.conf
Code:

# Wireless LAN adapter configuration
#
# Theory of operation :
#
# The script attempts to match a block of settings to the specific wireless
# card inserted, the *first* block matching the card is used.
# The address format is "hwaddr", with * as a wildcard.
# 'hwaddr' is the unique MAC address identifier of the wireless card.
# The MAC address is usually printed on the card, or can be found via ifconfig.
# Some examples here use only half of the MAC address with a wildcard to
# match a whole family of cards...
#
# All the Wireless specific configuration is done through the Wireless
# Extensions, so we will just call 'iwconfig' with the right parameters
# defined below.
# Of course, you need to have iwconfig installled on your system.
# To download iwconfig, or for more info on Wireless Extensions :
#      http://www.hpl.hp.com/personal/Jean_...nux/Tools.html
#
# Note : you don't need to fill all parameters, leave them blank, in most
# cases the driver will initialise itself with sane defaults values or
# automatically figure out the value... And no drivers do support all
# possible settings...
#
# -- This is a modified '/etc/pcmcia/wireless.opts' script --
# -- I added sections for Prism/GT and Atheros based cards --
# --    (supported by the prism54 and madwifi drivers)    --
# --              16/sep/2004 * Eric Hameleers            --
#

VERBOSE=1

case "$HWADDR" in

## NOTE : Comment out the following five lines to activate the samples below ...
## --------- START SECTION TO REMOVE -----------
## Pick up any Access Point, should work on most 802.11 cards
*)
    INFO="Any ESSID"
    ESSID="any"
    ;;
## ---------- END SECTION TO REMOVE ------------


# Here are a few examples with a few Wireless LANs supported...
# The matching is done on the first 3 bytes of the MAC address

# SMC2835W EZ Connect g 2.4GHz 54 Mbps Wireless Cardbus Adapter
00:04:E2:*)
    INFO="SMC2835W EZ Connect g 2.4GHz 54 Mbps Wireless Cardbus Adapter"
    # ESSID (extended network name) : My Network, any
    ESSID="any"
    # NWID/Domain (cell identifier) : 89AB, 100, off
    NWID=""
    # Operation mode : Ad-Hoc, Managed, Master, Repeater, Secondary, auto
    MODE="Managed"
    # Frequency or channel : 1, 2, 3 (channel) ; 2.422G, 2.46G (frequency)
    FREQ=""
    CHANNEL="7"
    # Sensitivity (cell size + roaming speed) : 1, 2, 3 ; -70 (dBm)
    SENS=""
    # Bit rate : auto, 1M, 11M,54M
    RATE="auto"
    # Encryption key : 4567-89AB-CD, s:password
    # Example for 40-bit encryption:
    #KEY="883e-aa67-21 [1] key 5501-d0da-87 [2] key 91f5-3368-6b [3] key 2d73-31b7-96 [4]"
    # Example for 104-bit encryption (aka 128-bit WEP):
    #KEY="d5ad2f05abd048ecf10b1c80c7"
    KEY=""
    # RTS threshold : off, 500
    RTS=""
    # Fragmentation threshold : off, 1000
    FRAG=""
    # Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
    IWCONFIG=""
    # iwspy parameters : + 01:23:45:67:89:AB
    IWSPY=""
    # iwpriv parameters : set_port 2, set_histo 50 60
    IWPRIV=""
;;

# Multiband Atheros based 802.11a/b/g universal NIC cards
00:05:4E:*)
    INFO="Multiband Atheros based 802.11a/b/g universal NIC"
    # ESSID (extended network name) : My Network, any
    ESSID=""
    # Operation mode : Ad-Hoc, Managed, Master, Repeater, Secondary, auto
    MODE="Managed"
    # Frequency or channel : 1, 2, 3 (channel) ; 2.422G, 2.46G (frequency)
    FREQ=""
    CHANNEL="7"
    # Bit rate : auto, 1M, 11M,54M
    RATE="auto"
    # Encryption key : 4567-89AB-CD, s:password
    # Example for 40-bit encryption:
    #KEY="883e-aa67-21 [1] key 5501-d0da-87 [2] key 91f5-3368-6b [3] key 2d73-31b7-96 [4]"
    # Example for 104-bit encryption (aka 128-bit WEP):
    #KEY="d5ad2f05abd048ecf10b1c80c7"
    KEY=""
    # Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
    IWCONFIG=""
    # iwspy parameters : + 01:23:45:67:89:AB
    IWSPY=""
    # iwpriv parameters : set_port 2, set_histo 50 60
    IWPRIV=""
    ;;

# Lucent Wavelan IEEE (+ Orinoco, RoamAbout and ELSA)
# Note : wvlan_cs driver only, and version 1.0.4+ for encryption support
00:60:1D:*|00:02:2D:*)
    INFO="Wavelan IEEE example (Lucent default settings)"
    ESSID="Wavelan Network"
    MODE="Managed"
    #RATE="auto"
    KEY="s:secu1"
    # To set all four keys, use :
    #KEY="s:secu1 [1] key s:secu2 [2] key s:secu3 [3] key s:secu4 [4] key [1]"
    # For the RG 1000 Residential Gateway: The ESSID is the identifier on
    # the unit, and the default key is the last 5 digits of the same.
    #ESSID="084d70"
    #KEY="s:84d70"
    ;;

# Cisco/Aironet 4800/3x0
# Note : MPL driver only (airo/airo_cs), version 1.3 or later
00:40:96:*|00:02:8A:*)
    INFO="Cisco/Aironet example (Cisco default settings)"
    ESSID="any"
    # To set all four ESSID, use iwconfig v21 and the same trick as above
    MODE="Managed"
    #RATE="11M auto"
    #KEY="d5ad2f05abd048ecf10b1c80c7"
    KEY="off"
    ;;

# Samsung MagicLan (+ some other PrismII cards)
# Note : Samsung binary library driver, version 1.20 or later
00:00:F0:*|00:02:78:*)
    INFO="Samsung MagicLan example (Samsung default settings)"
    ESSID="any"
    MODE="Managed"
    CHANNEL="4"
    RATE="auto"
    #KEY="883e-aa67-21 [1] key 5501-d0da-87 [2] key 91f5-3368-6b [3] key 2d73-31b7-96 [4]"
    #IWCONFIG="power on"
    ;;

# Raytheon Raylink/WebGear Aviator2.4
# Note : doesn't work yet, please use for debugging only :-(
00:00:8F:*|00:00:F1:*)
    INFO="Raylink/Aviator2.4 example (Aviator default ad-hoc setting)"
    ESSID="ADHOC_ESSID"
    MODE="Ad-Hoc"
    RATE="auto"
    IWPRIV="set_framing 1"
    ;;

# Old Lucent Wavelan
08:00:0E:*)
    INFO="Wavelan example (Lucent default settings)"
    NWID="0100"
    MODE="Ad-Hoc"
    FREQ="2.425G"
    KEY="off"
    ;;

# Netwave (Xircom Netwave/Netwave Airsurfer)
00:80:C7:*)
    INFO="Netwave example (Netwave default settings)"
    NWID="100"
    KEY="00"
    ;;

# Proxim RangeLan2/Symphony (what is the MAC address ???)
XX:XX:XX:*)
    INFO="Proxim RangeLan2/Symphony example"
    NWID="0"
    MODE="Master"
    CHANNEL="15"
    IWPRIV="setsubchan 1"
    ;;

# No Wires Needed Swallow 550 and 1100 setting (what is the MAC address ???)
XX:XX:XX:*)
    INFO="NWN Swallow example"
    ESSID="session"
    KEY="0000-0000-00 open"
    ;;

# Symbol Spectrum24 setting (what is the MAC address ???)
XX:XX:XX:*)
    INFO="Symbol Spectrum24 example"
    ESSID="Essid string"
    ;;

# Generic example (decribe all possible settings)
*)
    INFO="Fill with your own settings..."
    # ESSID (extended network name) : My Network, any
    ESSID=""
    # NWID/Domain (cell identifier) : 89AB, 100, off
    NWID=""
    # Operation mode : Ad-Hoc, Managed, Master, Repeater, Secondary, auto
    MODE=""
    # Frequency or channel : 1, 2, 3 (channel) ; 2.422G, 2.46G (frequency)
    FREQ=""
    CHANNEL=""
    # Sensitivity (cell size + roaming speed) : 1, 2, 3 ; -70 (dBm)
    SENS=""
    # Bit rate : auto, 1M, 11M
    RATE=""
    # Encryption key : 4567-89AB-CD, s:password
    KEY=""
    # RTS threshold : off, 500
    RTS=""
    # Fragmentation threshold : off, 1000
    FRAG=""
    # Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
    IWCONFIG=""
    # iwspy parameters : + 01:23:45:67:89:AB
    IWSPY=""
    # iwpriv parameters : set_port 2, set_histo 50 60
    IWPRIV=""
    ;;
esac


clw54 12-30-2008 08:24 AM

I didn't touch rc.wireless.conf to get mine to work.

Try uncommenting out this in rc.inet1.conf.

WLAN_WPADRIVER[4]="wext"

I showed exactly what I did to get mine to work and it worked on two different machines, including the one I'm posting from.

legeipsnelU 12-30-2008 09:18 AM

Zero result.

PS. I also didn't touch that file. I posted it to show its contents.

Didier Spaier 12-30-2008 10:05 AM

But first make sure /etc/rc.d/rc.wireless is executable:
Code:

bash-3.1$ ls -l /etc/rc.d/rc.wireless
-rwxr-xr-x 1 root root 12283 2008-04-23 22:50 /etc/rc.d/rc.wireless
bash-3.1$

If not it won't work because wpa_supplicant won't be called at all. (I had this problem: I thought I didn't need rc.wireless be executable because I don't need anything in rc.wireless.conf; but that's wrong).

In that case make it executable in typing (as root):
chmod +x /etc/rc.d/rc.wireless

and then try again:
/etc/rc.d/rc.inet1 restart

If you don't succeed, try commenting these lines in wpa_supplicant.conf:
Code:

network={
  key_mgmt=NONE
  priority=0
}

but I'm not at all sure this will help as if I understand (man wpa_supplicant.conf) in case of several networks wpa_supplicant tries the first one it finds in the configuration file.


All times are GMT -5. The time now is 11:30 AM.