LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 12.2 GUI Problems (http://www.linuxquestions.org/questions/slackware-14/slackware-12-2-gui-problems-764785/)

IcE-ColD 10-27-2009 08:35 AM

Slackware 12.2 GUI Problems
 
I have just successfully installed Slackware 12.2. I loggen on and typed the command "startx" to start the user interface. But once the user interface has started everything goes black with a few colours here or there. I can still use the user interface but it is very hard to read or do anything. I think this is a VGA driver fault but I can't find a solution to it. I'm using an ATI Radeon 4870 GPU and the only drivers ATI provide are for Ubuntu and Redhat.

Any help would be appreciated.

Thanks

w1k0 10-27-2009 11:27 AM

I encountered similar problems with Slackware 12.1 and ATI Radeon X1300. I solved it using fglrx proprietary driver. The new version of driver for ATI Radeon series 7800 is here. Try it.

AuroraZero 10-27-2009 03:13 PM

You can also type xconf at the command prompt before you type startx. It might be able to set up the screen automatically for you to at least get to the desktop. Then install the ATI driver as suggested.

adamk75 10-28-2009 04:08 AM

Quote:

Originally Posted by IcE-ColD (Post 3734086)
I have just successfully installed Slackware 12.2. I loggen on and typed the command "startx" to start the user interface. But once the user interface has started everything goes black with a few colours here or there. I can still use the user interface but it is very hard to read or do anything. I think this is a VGA driver fault but I can't find a solution to it. I'm using an ATI Radeon 4870 GPU and the only drivers ATI provide are for Ubuntu and Redhat.

That just is not correct at all. They provide a generic installer that can be run on pretty much any distribution. Having said that, the driver does require a custom kernel on Slackware 12.2 (though not on Slackware 13.0) either with MSI support, as I recall.

Adam

uppman 10-28-2009 04:31 AM

I have made a small utility called switch-driver.sh which can install proprietary nvidia and ati drivers.
It is more or less a wrapper for the slackbuilds found at slackbuilds.org.

You use it like this:

switch-driver.sh --driver ati
switch-driver.sh --driver nvidia
switch-driver.sh --driver vesa

Download here:

http://linuxconfig.dyndns.org/linuxf...6.27.7_smp.tgz

Good luck!

/Magnus

NightSky 10-28-2009 03:28 PM

What are your PC Hardware Specs? What media did u use to install 12.2? Did u download iso then burn them and then installed? After my 3rd reinstall, i was able to startx without configuring /etc/X11/xorg.conf -this is first time a fresh install of slackware did not work out of the box for me.

I just quickly googled your card: ATI Radeon 4870 is it a HD card? Why not just install slackware13 if your are using the newest hardware out there? Google show people expressing success with slackware13

U can just make sure your resolution settings in Monitor section are set properly determined by your monitor specs. Follow the same format for what is in there and change them.

Also u can put in your the actual ram u have on your card.

You don't say if u know howto do this? Please let us know. I am certain you can get slackware to work for you.

IcE-ColD 10-29-2009 06:24 AM

Quote:

Originally Posted by w1k0 (Post 3734240)
I encountered similar problems with Slackware 12.1 and ATI Radeon X1300. I solved it using fglrx proprietary driver. The new version of driver for ATI Radeon series 7800 is here. Try it.

I have already tried these drivers with no success. An error is reported about a corrupt file but i can't quiet read it because of the funny colours.

I am a complete amature with Linux and i have to use Slackware 12.2. because my uni assingment states so otherwise i would go for version 13.0. I will try and xconf method and report back if i have any success.

I have also downloaded the switch driver utility and i will see if that works. Thanks.

As for installing Slackware i downloaded an IO and burned that to a DVD. The installation seemed to run without a hitch. The hardware i have: Intel Core 2 Duo E6400, ATI 4870 HD GPU, 4Gb of OCZ RAM and an Asus P5Q Pro motherboard.

Thanks for all your suggestions i will see if i can get the problem sorted by the end of the day, I really need to be getting on with some assingment work and this little problem is holding me back.

wadsworth 10-29-2009 07:04 AM

You can try other video drivers in /etc/X11/xorg.conf
Driver "radeon"
or
Driver "radeonhd"
or
Driver "vesa"

To use the fglrx driver on 12.2 you must recompile the kernel and add MSI.

If you've unsuccessfully installed fglrx, you'll need to run the uninstall script,
fglrx overwrites portions of X.

Or tell you're prof. that ATI drivers stink (no lie there)
and you must use the newer drivers provided by 13.0.
(but they'll still stink)

windtalker10 10-29-2009 08:21 AM

I'm not counseling cheating, but Linux is Linux and the only difference between 12.2 and 13.0 essentially is the configurations and package availability.
If a custom kernel is called for, that's a bit much for a total newb and why go to the trouble of customizing a kernel when the next edition has a kernel that's already been customized for the hardware?
If it were me I'd install 13.0 and tell the Prof of the problem with 12.2 and remind him semesters are only so long.
Customizing a kernel is an assignment by itself that can be lengthy.
If 13.0 is how you have to end up going, I'd install XFCE and make sure it's set for default at boot.
I was able to find documentation for it more so than I was for the newer KDE desktop which relieved a good bit of frustration for me.

IcE-ColD 10-29-2009 08:28 AM

Quote:

Originally Posted by windtalker10 (Post 3736604)
I'm not counseling cheating, but Linux is Linux and the only difference between 12.2 and 13.0 essentially is the configurations and package availability.
If a custom kernel is called for, that's a bit much for a total newb and why go to the trouble of customizing a kernel when the next edition has a kernel that's already been customized for the hardware?
If it were me I'd install 13.0 and tell the Prof of the problem with 12.2 and remind him semesters are only so long.
Customizing a kernel is an assignment by itself that can be lengthy.
If 13.0 is how you have to end up going, I'd install XFCE and make sure it's set for default at boot.
I was able to find documentation for it more so than I was for the newer KDE desktop which relieved a good bit of frustration for me.

Well I've a had a look at the assingment brief and it says any version of slackware past 12 can be used so i successfully installed version 13.0 and evertything is working fine, except i can;t connect to the internet. Once i start KDE I go to the network settings page and when Slackware tries to detect my netowkr hardware i get the following error "could not parse XML file()". Has anyone encountered this problem before and how can it be fixed?

Thanks for all your help so far.

adamk75 10-29-2009 08:33 AM

Do you know if your network adapter is even detected? Does 'ifconfig' show an eth0 or eth1 device? Did you try setting up networking with 'netconfig' ?

Adam

IcE-ColD 10-29-2009 08:43 AM

Quote:

Originally Posted by adamk75 (Post 3736621)
Do you know if your network adapter is even detected? Does 'ifconfig' show an eth0 or eth1 device? Did you try setting up networking with 'netconfig' ?

Adam

Yes the network device is detected and i have ran netconfig. I has this issue with Slackware 12.2 and i had to go into network settings and enable the network device because by default it was disabled. It's probably the same error this time but i can't enable it because it wont show up in network settings under devices. Is there any way i can enable eth0 through a terminal?

Edit: All well and good now writing on here from Slackware 13. I had to install the wicd package to enable my network card. Thanks for all your help i can now finally get on with some work :)


All times are GMT -5. The time now is 07:29 PM.