LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 12.2 and sendmail 8.14.3 Host name lookup failure (http://www.linuxquestions.org/questions/slackware-14/slackware-12-2-and-sendmail-8-14-3-host-name-lookup-failure-725721/)

mirader9813 05-13-2009 11:00 AM

Slackware 12.2 and sendmail 8.14.3 Host name lookup failure
 
Hi I am new to linux org and hope I can receive the info I need here. I run skackware 12.2 and sendmail. I also run a mailing list of about 900 people. I recently switched to dsl from dialup and I have about 6 ip's
returning my mail with either "Hostname lookup failure" or Timeout waiting for data. All the other ip's on the list work fine. I have contacted these ip's and they say the problem is on my end, but I yet to figure it out. Although I have a static IP the only way to connect through the router is with DHCP. Although my DNS is programmed in the router, the DHCP automatically changes my resolv.conf to:

#Generated by dhcpcd for interface eth0
nameserver 192.168.0.1

That is not my true DNS. That is the DNS for the router and when I manually change my resolv.conf to my true dns the emails still bounce.

Any help would be so much appreciated

mirader

C-Sniper 05-13-2009 11:08 AM

try looking in /etc/mail/sendmail.cf for the parameters that you need. I am doing some configuration in that file myself right now and I think you can put your providers in there and it will pull mail from them.

Im not 100% sure but I *think* that is where you should look.

mirader9813 05-13-2009 11:17 AM

These ip's can send mail in to me. I just can't send mail to them. I have no clue what or where to put parameters in sendmail.cf. Can you help me there? I hate being a pest but I really need to fix this problem and I am quite new to sendmail. Thanks. Here is one of the return email messages I get:

---------- Forwarded message ----------
Date: Wed, 22 Oct 2008 21:39:34 -0700
From: Mail Delivery Subsystem <MAILER-DAEMON>
To: mirader@zoso.net
Subject: Warning: could not send message for past 4 hours

**********************************************
** THIS IS A WARNING MESSAGE ONLY **
** YOU DO NOT NEED TO RESEND YOUR MESSAGE **
**********************************************

The original message was received at Wed, 22 Oct 2008 17:31:11 -0700
from IDENT:1000@[127.0.0.1]

----- Transcript of session follows -----
... while talking to urscorp.com.inbound10.symantecmail.com.:
>>> EHLO zoso.net
<<< 421 Timeout exceeded
... while talking to urscorp.com.inbound10.symantecmail.net.:
>>> EHLO zoso.net
<<< 421 Timeout exceeded
<Rob_Marsh@URSCorp.com>... Deferred: Name server: urscorp.com.inbound10.symantecmail.net.: host name lookup failure
Warning: message still undelivered after 4 hours
Will keep trying until message is 5 days old


All times are GMT -5. The time now is 10:31 PM.