LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-07-2009, 06:10 PM   #1
tmerriam
Member
 
Registered: Dec 2008
Distribution: slackware
Posts: 50

Rep: Reputation: 16
Slackware 12.2 and KDE Clock Drift


I've been experiencing a very annoying bug the last week or so. The time displayed in the clock in KDE does not keep time. It runs fast, gaining about 1 minute each hour.

I have the RTC module loaded at boot from rc.local to create /dev/rtc

Code:
/sbin/modprobe rtc_cmos
For whatever reason, /etc/ntp/drift did not exist, so...

Code:
touch /etc/drift/drift
echo 0.0 > etc/ntp/drift
Reading the time directly from the hardware clock shows the 'correct' time. (It is exactly the same as the time displayed on KDE's clock on another computer running Slackware 12.1 and kernel 2.6.27.7, my wristwatch, and a clock radio.) Reading the hwclock reveals almost no deviation from those three other sources.

Code:
/sbin/hwclock
I also removed /etc/adjtime so ntp could recreate it, but still the displayed time keeps going fast. I'm really puzzled as to why this is occurring. Any suggestions?
 
Old 01-07-2009, 06:20 PM   #2
SqdnGuns
Member
 
Registered: Aug 2005
Location: Fountain Valley, CA / Thailand
Distribution: Slackware64 14.0
Posts: 981

Rep: Reputation: 88
I have not noticed it and just checked............mine is good to go.

I also have no drift file but I am using ntp.

Odd..........
 
Old 01-15-2009, 09:42 PM   #3
tmerriam
Member
 
Registered: Dec 2008
Distribution: slackware
Posts: 50

Original Poster
Rep: Reputation: 16
After some trial and error and some testing, I found the fix to this. Hopefully this helps someone....

I was able to fix this by appending "clocksource=hpet" to the kernel's boot options.
 
Old 01-15-2009, 10:17 PM   #4
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Quote:
I was able to fix this by appending "clocksource=hpet" to the kernel's boot options.
Perhaps then by enabling HPET support in the BIOS the boot parameter might not be needed?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 10.2 clock drift on supermicro system wapfos Linux - Software 0 06-11-2007 11:41 AM
Mandriva 2006.0 Clock Drift crxssi Mandriva 20 01-03-2006 06:52 AM
Clock Drift with Gnome Battery Applet? Matir Linux - Software 1 09-09-2005 02:56 PM
How to fix severe clock drift in FC3? rylan76 Linux - Software 1 07-03-2005 11:37 AM
Clock Drift, Any Ideas ? audie Linux - General 5 04-30-2004 03:35 AM


All times are GMT -5. The time now is 07:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration