LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-17-2008, 02:48 PM   #1
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,209

Rep: Reputation: 55
Slackware 12.2 and bouncing firefox icon


Just upgraded to 12.2 as a fresh installation. I am very impressed.

One issue I have noted is that on starting firefox I get two firefox buttons appearing on the status bar and a bouncing firefox icon which persists for some seconds before disappearing along with the second firefox button.

This may be a firefox 3 rather than a slackware 12.2 issue.

I had thought that it might be an issue with my old .mozilla directory but I have tried deleting it and starting afresh and still get the problem.
 
Old 12-17-2008, 02:57 PM   #2
mattydee
Member
 
Registered: Dec 2006
Location: Vancouver, BC
Distribution: Debian
Posts: 462

Rep: Reputation: 39
I've never found a solution to this problem nor have I really found an explanation to what causes this behavior.

A workaround: you can control the timeout for this at

Control Center - Appearance and Themes - Launch Feedback.
 
Old 12-17-2008, 03:06 PM   #3
digger95
Member
 
Registered: Oct 2007
Location: Indiana, PA
Distribution: Slackware 14
Posts: 330

Rep: Reputation: 45
arubin,

Control Center > Appearance and Themes > Launch Feedback:

1. From the dropdown box choose 'no busy cursor'.
2. Uncheck the box for launch feedback.

You can also disable launch feedback just for Firefox:

1. Right-click Firefox in the start menu and choose 'edit'.
2. Uncheck the box for launch feedback.

Dig
 
Old 12-17-2008, 03:26 PM   #4
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,209

Original Poster
Rep: Reputation: 55
Thanks. That gets rid it though it would be nice to know what is causing it in the first place.
 
Old 12-17-2008, 04:12 PM   #5
Eternal_Newbie
Member
 
Registered: Jun 2005
Location: The Pudding Isles
Distribution: Slackware 13.37
Posts: 573

Rep: Reputation: 59
No idea why, but I have noticed it takes several seconds longer for FF3 to start under KDE than it does under XFCE, for some reason. I'm sure FF2 wasn't as bad. This is under Slackware 12.1, by the way. Switching off startup notification does not help.

Last edited by Eternal_Newbie; 12-17-2008 at 04:13 PM.
 
Old 12-17-2008, 04:50 PM   #6
adriv
Member
 
Registered: Nov 2005
Location: Diessen, The Netherlands
Distribution: Slackware 14.1
Posts: 661

Rep: Reputation: 38
Maybe you've turned on the session restore?
FF does load a bit slower on KDE than IceWM (which I use), so I can imagine it's also a bit faster on Xfce.
 
Old 12-17-2008, 05:18 PM   #7
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,209

Original Poster
Rep: Reputation: 55
I never use session restore.
 
Old 12-17-2008, 05:27 PM   #8
adriv
Member
 
Registered: Nov 2005
Location: Diessen, The Netherlands
Distribution: Slackware 14.1
Posts: 661

Rep: Reputation: 38
Maybe it helps if you uncheck "warn for reported attack sites" (or something like that, my FF speaks Dutch) under Security?
 
Old 12-18-2008, 04:42 AM   #9
Toods
Member
 
Registered: Dec 2005
Location: UK
Distribution: Slackware 12.1
Posts: 249

Rep: Reputation: 32
I read somewhere that recent versions of Firefox (v3) need the following added to the '.mozconfig' file priot to the build:

Quote:
ac_add_options --enable-startup-notification
 
Old 12-18-2008, 04:46 AM   #10
vince4amy
Member
 
Registered: Dec 2008
Location: Great Britain
Distribution: Slackware
Posts: 58
Blog Entries: 1

Rep: Reputation: 17
I've also got this issue with Fx on Slackware. Though I disable the launch feedback in kcontrol. I'm also curious on what causes it to do this. Also it loads quicker on XFCE, but I'm sure this is because of the gtk elements.
 
Old 12-18-2008, 07:19 AM   #11
dizzi
Member
 
Registered: Jun 2004
Location: Yorkshire, UK
Distribution: Slackware, Mepis LiveCD
Posts: 146

Rep: Reputation: 15
Quote:
Originally Posted by digger95 View Post
arubin,

Control Center > Appearance and Themes > Launch Feedback:

1. From the dropdown box choose 'no busy cursor'.
2. Uncheck the box for launch feedback.

You can also disable launch feedback just for Firefox:

1. Right-click Firefox in the start menu and choose 'edit'.
2. Uncheck the box for launch feedback.

Dig

Just upgraded to Slack 12.2 last night and immediately noticed the "bouncing icon" and the double Firefox instance on the task bar. I viewed it as a bit of an annoyance since it seemed to drag on.

Thanks for the fixes .

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE Bouncing Icon Distortion sloik2000 Linux - Software 5 06-18-2007 07:15 PM
Firefox Icon? carlosinfl Debian 2 09-12-2006 10:48 PM
firefox toolbar icon? kud0s Linux - Software 6 07-27-2006 01:53 AM
Bouncing programs icons keep bouncing for ages blastradius Ubuntu 2 09-10-2005 02:49 AM
Where is firefox icon? planetsheinker Slackware 5 09-05-2005 01:41 PM


All times are GMT -5. The time now is 06:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration