LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-03-2008, 09:26 AM   #1
meikitsu
LQ Newbie
 
Registered: Nov 2006
Location: The Netherlands
Distribution: Slackware 12.1
Posts: 13

Rep: Reputation: 0
Slackware 12.1: XOrg freezes after CPU upgrade


Hi there,

I seem to have worked myself into another mess. The other day, I upgraded my 2.4GHz Celeron CPU to a 2.6GHz Pentium 4 CPU. And now I see my KDE 3.5.9 desktop freeze semi-randomly.
I use almost everything the way it came on the Slack DVD, apart from the occasional app that does not seem to cause the problem, and as far as I know, the (old) Celeron 2.4GHz belongs to the same processor family as the Pentium 4.

I have tried to establish some sort of a pattern, but cannot find it: first time it was Firefox (3.0.3) when opening a rather flashy website, and with MPlayerplugin playing and KTorrent on; second time it was with OpenTTD playing and KTorrent on; third time it was on starting KTorrent - and fourth time it was just Firefox running. But what puzzles me the most, is that this problem did not exist on my previous CPU.

Any idea on what might cause this? Defective CPU, perhaps? Or should it cause the problems less randomly then?

CPU: now Pentium 4 2.6GHz
RAM: 1024MB
MB: Asus P4PE-X
Vid: ATI Radeon 9600

Thanks in advance!
 
Old 11-03-2008, 10:05 AM   #2
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,282

Rep: Reputation: 66
You can do a CPU/memory stress test with kernel compilation.
This way you can do the CPU test without X running (to discard video driver failure)
Download the kernel sources from http://www.kernel.org, then tar xvf it and cd into it, and run:
Code:
while true; do
  make mrproper
  make defconfig
  make
done
(ctrl-c to stop it)
Then see if it has problem, if all is good then I would suspect video driver problem

Last edited by keefaz; 11-03-2008 at 10:09 AM.
 
Old 11-03-2008, 12:06 PM   #3
meikitsu
LQ Newbie
 
Registered: Nov 2006
Location: The Netherlands
Distribution: Slackware 12.1
Posts: 13

Original Poster
Rep: Reputation: 0
Running it at this very moment, without really knowing how long I should make it last

So far everything seems to run ok, so I'm afraid I'm still looking for an answer... Anyone?
 
Old 11-03-2008, 12:27 PM   #4
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,282

Rep: Reputation: 66
Re-install video drivers maybe ?
(a real CPU test would be run the above test for 30 minuts at a minimum)

Last edited by keefaz; 11-03-2008 at 12:29 PM.
 
Old 11-03-2008, 01:01 PM   #5
meikitsu
LQ Newbie
 
Registered: Nov 2006
Location: The Netherlands
Distribution: Slackware 12.1
Posts: 13

Original Poster
Rep: Reputation: 0
Tried that, downloaded ATI's drivers, can't even start x now. Certainly solves the problem of it freezing Continuing my search... (although it might be easier to just revert to the old CPU as the difference between the two is far from enormous)
 
Old 11-03-2008, 01:03 PM   #6
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Did you install the CPU yourself ? If so did you apply new thermal paste after scraping off the old one ? Does the CPU temperature look ok ?

Does X just crash or does the whole computer ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 11 to 12 upgrade problem with Xorg, xwmconfig salviadud Slackware 2 07-09-2007 11:40 PM
cpu freezes for 10 seconds incognito_kanchi Linux - Software 4 10-20-2006 06:28 PM
Misc. Xorg 6.9.0 problems after Slackware 11.0 upgrade BlueSpirit Slackware 9 10-15-2006 10:30 AM
recent dist-upgrade of xorg has killed my mouse (and thusly, xorg). Lokathor Debian 4 06-10-2006 04:52 AM
Xorg freezes on Gentoo Azazzello Linux - Software 3 11-27-2004 06:01 PM


All times are GMT -5. The time now is 01:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration