LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   slackware 12.1 won't boot up after installation advent 5302 (http://www.linuxquestions.org/questions/slackware-14/slackware-12-1-wont-boot-up-after-installation-advent-5302-a-672630/)

matt0007 09-26-2008 09:24 PM

slackware 12.1 won't boot up after installation advent 5302
 
hello again,

i managed to install slackware 12.1 on my hd. everything went well.
i'm trying to triple boot, so i went passed the OS choice screen by selecting "Linux" and then there was a lot of text running. first time i had a big grin on my face because i thought i finally managed to install linux and would be enjoying it, but it appeared i was wrong. suddenly it stopped after the line:

shpchp: Standart Host Plug PCI Controller Driver version: 0.4

then tried again and again it froze, but this time after line:
sd 4:0:0:0: Attached SCSI generic sgl type0

then third time:
hda_codec: Unknown model for ALC662, trying auto-probe from BIOS...

then fourth:
ACPI: Video Device [VGA] (multi-head: yes rom: no post:no)

fifth was the same as third so i gave up

any help would be much appreciated

my laptop spec: http://www.uktsupport.co.uk/advent/laptop/5302.htm

also, i had a slight issue with creating partition, but in my opinion that's just my stupidity and it's totally unrelated: http://www.linuxquestions.org/questi...nstall-672578/

if there is any other info that would help, just ask

edit: a little thing I failed to mention earlier: when I finished install, there was a message saying: close the setup and press ctrl+alt+del to reboot, so i closed setup but ctrl+ald+del didn't work. so i halted the system and then rebooted it by switching it off and back on

and one more thing that could be a sign of something: i've tried some other distros of linux. most of them don't even boot up, but the ones i managed to boot using "apci=off noapic nolapic pci=noapic"(that's a line i found in some forum that was supposed to help) none off them would shutdown - it would freeze

p.s. sorry for my "broken-English"

bobaye 09-27-2008 12:25 AM

How much of the software on the CD Or DVD did you install? And did it pass the md5 sum check OK?
It sounds like it's missing drivers......maybe. A guess on my part.
Best success can probably be had by by choosing the default kernel, and installing everything
but the I18 language packs (unless you really need them) and Emacs (because then you'll have to learn vi)....:-)
If you didn't do a full install to try and keep disk space, go ahead and retry a full install again.

matt0007 09-27-2008 06:08 AM

thanx for reply

i downloaded dvd iso and checked md5 - it matched.
what concerns installation, i did the fullest installation possible, including language packs.

i've got a feeling that you're right and there is something wrong with the drivers, but i'm new to linux and haven't got a clue how it works, how you check or edit them

Road_map 09-27-2008 06:52 AM

Before you reinstall, you should try:
1. Boot from DVD installation disk and type
Code:

hugesmp.s root=/dev/sda1 rdinit= ro
eventually
Code:

hugesmp.s root=/dev/sda1 rdinit= ro acpi=off
2. Login as root and check your /etc/lilo.conf file. You should add a line
Code:

append="acpi=off"
then run lilo command and - if no errors appears - reboot.

matt0007 09-27-2008 07:33 AM

Quote:

Originally Posted by Road_map (Post 3293304)
Before you reinstall, you should try:
1. Boot from DVD installation disk and type
Code:

hugesmp.s root=/dev/sda1 rdinit= ro
eventually
Code:

hugesmp.s root=/dev/sda1 rdinit= ro acpi=off
2. Login as root and check your /etc/lilo.conf file. You should add a line
Code:

append="acpi=off"
then run lilo command and - if no errors appears - reboot.

i did like you said.
booted dvd and at boot: typed

root=/dev/sda1 rdinit= ro

it froze after the line:
warning: anable to open an initial console
Kernel panic - not syncing: No init found. Try passing init= option to kernel

second time i typed: hugesmp.s root=/dev/sda1 rdinit= ro apci=off

and it froze again after the same line

i thought i mistyped so i tried again. this time it froze after the line:
Ext INT not setup in hardware but reported by MP table ENABLING IO-APIC IRQs
..TIMER: vector=0x31 apic1=0 pin1=2 apic2=0 pin2=0

i also tried few other variations with noapic nolapic, then it froze after:
ohci_hcd 0000:00:03.1: unlink after no IRQ? Controller is probably using the wrong IRQ

Road_map 09-27-2008 08:55 AM

Try append these kernel parameters: apic=debug irqpoll. See also http://www.mjmwired.net/kernel/Docum...parameters.txt

matt0007 09-27-2008 09:52 AM

Quote:

Originally Posted by Road_map (Post 3293389)
Try append these kernel parameters: apic=debug irqpoll. See also http://www.mjmwired.net/kernel/Docum...parameters.txt

tried:
boot: hugesmp.s root=/dev/sda1 rdinit= ro apci=debug irqpoll - no luck. computer freezes after the same lines

edit: also visited the link provided. i am new to linux and know very little about this OS. i understand that there are different commands and parameters to go with them, but i've got no clue which one to start with and what is the problem with my system in the first place. it's like walking blindfolded in a dark room. anyone could shed some light?

keefaz 09-27-2008 11:55 AM

Quote:

Originally Posted by matt0007 (Post 3293425)
tried:
boot: hugesmp.s root=/dev/sda1 rdinit= ro apci=debug irqpoll - no luck.

Just to discard obvious thing: Did you install slackware on the first partition of your drive ?

hitest 09-27-2008 12:11 PM

Did you set your root partition as bootable?

matt0007 09-27-2008 01:31 PM

Quote:

Originally Posted by keefaz (Post 3293529)
Just to discard obvious thing: Did you install slackware on the first partition of your drive ?

once again - my stupidity. my slackware is on sda4. so i tried now

boot: hugesmp.s root=/dev/sda4 rdinit= ro apci=off apic=debug irqpoll

all the process went a bit further but still stopped at:
etho: GMII mode.
etho: Enabling Auto-negotiation.
ACPI: PCI Interupt 0000:00:0f 0[A] -> GSI 18 (level, low) -> IRQ 22
hda_codec: Unknown model for ALC662, trying auto-probe from BIOS...

matt0007 09-27-2008 01:38 PM

Quote:

Originally Posted by hitest (Post 3293536)
Did you set your root partition as bootable?

not sure i understand the question. how do one set it?
i did everything as described in slackbook2.0 if you were asking if i added it when i was creating lilo, then answer is yes, and i get a nice screen with slackware logo and choice between my OSs

hitest 09-27-2008 01:55 PM

Quote:

Originally Posted by matt0007 (Post 3293595)
not sure i understand the question. how do one set it?

Here's a how to using fdisk, but, cfdisk would work just as well. If the root partition was not set as bootable that may be your problem.

http://www.howtoforge.com/the_perfec...op_slackware12

keefaz 09-27-2008 02:02 PM

Could you try to boot with:
hugesmp.s root=/dev/sda4 ro hda=noprobe

matt0007 09-27-2008 02:18 PM

Quote:

Originally Posted by keefaz (Post 3293613)
Could you try to boot with:
hugesmp.s root=/dev/sda4 ro hda=noprobe

if i type in the suggested line then the installation dvd boots up

keefaz 09-27-2008 02:22 PM

good :)
Login as root, and mount your system partition:
mount /dev/sda4 /mnt

then post the output with:
cat /mnt/etc/lilo.conf

[edit]
or maybe just try to boot with:
hugesmp.s root=/dev/sda4 rdinit= ro hda=noprobe


All times are GMT -5. The time now is 06:42 AM.