LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-19-2008, 06:07 PM   #1
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,082

Rep: Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799
Slackware 12.1: Fixed IP Address Not Working


I installed Slackware 12.1 on a Dell Inspiron 6000 (laptop) -- a clean install, not an upgrade -- and I cannot communicate with any internal server or the network printer; I can ping the gateway (192.168.1.1) and I can ping "myself" (192.168.1.20 or by name, "snafu") with no problems. I cannot ping another server (192.168.1.10) or printer (192.168.1.15) although I can, strangely, ping news.google.com (both with and without packet losses). I have the addresses and names of the servers and printer in /etc/hosts and I have the network configured exactly as it was with Slackware 12.0 -- I use fixed IP and have done so with this machine and this local network configuration for some years; same netmask, same gateway (a Linksys router), same everything (from, I think, Slackware 10.x through 11.x and 12.0).

The output of ifconfig -a, netstat -rn and everything else I can think of looks like I expect it to; all the pertinent stuff I can think of looks like below.

Is there some funky thing about Slackware 12.1 that I've missed? I do know that the wireless stuff came up without prompting but that doesn't seem to appear here.

Any help is deeply appreciated.
Code:
ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:12:f0:98:45:1e
         inet addr:192.168.1.20  Bcast:192.168.1.255  Mask:255.255.255.0
         inet6 addr: fe80::212:f0ff:fe98:451e/64 Scope:Link
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:2278 errors:0 dropped:0 overruns:0 frame:0
         TX packets:884 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:1991692 (1.8 MiB)  TX bytes:60047 (58.6 KiB)
         Interrupt:17 Base address:0x8000 Memory:dfdfd000-dfdfdfff

eth1      Link encap:Ethernet  HWaddr 00:12:3f:da:8d:74
         BROADCAST MULTICAST  MTU:1500  Metric:1
         RX packets:0 errors:0 dropped:0 overruns:0 frame:0
         TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
         Interrupt:18

lo        Link encap:Local Loopback
         inet addr:127.0.0.1  Mask:255.0.0.0
         inet6 addr: ::1/128 Scope:Host
         UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:4 errors:0 dropped:0 overruns:0 frame:0
         TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:372 (372.0 B)  TX bytes:372 (372.0 B)
netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U         0 0          0 lo
0.0.0.0         192.168.1.1     0.0.0.0         UG        0 0          0 eth0

/etc/rc.d/rc.inet1.conf
...
# Config information for eth0:
IPADDR[0]="192.168.1.20"
NETMASK[0]="255.255.255.0"
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY="192.168.1.1"

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"
(everything else is commented out)

/etc/hosts
# For loopbacking.
127.0.0.1               localhost
192.168.1.20            snafu.com snafu
192.168.1.10            fubar.com fubar
192.168.1.15            InkJet

# End of hosts.

/etc/resolv.conf
search com
nameserver 68.94.156.1
nameserver 68.94.157.1
 
Old 05-19-2008, 07:20 PM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,312
Blog Entries: 3

Rep: Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463
Hi,

How do you have your DNS setup?
edit:
Quote:
/etc/resolv.conf
search com <<<- what's this?
nameserver 68.94.156.1
nameserver 68.94.157.1

Last edited by onebuck; 05-19-2008 at 07:22 PM. Reason: edit notice file
 
Old 05-19-2008, 10:26 PM   #3
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,082

Original Poster
Rep: Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799
Uh, the "com" is the local domain name (at least that's what I've had in resolv.conf for... well, quite a while -- like years -- with no problems). If I remember right the network wizard at work (who managed about fifty Sun servers) said to stick that in the search list and the manual page seems to bear that out. Could, of course, be dead wrong about that (and the machine I'm writing this on has exactly that in resolv.conf and has since 10.x (I think).

Took that out, doesn't work for squat. Odd thing -- I can ping the system by name or address and it's fine; I can ping the gateway, it's fine; I ping either of the other services (192.168.1.10 or 192.168.1.15) and "Destination Host Unreachable."

I dunno.
 
Old 05-20-2008, 12:43 AM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,465

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
Perhaps you could try blacklisting the ipv6 module. Appears to have helped some others.
http://www.linuxquestions.org/questi....-help-642399/
 
Old 05-20-2008, 06:28 AM   #5
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,082

Original Poster
Rep: Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799
OK, tried blacklisting ipv6, rebooted, no joy in Mudville (thing won't even ping the gateway).

So, I'm wondering... I installed the default kernel. This thing is a laptop (and everybody knows that laptops are weird) and I'm pretty sure it's a Pentium (bearing in mind that Slackware 12.0 worked just fine with the SMP kernel) and maybe I should have used a different kernel? Right now I'm reinstalling (yeah, using the same default kernel) just in case I did something stupid without realizing it).

This one has me stumped.
 
Old 05-20-2008, 06:52 AM   #6
[stinger]
LQ Newbie
 
Registered: May 2008
Location: Boston, Mass
Distribution: Slackware
Posts: 20

Rep: Reputation: 0
Would I be correct to assume eth1 is the wireless card (that is not configured)?

If so, I don't see why this is coming up at all in the output of ifconfig (based on the snippit of rc.inet1.conf you showed). Again, if this is true, try disabling the radio with the function keys on the laptop keyboard and restart rc.inet1 (or reboot) and see if you get an ifconfig output without eth1 listed. Then see if you can reach these other addresses.

What wireless card are you (not) using?
 
Old 05-20-2008, 07:14 AM   #7
randomsel
Member
 
Registered: Oct 2006
Location: Wilmington, DE
Distribution: Slackware 11
Posts: 201

Rep: Reputation: 30
Quote:
Originally Posted by tronayne View Post
I can ping the gateway (192.168.1.1) and I can ping "myself" (192.168.1.20 or by name, "snafu") with no problems. I cannot ping another server (192.168.1.10) or printer (192.168.1.15) although I can, strangely, ping news.google.com (both with and without packet losses).
If you can ping news.google.com, then the network is working, so the problem lies somewhere else.
  • Do you have iptables enabled?
  • Can you ping "yourself" 192.168.1.20 from the server 192.168.1.10?
  • Can you open webpages (just to verify that the network's working)
  • Are the machines in the same switch/VLAN?
  • Is the correct module for the NIC loading? Does it need firmware?

You can also use nmap to scan for present hosts on the network.

Last edited by randomsel; 05-20-2008 at 07:15 AM.
 
Old 05-20-2008, 07:45 AM   #8
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,082

Original Poster
Rep: Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799
I did a complete reinstall (this time the Ethernet cables was not plugged in during installation, only difference, an I can not imagine why that would have mattered).

The machine can talk to the LAN, talk to the world, what the heck talk to the animals as far as I know. Why it works now and did not work previously, I do not know, alas.

Thank you to all for your time and effort (and I wrote down all those great hints for future reference, too).

All is well that ends.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DHCP Fixed IP Address confusion noir911 Linux - Server 1 03-23-2008 08:10 AM
problem acquiring IP address without router FIXED parliminux Fedora 1 01-09-2006 05:11 AM
i need fixed IP address. bruse Linux - Networking 5 09-19-2005 06:27 AM
Fixed IP Address with DHCP dgreenbean Linux - Networking 9 09-19-2004 01:12 PM
suse 9.1 network card setup with fixed ip address reinhard Linux - Networking 11 06-23-2004 01:11 PM


All times are GMT -5. The time now is 12:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration