LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 12.1 Dell D520 notebook detects HD as sda vs hda (http://www.linuxquestions.org/questions/slackware-14/slackware-12-1-dell-d520-notebook-detects-hd-as-sda-vs-hda-642100/)

howlerbr 05-14-2008 06:24 AM

Slackware 12.1 Dell D520 notebook detects HD as sda vs hda
 
Ola,

Estou tentando instalar o slackware 12.1 em um notebook dell d520. Ele está detectando o HD como /dev/hda. Na versão anterior (12.0) ele detectava como /dev/sda.

Ao tentar formatar a partição a instalação trava e nao consigo ir adiante. Tem algum parametro que eu possa passar na hora do boot para fazer com que o proc4esso de instalação detecte meu HD como SATA??

Obrigado,
Luiz Fernando

pdw_hu 05-14-2008 06:41 AM

Speak english.

howlerbr 05-14-2008 06:47 AM

oopss.. really sorry about that. I've posted the same message in a Brazilian forum...

Hi,

I'm trying to install slackware 12.1 in a D520 dell notebook. The installation process is detecting my HD as /dev/hda. In previous version (12.0) it detected as /dev/sda.

When I try to format the partition the installation process hangs up and I'm not able to even finish it. Is there any parameter that I can pass at boot time in order to make the installation process to detect by HD as SATA (/dev/sda) instead of IDE (/dev/hda)

Any help is welcomed!

Thanks,
Luiz Fernando

Alien Bob 05-14-2008 08:22 AM

Hi!

When starting the installation, add the string "hda=noprobe" (minus the quotes) to the boot command. For instance, if you do not have to add further parameters, you would boot the Slackware installer with this commandline instead of just pressing <ENTER>:
Code:

hugesmp.s hda=noprobe
This will cause your disk to be recognized as sda again and enable DMA as well. Did you notice how slow disk access was when the disk was recognized as hda? That is because DMA is turned off and there is no way to turn it back on.
At the end of the installation when you get to the LILO configuration dialogs, you will see the prompt to add additional parameters:
Code:

Some systems might require extra parameters to be passed to the kernel.
If you needed to pass parameters to the kernel when you booted the
Slackware bootdisk, you'll probably want to enter the same ones here.
Most systems won't require any extra parameters.
If you don't need any, just hit ENTER to continue

Here, you have to enter again
Code:

hda=noprobe
so that your system will assign sda to your harddisk when it boots.

This issue is covered in the CHANGES_AND_HINTS.TXT file too, please read the documentation that comes with Slackware! We do not write these for fun.

Eric

howlerbr 05-15-2008 08:41 AM

tks! it worked!

olivier.voutat 07-24-2008 10:10 AM

I'm not finding why but since I changed from Slackware 12 to 12.1 my notebook hp 6715s is reallly sloooow during boot at the "Replaying journal.." for the non-root partitions.

Thought it was caused by the same problem that howlerbr was having but no effect at all. Some idea?

I'm using Reiserfs...


All times are GMT -5. The time now is 01:27 PM.