LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-15-2008, 03:12 AM   #1
bingle
LQ Newbie
 
Registered: May 2007
Posts: 3

Rep: Reputation: 0
Slackware 12.1 Atheros Wireless (BEWARE!! I am a linux Noob)


I am fairly new to posting on this forum so bear with me.

Right people here goes, as the title says I am looking to setup my wireless on my laptop (Atheros) to connect to my wireless router so that I can browse then net. The problem is that it seems that Slackware 12.1 doesn't support my wireless card straight away out of the box.

I think I could try and connect to my router via cable if need be so that I could issue any terminal commands that require internet access.

What I need is a step by step guide for an idiot that explains how to correctly install drivers and configure the setup in Slackware 12.1

I read somewhere that using netconfig will do it but I'm assuming (I'm at work at the moment and haven't been able to try it) that it will require me to have my wireless drivers installed.

Also when I tell Slackware to shutdown, it doesn't automatically power off my laptop, is this a problem with the ACPI config? Any help will do.
 
Old 08-15-2008, 03:16 AM   #2
bingle
LQ Newbie
 
Registered: May 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Also I forgot to mention, it's on my laptop which is an Acer Aspire 5051AWXMi.
 
Old 08-15-2008, 06:44 AM   #3
bingle
LQ Newbie
 
Registered: May 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Found a couple of guides that go on to use madwifi and explain some things that confused me

http://xlayn.blogspot.com/2007/07/sl...12-review.html

http://madwifi.org
 
Old 08-15-2008, 08:06 AM   #5
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
To build it, it's pretty simple, you could just install this package from Alien Bob:
http://www.slackware.com/~alien/slac...wifi/pkg/12.1/
use 'installpkg' as root on the package.
Or you can use the Slackbuild that he provides, or just do 'make', then 'make install' if you download the source (and have the kernel source and headers installed).

Then take a look at Alien Bob's wiki: (edit: vehn beat me to it)
http://wiki.alienbase.nl/doku.php?id=slackware:madwifi
 
Old 08-24-2008, 12:45 AM   #6
bsurfin
Member
 
Registered: May 2004
Location: Kalispell Montana
Distribution: Kubuntu ( Current Version )
Posts: 112

Rep: Reputation: 15
I've been trying to get this to work on a HP dv5-1002nr Laptop with an Atheros 5007 wifi for about 14 hours straight "no luck", running Slackware 12.0 updated to current but still have kernel 2.6.21.5 from 12.0 installation, is there a snapshot somewhere in cyberspace that may work better and would I need to uninstall anything first ?
 
Old 08-24-2008, 05:30 AM   #7
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 213

Rep: Reputation: 43
You need an patched source for AR5007 chipset.
http://snapshots.madwifi.org/special...+ar5007.tar.gz
The rest is the same as normal.
 
Old 08-24-2008, 09:47 PM   #8
bsurfin
Member
 
Registered: May 2004
Location: Kalispell Montana
Distribution: Kubuntu ( Current Version )
Posts: 112

Rep: Reputation: 15
Hey thanks Nilly for the link, the info was outdated, but the info inside helped me get a new one, well it definately got the laptop to recognise the ath0, before it would only show eth0 and lo "and that's it", but I'm Still having a config problem of some sort, here are some outputs:

root@Darkstar:~# ifconfig
ath0 Link encap:Ethernet HWaddr 00:22:68:bf:50:83
inet addr:192.168.1.10 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::222:68ff:febf:5083/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:28 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3750 (3.6 KiB) TX bytes:468 (468.0 B)

eth0 Link encap:Ethernet HWaddr 00:1e:68:a6:32:93
inet addr:192.168.1.9 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::21e:68ff:fea6:3293/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2605 errors:0 dropped:3430093112 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:510354 (498.3 KiB) TX bytes:468 (468.0 B)
Interrupt:18 Base address:0x6000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wifi0 Link encap:UNSPEC HWaddr 00-22-68-BF-50-83-61-74-00-00-00-00-00-00-00 -00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:25778 errors:0 dropped:0 overruns:0 frame:564
TX packets:122 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:280
RX bytes:2288048 (2.1 MiB) TX bytes:5750 (5.6 KiB)
Interrupt:17


Then:

root@Darkstar:~# /etc/rc.d/rc.inet1 ath0_restart
/etc/rc.d/rc.inet1: ath0 information: 'Any ESSID'
Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory

I thought I would spare the other 50 lines of the failed to connect error

"Please Help"
 
Old 08-24-2008, 11:45 PM   #9
sparker
Member
 
Registered: Aug 2007
Location: Canada
Distribution: OpenBSD 4.6, Debian Lenny
Posts: 64

Rep: Reputation: 16
Have you configured the card yet? From the looks of the output you are using WPA encryption. Make sure you edit /etc/wpa_supplicant.conf and fill in your information.
 
Old 08-25-2008, 12:47 AM   #10
bsurfin
Member
 
Registered: May 2004
Location: Kalispell Montana
Distribution: Kubuntu ( Current Version )
Posts: 112

Rep: Reputation: 15
I already edited /etc/wpa_supplicant.conf, I've followed all the instructions the best I could understand them. ath0 is also now showing up in the KDE Control Module, when I try to highlight ath0 and then press button to enable I get this error code: There was an error changing the device's state. You will have to do it manually.

I'm not sure if I have configured the card or not, how is that done ?
I have loaded the driver and then madwifi, then edited all the config files in the instructions in the links above.
 
Old 08-25-2008, 06:32 AM   #11
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 213

Rep: Reputation: 43
Changing mode on an madwifi device may be different because it uses wlanconfig rather then iwconfig. (or at least did on older versions, i haven't tried it on the newer versions)
About the error i think you got some settings wrong in /etc/rc.d/rc.inet1.conf or /etc/wpa_supplicant.conf
 
Old 08-25-2008, 08:35 AM   #12
C-Sniper
Member
 
Registered: Dec 2006
Distribution: Slackware
Posts: 507

Rep: Reputation: 33
Have you tried the ATH5k module?
 
Old 08-25-2008, 07:26 PM   #13
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 13.37 Android 4.0
Posts: 2,248

Rep: Reputation: 46
Google "madwifi hal". You need to replace the default Hal so that it recognizes your card. That package will take care of everything you need to detect and initialize your card. Just build and install it.
 
Old 08-26-2008, 11:59 PM   #14
bsurfin
Member
 
Registered: May 2004
Location: Kalispell Montana
Distribution: Kubuntu ( Current Version )
Posts: 112

Rep: Reputation: 15
Wow, very easily done, Download, cd /, make, make install, now card has been enabled. Yeah it works. Thanks very for the great help !!!
 
Old 08-30-2008, 07:14 PM   #15
bsurfin
Member
 
Registered: May 2004
Location: Kalispell Montana
Distribution: Kubuntu ( Current Version )
Posts: 112

Rep: Reputation: 15
Now Trying to get the encryption key to work, everything is configured as far as I can tell,the info from iwconfig says Encryption key:0ff

How can I enable this ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
linux (debian) doesn't recognize my atheros wireless card ygn123 Linux - Wireless Networking 4 05-01-2008 06:04 PM
Getting Atheros USB wireless card to work in Linux RobynKartinian Linux - Wireless Networking 3 04-25-2008 09:42 AM
Completely new to Linux, need help with setting up Atheros Wireless chip taman Linux - Newbie 11 11-17-2007 02:01 PM
Help with Slackware not detecting Atheros AR5005G wireless adapter TonyJephson Slackware 6 12-23-2006 08:37 AM
Linux (CentOS) and Atheros Wireless Driver nentendo Linux - Newbie 33 08-28-2006 12:43 AM


All times are GMT -5. The time now is 11:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration