LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-29-2008, 11:24 AM   #1
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,033

Rep: Reputation: 755Reputation: 755Reputation: 755Reputation: 755Reputation: 755Reputation: 755Reputation: 755
Slackware 12.1, AMD ATI Driver Update, Open DRM Failed


Oof.

I've upgraded from ati-driver-installer-8-5-x86.x86_64.run to ati-driver-installer-8-6-x86.x86_64.run and get
Code:
fgl_glxgears
Using GLX_SGIX_pbuffer
libGL error: open DRM failed (Operation not permitted)
libGL error: reverting to (slow) indirect rendering
Memory fault
when running as a user (it works just fine as root and the previous version worked just fine as anybody).

Did I miss adding users to some group, a permission somewhere or other or something?

EDIT: I Found the Answer (that I forgot about from a couple of years ago)

There are two choices to deal with this: first, allow any user access, edit /etc/X11/xorg.conf and append
Code:
Section "dri"
        Mode    0666
EndSection
Or, edit /etc/X11/xorg.conf and append
Code:
Section "dri"
        Group   "video"
        Mode    0666
EndSection
Works fine.

Last edited by tronayne; 06-29-2008 at 01:33 PM. Reason: Found the Answer
 
Old 06-30-2008, 12:33 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Okay, you're now also off the Zero Replies list.
 
Old 06-30-2008, 06:06 AM   #3
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,033

Original Poster
Rep: Reputation: 755Reputation: 755Reputation: 755Reputation: 755Reputation: 755Reputation: 755Reputation: 755
Aw, phooey -- shoulda' coulda replied instead of edit, my bad, thanks for the reminder.
 
Old 06-30-2008, 07:03 AM   #4
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
No, problem. Thanks for posting the solution, so the next
person who finds your thread by searching will have the answer.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with the ATI driver from AMD (SLACKWARE 11) brevleq Linux - Hardware 3 05-25-2007 09:19 AM
Ati Xpress with AMD 64 driver Alinuxnoob Linux - General 1 06-09-2005 11:02 AM
ATI driver: ATI 9600XT failed dependencies igmcdermott Linux - Software 2 08-06-2004 09:26 AM
ATI driver: ATI 9600XT failed dependencies igmcdermott Linux - Software 1 08-06-2004 02:26 AM
ATI driver: ATI 9600XT failed dependencies igmcdermott Linux - Software 1 08-06-2004 02:24 AM


All times are GMT -5. The time now is 07:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration