LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-28-2007, 01:18 PM   #1
BigNate37
LQ Newbie
 
Registered: Nov 2007
Location: Canada
Distribution: Ubuntu 8.10
Posts: 25

Rep: Reputation: 15
Slackware 12.0 CD boot hangs on floppy drive


As a disclaimer, I'm new to slackware and less-than-comfortable with unix-based systems in general, despite being pretty experienced building PCs.

So I'm trying to install Slackware 12.0 on a new PC from the CDs.

The PC is built on an Asus M2A-VM motherboard, with a Sempron 3400+ AM2 F2 Manila CPU. It's a 64-bit core but supposedly should work like an x86 without problems. It's got 2x1MB PC2-5300, a Western Digital SATA2 HDD, a Sony 1.44MB floppy drive, and an LG CD-RW/DVD-ROM IDE drive. Graphics and LAN are onboard.

Booting with CD1 in the drive, I boot the default hugesmp.s kernel, and partway through the boot the system hangs:

Quote:
.
.
.
pci_hotplug: PCI HOt Plug PCI COre version: 0.5
isapnp: Scanning for PnP cards...
CLocksource tsc unstable (delta = 500028887 ns)
Time: hpet clocksource has been installed.
isapnp: No Plug & Play device found
Real Time Clock Driver v1.12ac
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
Floppy drive(s): fd0 is 1.44M
_
And there it gets stuck until I reset the machine.

Oddly enough, this wasn't the first problem I had with hanging on boot. It originally hung on the "Serial: 8250/16550 driver ..." line, so I started playing with the serial port address in the BIOS. The serial port can be set to disabled, 3F8/IRQ4, 2F8/IRQ3, 3E8/IRQ4, 2E8/IRQ3, or auto. The only setting I found which didn't cause a hang on the "Serial: 8250/16550 driver ..." line was disabled. I don't mind disabling it, since the serial port pins on the motherboard don't get off the board to a DB-9, and I have no plans to change that. Only with the serial port disabled did it get one line further to hang on the floppy drive line. So I went back to the BIOS and disabled the floppy drive, causing the boot to hang at the "Serial: 8250/16550 driver ..." line again.



What's going on here? What can I do to get the Slackware 12.0 installer running?
 
Old 11-28-2007, 01:27 PM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: Slackware®
Posts: 11,282
Blog Entries: 3

Rep: Reputation: 1446Reputation: 1446Reputation: 1446Reputation: 1446Reputation: 1446Reputation: 1446Reputation: 1446Reputation: 1446Reputation: 1446Reputation: 1446
Hi,

Pass the parameters 'noapci' & 'noapic' to the kernel at the boot prompt.

What is your boot order in the BIOS? Try the cdrom (1st) boot before the floppy (2nd) & hard disk (3rd).

BTW, Welcome to Slackware & LQ

Last edited by onebuck; 11-28-2007 at 01:28 PM. Reason: Salutation
 
Old 11-28-2007, 01:46 PM   #3
BigNate37
LQ Newbie
 
Registered: Nov 2007
Location: Canada
Distribution: Ubuntu 8.10
Posts: 25

Original Poster
Rep: Reputation: 15
The boot order was FD-CD-HD, but I've changed it to CD-FD-HD. This didn't change where the boot hung.

I also tried passing noapci and noapic—what is the correct syntax?
I tried these forms, and none worked:
Quote:
boot: hugesmp.s noapci noapic
boot: hugesmp.s -noapci -noapic
boot: hugesmp.s --noapci --noapic
Although the last one, with two hyphens, seemed to make the machine take a brief (less than 0.5s) pause before loading the kernel. Forgive me, this is where my lack of unix eperience kills me—directions like this I sometimes need spelled out for me.

Playing on the APCI angle, I also tried disabling APCI APIC support in the BIOS, with no better luck than the other two remedies.



I'm going to crack the case and make sure the FDD cable didn't come loose or something silly. Oh, and thanks for taking the time to offer suggestions. This'll be my only unix-based system, if I can get it up.

Last edited by BigNate37; 11-28-2007 at 01:47 PM. Reason: thanks note
 
Old 11-28-2007, 01:51 PM   #4
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Have you tried booting the 'huge.s' kernel ?
 
Old 11-28-2007, 01:52 PM   #5
BigNate37
LQ Newbie
 
Registered: Nov 2007
Location: Canada
Distribution: Ubuntu 8.10
Posts: 25

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by BigNate37 View Post
I'm going to crack the case and make sure the FDD cable didn't come loose or something silly.
Well the floppy drive has power and is solidly connected to the motherboard (assuming the cable is OK). Though I did notice I installed one of the exhaust fans backwards...
 
Old 11-28-2007, 01:55 PM   #6
BigNate37
LQ Newbie
 
Registered: Nov 2007
Location: Canada
Distribution: Ubuntu 8.10
Posts: 25

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by H_TeXMeX_H View Post
Have you tried booting the 'huge.s' kernel ?
Yep. Tried it again a couple times just now, the only difference is that the delta in the sixth-last line is around 504ms instead of 500ms. Hangs in the same place.
 
Old 11-28-2007, 02:50 PM   #7
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Does the md5sum of the disk check out ? i.e. is the disk burnt properly ?
 
Old 11-28-2007, 03:19 PM   #8
BigNate37
LQ Newbie
 
Registered: Nov 2007
Location: Canada
Distribution: Ubuntu 8.10
Posts: 25

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by H_TeXMeX_H View Post
Does the md5sum of the disk check out ? i.e. is the disk burnt properly ?
Actually, these are the stamped Slackware 12.0 CDs, dated August 2007. I bought them along with Slackware Linux Essentials and Linux: The Complete Reference.
 
Old 11-28-2007, 04:29 PM   #9
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,771

Rep: Reputation: 205Reputation: 205Reputation: 205
At a guess, there is something in the default Slackware kernel which is causing a conflict somewhere.

To work around your problem, you could temporarily disconnect the floppy drive data cable and see if that will at least let you get the system installed.

Once that's done, the next thing would be to compile a custom kernel. This is not an easy thing for a beginner to do, but will give you the best results.
 
Old 11-29-2007, 11:35 AM   #10
BigNate37
LQ Newbie
 
Registered: Nov 2007
Location: Canada
Distribution: Ubuntu 8.10
Posts: 25

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by rkelsen View Post
At a guess, there is something in the default Slackware kernel which is causing a conflict somewhere.

To work around your problem, you could temporarily disconnect the floppy drive data cable and see if that will at least let you get the system installed.

Once that's done, the next thing would be to compile a custom kernel. This is not an easy thing for a beginner to do, but will give you the best results.
Disconnecting the floppy drive changes little:
  • If I disconnect the floppy drive and disable it in the BIOS, it hangs as above at the serial line just as before with the floppy drive set to disabled in the BIOS while it was connected.
  • If I disconnect the floppy drive and leave it set to "1.44MB, 3.5 in." in the BIOS, the motherboard complains on POST. Pressing F1 to continue despite the error, it hangs at the floppy drive line just as before where the floppy drive was connected and enabled.

Is it possible that the system is hanging on whatever comes after the floppy drive check?
 
Old 11-29-2007, 03:21 PM   #11
BigNate37
LQ Newbie
 
Registered: Nov 2007
Location: Canada
Distribution: Ubuntu 8.10
Posts: 25

Original Poster
Rep: Reputation: 15
Is there a more tolerant or all-inclusive kernel I could try instead of hugesmp.s? That, huge.s and speakup.s are the only three on the CD, and none of them work.

Alternatively, could someone comment on the exact syntax for specifying noacpi and noapic at the boot: prompt? I'm still not sure I did it properly, as mentioned above.
 
Old 11-29-2007, 04:00 PM   #12
BigNate37
LQ Newbie
 
Registered: Nov 2007
Location: Canada
Distribution: Ubuntu 8.10
Posts: 25

Original Poster
Rep: Reputation: 15
Based on Documentation/floppy.txt, I tried using:
Code:
hugesmp.s floppy=nodma
hugesmp.s floppy=yesdma
hugesmp.s floppy=0,daring
hugesmp.s floppy=asus_pci
None of them worked, though I had high hopes for the asus_pci switch (the machine has an Asus board, afterall).

I also tried playing with PCIPnP BIOS settings to no avail.

From the looks of other folks' machine info [1] [2], I'd venture a guess that the next line (if it were not hanging on the floppy drive) would be the floppy disk controller.

Quote:
...
Jan 9 09:16:02 thor kernel: Floppy drive(s): fd0 is 1.44M
Jan 9 09:16:02 thor kernel: FDC 0 is a post-1991 82077
...
Quote:
...
Floppy drive(s): fd0 is 1.44M
floppy0: no floppy controllers found
...
Since the system hangs before the "Floppy drive(s): fd0 is 1.44M" line when I remove or disable the floppy drive, I'm not even sure that the floppy drive is the problem. Is there a way I can get the kernel to load without floppy support at all, or is it not in an independent module?
 
Old 11-29-2007, 04:53 PM   #13
tobyl
Member
 
Registered: Apr 2003
Location: uk
Distribution: slackware current
Posts: 743

Rep: Reputation: 51
I think this is a new motherboard, and the linux kernel has some issues.

To pass the kernel parameter, try acpi=off or noacpi

googling suggests to try turning HPET off in the bios

and also get a bios update if you can.

Also make sure you have connected up all your cables the right way round!

When you are ready, an update to the latest kernel will almost certainly help too as your motherboard is pretty new.

references:

http://bugzilla.kernel.org/show_bug.cgi?id=8326
http://disparitybit.supersized.org/a...s-summary.html

tobyl
 
Old 11-29-2007, 05:03 PM   #14
BigNate37
LQ Newbie
 
Registered: Nov 2007
Location: Canada
Distribution: Ubuntu 8.10
Posts: 25

Original Poster
Rep: Reputation: 15
Well, I e-mailed a friend about it. I tried a couple other kernel parameters and took a couple pictures, so I thought I'd note that here as well.



Using the quiet option as follows:
Code:
boot: hugesmp.s quiet
I get the following error. This is interesting, and hopefully will help diagnose the problem. Edit: apparently this happens anyways: my friend confirms that when using the quiet option, his Ubuntu system has almost the same line—it's a red herring that you just normally don't notice.
Code:
Uncompressing Linux... Ok, booting the kernel.
PCI: Cannot allocate resource region 1 of device 0000:00:14.0
_
A ~75kB JPG photo of the "hugesmp.s quiet" output is here:
http://i1.tinypic.com/8bgp1tg.jpg

A ~75kB JPG photo of the usual hung output I've been getting (and typed out in part in the original post) is here:
http://i10.tinypic.com/6wndlp3.jpg

Last edited by BigNate37; 11-29-2007 at 05:29 PM. Reason: Turns out that the utput from using quiet did *not* mean anything
 
Old 11-29-2007, 05:25 PM   #15
BigNate37
LQ Newbie
 
Registered: Nov 2007
Location: Canada
Distribution: Ubuntu 8.10
Posts: 25

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by tobyl View Post
I think this is a new motherboard, and the linux kernel has some issues.

To pass the kernel parameter, try acpi=off or noacpi

googling suggests to try turning HPET off in the bios

and also get a bios update if you can.

Also make sure you have connected up all your cables the right way round!

When you are ready, an update to the latest kernel will almost certainly help too as your motherboard is pretty new.

references:

http://bugzilla.kernel.org/show_bug.cgi?id=8326
http://disparitybit.supersized.org/a...s-summary.html

tobyl
(emphasis added)


Bingo. In the BIOS, I changed HPET Support from enabled to disabled. Then I booted with the default kernel with no extra parameters (i.e. hugesmp.s), and voilą, passed where it hung before and now it's asking me to select a keyboard map!

Coincidentally, I've re-enabled the serial port, floppy drive, onboard LAN, PCI Plug-n-Play, and onboard sound in the BIOS, and the kernel still boots successfully.

Right now I'm pretty elated, but I'm not going to continue with the install until either later tonight or tomorrow. If all goes well from here on out, this box will be a custom honeypot, happily sniffing packets for a school project within a week or two. I might do some reading on my BIOS version, but that'll be on the back burner. The kernel on my CDs is 2.6.21.5, so it's not too far off from the latest at the moment.

Thanks so much, tobyl, onebuck, H_TeXMeX_H and rkelsen!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Floppy drive interfaced tape drive in Slackware isolationist Linux - Hardware 6 02-13-2006 05:54 AM
Linux hangs on boot - no floppy device found Penseur46 Linux - Newbie 6 02-02-2005 09:50 AM
Fedora boot hangs when it cannot find a floppy Penseur46 Linux - Hardware 1 01-31-2005 03:35 PM
boot from floppy drive then insall linux redhat9 from HARD DRIVE Shiraz Ahmed Linux - Software 0 08-23-2004 05:11 AM
System hangs during floppy boot (RH 7.2 - newbie) misfit13b Linux - Software 2 02-28-2002 05:19 PM


All times are GMT -5. The time now is 10:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration