LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-17-2006, 09:36 PM   #1
rotty
Member
 
Registered: Dec 2005
Posts: 39

Rep: Reputation: 15
Slackware 11 no GUI


I have a problem where i run "startx" command and the screen goes blank.

I have a radeon 9800se graphics card (But i want to use the default linux drivers)

and a 15" monitor

I selected 1024 * 768 (Which i know is a bit big for the monitor)

I tried the CTRL ALT (+/-) trick while the screen was blank.

I used the Huge26.s kernal.

What is wrong with this bloody monitor?

Perhaps it is the refresh rates, how do i check?

I tried to run "/usr/X11R6/bin/xorgconfig" at the command line, that came up with:

"This program will create a basic xorg.conf file, based on....." , now should i create this and enter the details?

cheers, rotty

Last edited by rotty; 10-17-2006 at 09:54 PM.
 
Old 10-17-2006, 09:55 PM   #2
truthfatal
Member
 
Registered: Mar 2005
Location: Winnipeg, MB
Distribution: Raspbian, Debian, Slackware, OS X
Posts: 443
Blog Entries: 9

Rep: Reputation: 32
have you run xorgconfig? If not, you should google your monitor to try to find out it's proper refresh rates. then run that program.(The rates may also be found in the manual for your monitor )

For example, I googled `xorg.conf Philips +109b" and found several examples of etc/X11/xorg.conf with
Code:
	HorizSync	30-97
	VertRefresh	50-160
in the Monitor section. these settings work for me.
 
Old 10-17-2006, 10:07 PM   #3
rotty
Member
 
Registered: Dec 2005
Posts: 39

Original Poster
Rep: Reputation: 15
Ok, so when it asks me to create that file, just continue? I don't want to create more problems (-:


cheers, rotty
 
Old 10-17-2006, 10:11 PM   #4
truthfatal
Member
 
Registered: Mar 2005
Location: Winnipeg, MB
Distribution: Raspbian, Debian, Slackware, OS X
Posts: 443
Blog Entries: 9

Rep: Reputation: 32
That sould work. if you're root, it will automatically put the file in the right place, if not xorgconfig will put the file in your home dir ( it think ) and you'll have to move it to /etc/X11
 
Old 10-17-2006, 10:43 PM   #5
rotty
Member
 
Registered: Dec 2005
Posts: 39

Original Poster
Rep: Reputation: 15
so do i edit : etc/X11/xorg.conf
or : /usr/X11R6/bin/xorgconfig

which file?

cheers, rotty
 
Old 10-17-2006, 10:58 PM   #6
cereal83
Member
 
Registered: Feb 2004
Location: Canada
Distribution: Slackware
Posts: 478

Rep: Reputation: 30
/etc/X11/xorg.conf


xorgsetup as root will usually detect all your settings and put it in thise file for you but sometimes you have to make little changes
 
Old 10-17-2006, 11:00 PM   #7
rotty
Member
 
Registered: Dec 2005
Posts: 39

Original Poster
Rep: Reputation: 15
I did a google search for our "samsung syncmaster 550s" monitor, also used the same syntax you did but i did not find anything useful as to the configuration.

Ok i found that the horizontal frequancy support and the vertical are 30 to 61 Hz and 1,024 x 768 resolution i gather i should just set this?

cheers, rotty

Last edited by rotty; 10-17-2006 at 11:04 PM.
 
Old 10-17-2006, 11:03 PM   #8
cereal83
Member
 
Registered: Feb 2004
Location: Canada
Distribution: Slackware
Posts: 478

Rep: Reputation: 30
You will find the horz and vertical rates in the manual of the monitor. Usually xorgsetup detects this stuff if the monitor is newer then like 4 or 5 years
 
Old 10-17-2006, 11:08 PM   #9
rotty
Member
 
Registered: Dec 2005
Posts: 39

Original Poster
Rep: Reputation: 15
This is a monitor picked up cheap (They would have been disposed of otherwise, for test purposes. never really got a manual.

cheers, rotty
 
Old 10-17-2006, 11:48 PM   #10
rotty
Member
 
Registered: Dec 2005
Posts: 39

Original Poster
Rep: Reputation: 15
Well i tried the +/- trick, i set the refresh rate. I also noticed that when i press Ctrl - alt - Backspace the screen flickers with the logon then goes back to the command line screen. Also when i entered "kdm" the screen would flicker with the logon window when entering and exciting the KDE mode.

I have no idea what is going on.

Thanks for all the help this forum has given me!!!

cheers, rotty
 
Old 10-18-2006, 12:22 AM   #11
rotty
Member
 
Registered: Dec 2005
Posts: 39

Original Poster
Rep: Reputation: 15
i did not run "xorgconfig", this should fix the problem. I got confused with people mentioning both files, i was not sure what i was meant to do.

I will try this.

cheers, rotty
 
Old 10-18-2006, 08:46 AM   #12
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,331
Blog Entries: 3

Rep: Reputation: 1466Reputation: 1466Reputation: 1466Reputation: 1466Reputation: 1466Reputation: 1466Reputation: 1466Reputation: 1466Reputation: 1466Reputation: 1466
Quote:
Originally Posted by rotty
i did not run "xorgconfig", this should fix the problem. I got confused with people mentioning both files, i was not sure what i was meant to do.

I will try this.

cheers, rotty
Hi,

I would suggest that you read some reference. Check my sig!

For your X setup go here.
 
Old 10-18-2006, 11:25 AM   #13
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,205

Rep: Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554
Yep run xorgconfig as root and over-write any mistakes you've made. xorgconfig will ask you a series of questions, once you're done then startx should work.
 
Old 10-18-2006, 12:28 PM   #14
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,205

Rep: Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554
You could also try the command #xorgsetup, which will set-up your xorgconfig file automatically for you. I prefer xorgconfig as xorgsetup is not as accurate, for me anyway:-)
 
Old 10-18-2006, 05:52 PM   #15
rotty
Member
 
Registered: Dec 2005
Posts: 39

Original Poster
Rep: Reputation: 15
Ok well i ran xorgconfig and got this error in the log file.

I had the screen were it shows black and white vertical lines and the screen was not really visible but you can see the outline of the prompts that came up (No idea what they said).

I tried xorgconfig again and now get the following no matter what settings i tell it.

"Fatal server error: no screen found"

"XIO: Fatal IO error 104 (Connection reset by peer) on X server ":0.0" after 0 requests (0 known processed) with 0 events remaining."

I found the user guide for the monitor:

http://downloadcenter.samsung.com/co...33_550S_EN.pdf

This whole process with slackware has already been very time consuming and is looking to stay that way, should i consider SUSE instead, it is meant to be easier and more automated.

cheers, rotty

Last edited by rotty; 10-18-2006 at 06:02 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No GUI in SLackware 10?! Worksman Slackware 20 11-19-2004 08:53 PM
Slackware 10.0 won't go to GUI garbo73 Slackware 17 11-02-2004 10:20 AM
GUI for Slackware btexpress Slackware 10 05-16-2004 11:30 PM
Slackware 9.0 GUI? Gerardoj Linux - Software 11 07-02-2003 01:36 AM
slackware gui? emory7825 Linux - Newbie 3 11-26-2001 03:16 PM


All times are GMT -5. The time now is 04:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration