LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 11 - Audacity 1.3.2 (http://www.linuxquestions.org/questions/slackware-14/slackware-11-audacity-1-3-2-a-499886/)

bgeddy 11-08-2006 07:50 PM

Slackware 11 - Audacity 1.3.2
 
Anyone running Audacity 1.3.2 under Slackware 11 ? I have downloaded the package audacity-1.3.2-i486.tgz from slacky.it (an Italian Slackware site) and installed it using KDE's package installer. It seemed to go OK but when I try to launch it from KDE it tries to load for a while then just returns to KDE (no error messages). Does anyone know of a working Slackware Package of this product or know how to get this version running?

Thanks

Okie 11-08-2006 09:11 PM

wxwidgets is a dependency of audacity, if it is not installed audacity wont run

http://www.wxwidgets.org/

bgeddy 11-09-2006 11:57 AM

Thanks for the reply. I have some further information if it helps. When trying to run Audacity from a Konsole prompt it complains that it can't find the shared library "libsndfile.so.1" . I have downloaded the source to this library, compiled and installed it. The install has placed libsndfile.so.1 in /usr/local/lib, should I set Audacity to look there for this library and if so how do I do this ? Or I am barking up the wrong tree ? Audacity seems to be looking for this shared library but can't find it. Thanks..

Mr_C 11-09-2006 12:04 PM

yep so go get libsndfile!
http://packages.debian.org/unstable/source/libsndfile

tramni1980 11-09-2006 03:21 PM

Hello!
I have a question about audacity as well. I also downloaded it from slacky.it, together with all the dependencies:

audacity-1.3.2-i486-1sl.tgz libsamplerate-0.1.2-i486-4sl.tgz
fftw-3.1.2-i486-3sl.tgz libsndfile-1.0.17-i486-2sl.tgz
jack-audio-connection-kit-0.102.20-i486-1sl.tgz sqlite-2.8.17-i486-2sl.tgz

I am running Slackware 11.0 with kernel 2.6.18. When I typed "audacity", it complained that there was incompatibilty between the libraries and the package, because I am running 2.6, and they were compiled with 2.4. What should I do?

Okie 11-09-2006 04:04 PM

Quote:

I am running 2.6, and they were compiled with 2.4. What should I do?
get the source for both audacity and wxWidgets and compile wxWidgets first and audacity second...

tramni1980 11-09-2006 07:12 PM

Could you please tell us what sources and from where have to be downloaded and in what succession they have to be compiled, so that audacity is successfully compiled as well?
I have ben trying to compile it for quite a time, but in vain :(

Mr_C 11-09-2006 08:44 PM

that would be the wxWidgets to compile first, then libsndfile then audacity.
OR
you can dl from linuxpackages wxWidgets 2.6, audacity 1.3.2, install both and dl libsndfile from the link I posted above and after which all works <well for me>
Clicking on the packaged details on the site helps point ya in the correct direction.

bgeddy 11-09-2006 09:43 PM

Mr C - maybe you didn't read my post. I had installed libsndfil and installed it but Audacity still complained. Anyway - I ran ldconfig and that fixed it. I then downloaded the wxwidgets and compiled that, then jack audio compile, ldconfig, and audacity now works. Well actually I had to tell KDE to drop it's control of ALSA after 1 second of inactivity as it was keeping audacity from opening the sound device.

Tramni1980 - I am not at my machine now so I can't give the exact steps I took to get it working but I'll have a look tomorrow if you wish.

Cheers

arubin 11-10-2006 03:43 AM

I have audacity running fine with a 2.6 kernel using packages from linuxpackages. I have not had to compile anything

tramni1980 11-10-2006 06:45 AM

Hello again!
I managed to install audacity. it now runs , but seems to be quite unstable it often crashes. Maybe cos I downloaded the beta version. I had no choice because the beta version used wxWidgets 2.6, which are available. The stable version needs wxWidgets 2.4.x, which are nowhere to be found.


All times are GMT -5. The time now is 05:08 AM.