LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-12-2007, 05:32 PM   #1
thethinker
Member
 
Registered: Jul 2006
Location: Urbana, IL, USA
Distribution: Slackware 13.37
Posts: 103
Blog Entries: 2

Rep: Reputation: 15
Slackware 11.0 Xfce problem - failing to start xfdesktop


Hey everyone,
My laptop randomly started giving me a black desktop yesterday. Everything seems to work except all interaction with the desktop itself...I have toolbars and such (which work), but i.e. I can't use the right mouse button. I have found a help topic on this, and it turns out when I start 'xfdesktop' it fixes the problem. However, I do not know how to put this in a startup script or something, so that it starts every time I do startx. Anyone know an easy way to do that?

As I said above, I'm using Slackware 11.0, X11 version 6.9.0, and a 2.6.20 kernel. Thanks a bunch!
 
Old 07-12-2007, 06:01 PM   #2
frazum
LQ Newbie
 
Registered: Jul 2007
Distribution: ZenWalk
Posts: 25

Rep: Reputation: 15
check your xinitrc file. That is where one usually tweaks to start various programs when X is launched.
 
Old 07-12-2007, 07:14 PM   #3
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 926

Rep: Reputation: 96
Actually, starting xfdesktop while XFCE is running and then logging out of XFCE (with "save settings" enabled) should do the job, next time xfdesktop should start automatically (the same is true for panels etc.).

Also, there's the option "Allow XFCE to manage the desktop" in the desktop settings of XFCE. Enable that, if it's not so already.
 
Old 07-12-2007, 07:15 PM   #4
badfrog
LQ Newbie
 
Registered: Jul 2007
Location: Louisville, KY
Distribution: Slackware, Debian and LFS (soon!)
Posts: 14

Rep: Reputation: 0
Had a similar problem caused by me farting around with hal.conf. Starting xfdesktop in the background (type xfdesktop & in a console window) while in X seems to have fixed the problem and my desktop is back even when I start a new X session. At the very least, if it doesn't work you should see an error message that might help you troubleshoot the problem?

Edit - Like he said ^^^
 
Old 07-13-2007, 02:16 PM   #5
thethinker
Member
 
Registered: Jul 2006
Location: Urbana, IL, USA
Distribution: Slackware 13.37
Posts: 103
Blog Entries: 2

Original Poster
Rep: Reputation: 15
That got it, thanks guys! I'm such a newbie...I started xfdesktop without running in the background :-P. Anyway, running it in the background worked fine. Another fix by LQ. thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dovecot Failing to start mrJimmbo Linux - Server 6 01-24-2007 08:51 PM
Xfce problem - can't start it J_K9 Linux - Software 4 07-14-2005 10:22 PM
INIT failing to start dubya Fedora 3 04-25-2005 06:59 PM
Squid Failing to Start WarlockofVirgo Linux - Networking 2 09-03-2004 03:59 AM
X failing to start... Tayl Linux - Newbie 5 07-19-2002 04:51 AM


All times are GMT -5. The time now is 04:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration