LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 10, sound works only with alsaconf (http://www.linuxquestions.org/questions/slackware-14/slackware-10-sound-works-only-with-alsaconf-204561/)

SyBorg 07-13-2004 12:13 PM

Slackware 10, sound works only with alsaconf
 
Strange problem here

I installed Slackware 10.0 doing FULL install.

Launched 'alsaconf', sound working ok with shell (with 'mpg123 somemusic.mp3')
Launched KDE, sound is off
Launched konsole, made the 'alsaconf' again, sound working in KDE.

Now I'm in KDE as user, no sound, make alsaconf as root in konsole, sound working again.

I tried checking the files&links permissions in /dev/, but all seems ok to me, mixer*, dsp*, midi* and other are all owned by root,audio

Motherboard Asus A7V8X-X
Soundcard Sound Blaster Audigy (rev 03)
Linux Slackware 10, 2.4.26

TIA for any tip, I already looked in the forum but found nothing like this

keefaz 07-13-2004 01:19 PM

Did you try alsamixer to set your audio channels ?

SyBorg 07-13-2004 01:27 PM

Yes I did, all volumes are up : sounds comes up only by running 'alsaconf' (with 4 'Enter' keypress).

Now I'm checking the /dev/dsp* and mixer* again, I saw that the stat says '662' opposed to '666' as per the sticky post about Slack installation.

Update :
Just tried it, no chance. Still I have to 'alsaconf' and nothing else to get sounds in KDE.

I saw this in X :

kmixctrl: ERROR: Alsa mixer cannot be found.
Please check that the soundcard is installed and the
soundcard driver is loaded.
kmixctrl:
kmixctrl: ERROR: Alsa mixer cannot be found.
Please check that the soundcard is installed and the
soundcard driver is loaded.
kmixctrl:
ALSA lib pcm_hw.c:549:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
ALSA lib pcm_hw.c:549:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
ALSA lib pcm_hw.c:549:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe

keefaz 07-13-2004 01:42 PM

Try copy all alsa modules parameters in your /etc/modules.conf to your /etc/modprobe.conf as modprobe looks in modprobe.conf with kernel 2.6.

Try rm /etc/asound.state if that helps.

Look at the output of lsmod to see if are modules are loaded. Is your /etc/rc.d/rc.hotplug file executable ?

drxsmurf 07-13-2004 04:43 PM

Quote:

Originally posted by SyBorg
I saw this in X :
kmixctrl: ERROR: Alsa mixer cannot be found.
Please check that the soundcard is installed and the
soundcard driver is loaded.
kmixctrl:
kmixctrl: ERROR: Alsa mixer cannot be found.
Please check that the soundcard is installed and the
soundcard driver is loaded.
kmixctrl:
ALSA lib pcm_hw.c:549:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
ALSA lib pcm_hw.c:549:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
ALSA lib pcm_hw.c:549:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe [/B]
Where did you see that in X?
I have the exact same problem that you are having. I also use KDE and am unable to keep sound working after a reboot or reloading X.

SyBorg 07-13-2004 11:51 PM

Now I'm confused, my sound is working again

Here's what I did

- started X, no sound
- ran alsaconf, sound's back
- listened to some music, checked some video while playing with the mixer/alsa tools
- went to bed (Italy here)

This morning I started KDE (as user, not as root) to see if there was any hint for me.... bingo?!? Sound works without forcing alsaconf?!? Maybe I have set up something 'magic' in the mixer?



drxsmurf : startx &> ~/x.log then open up x.log with kedit/kwrite/yourfavoriteeditor

drxsmurf 07-14-2004 03:48 AM

Quote:

Originally posted by SyBorg
This morning I started KDE (as user, not as root) to see if there was any hint for me.... bingo?!? Sound works without forcing alsaconf?!? Maybe I have set up something 'magic' in the mixer?

Nothing wrong with good luck :)

I notice that whenever I run 'alsaconf', the last window presented during the configuration mentions a program called 'rcalsasound start'. Maybe this should be added to rc.d or something like that? I don't really know. Congrats on your success, though :p

hkctr 07-14-2004 09:20 AM

Run 'alsactl store' after alsamixer to store your sound settings. alsactl restore is run automatically (/etc/rc.d/rc.alsa) when you boot and restores your previously saved sound settings.

rekcals 08-03-2004 06:12 AM

Have a look at /dev/dsp and /dev/audio, my old ones pointed to /dev/dsp0 etc which no longer worked, I needed /dev/dsp1.

khellendros 09-08-2004 03:44 PM

What I had to do, was go into kmixer and tell it not to reload its settings on startup. It kept overwriting my alsa defined settings. Works well now!

THEHERO 09-08-2004 04:48 PM

Quote:

Originally posted by khellendros
What I had to do, was go into kmixer and tell it not to reload its settings on startup. It kept overwriting my alsa defined settings. Works well now!


Exactly what I did except I turned off Kmixer completely.


All times are GMT -5. The time now is 02:01 AM.