LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-04-2004, 11:48 PM   #1
Chryzmo
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 10.1
Posts: 180

Rep: Reputation: 30
Slackware 10 - Problem Playing DVD Movies


Hello,

I have been looking through the forums for the past couple of hours and I still cannot figure out how to fix this problem. I have a DVD-RW drive that, at the moment, I just want to use as a normal DVD drive to play movies on. I have tried using both Xine and MPlayer to play movies, but I get the following errors with them:

Xine:
$ xine
This is xine (X11 gui) - a free video player v0.99.2.
(c) 2000-2004 The xine Team.
libdvdnav: Using dvdnav version 1-rc7 from http://xine.sf.net
libdvdread: Using libdvdcss version 1.2.8 for DVD access
libdvdread: Could not open /dev/dvd with libdvdcss.
libdvdread: Can't open /dev/dvd for reading
libdvdnav: vm: faild to open/read the DVD
libdvdnav: Using dvdnav version 1-rc7 from http://xine.sf.net
libdvdread: Using libdvdcss version 1.2.8 for DVD access
libdvdread: Could not open /dev/dvd with libdvdcss.
libdvdread: Can't open /dev/dvd for reading
libdvdnav: vm: faild to open/read the DVD

MPlayer:
$ mplayer dvd://1
mplayer: /usr/lib/libGL.so.1: no version information available (required by mplayer)
MPlayer 1.0pre4-3.3.3 (C) 2000-2004 MPlayer Team

CPU: Advanced Micro Devices Athlon 4 /Athlon MP/XP Palomino 1596 MHz (Family: 6, Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.
Reading config file /etc/mplayer/mplayer.conf
Reading config file /home/tathlyn/.mplayer/config
Reading /home/tathlyn/.mplayer/codecs.conf: Can't open '/home/tathlyn/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: 66 audio & 176 video codecs
font: can't open file: /home/tathlyn/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
Using usleep() timing
Can't open input config file /home/tathlyn/.mplayer/input.conf: No such file or directory
Can't open input config file /etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config

Playing dvd://1.
libdvdread: Using libdvdcss version 1.2.8 for DVD access
libdvdread: Could not open /dev/dvd with libdvdcss.
libdvdread: Can't open /dev/dvd for reading
Couldn't open DVD device: /dev/dvd


Exiting... (End of file)

My /dev/dvd link is a link from /dev/hdd, which is my DVD drive. I even did chmod 666 on /dev/dvd. My problem should not be permissions. I know the drive plays movies too, because I have played them in Windows XP.

Here is my /etc/fstab file if it may help:

/dev/hdb5 swap swap defaults 0 0
/dev/hdb1 / ext3 defaults 1 1
/dev/hda1 /mnt/win_c vfat auto,gid=100,umask=0 1 0
/dev/cdrom /mnt/cdrom iso9660 noauto,users,ro 0 0
/dev/hdd /mnt/dvd iso9660 udf,noauto,users,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,users 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0


I am completely stumped as to what the problem may be. I am willing to try anything to get this working, I will even try different players if that may make a difference, these two just seemed to be the most popular and I had them installed already. Any help would be appreciated.

Thanks,
Chris

Last edited by Chryzmo; 12-04-2004 at 11:50 PM.
 
Old 12-05-2004, 12:32 AM   #2
zhangmaike
Member
 
Registered: Oct 2004
Distribution: Slackware
Posts: 376

Rep: Reputation: 31
Can you mount dvd's / cd's in that drive?
 
Old 12-05-2004, 03:42 AM   #3
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
/dev/hdd /mnt/dvd iso9660 udf,noauto,users,ro 0 0

should be:

/dev/hdd /mnt/dvd iso9660,udf noauto,users,ro 0 0

sl mritch.
 
Old 12-05-2004, 06:59 AM   #4
hayesben
LQ Newbie
 
Registered: Jul 2004
Location: Peterborough, England
Distribution: Slackware 10 (moving from RHEL 3 WS)
Posts: 27

Rep: Reputation: 15
Chryzmo

Change your fstab as mritch has suggested. Another way to get it to work is to change the configuration in the application to point to your /dev/hdd .

Ben

Last edited by hayesben; 12-05-2004 at 07:01 AM.
 
Old 12-05-2004, 07:23 AM   #5
JunctaJuvant
Member
 
Registered: May 2003
Location: Wageningen, the Netherlands
Distribution: OS X
Posts: 488

Rep: Reputation: 31
Another possibility: does playback fail when you are logged in as root?
I couldn't play cd's untill I added my normal account to the appropriate groups in
/etc/group.

And aren't you going to have problems mounting stuf if you don't specify a filesystemtype?
I mean "/dev/dvd /mnt/dvd iso9660 udf,noauto,users,ro 0 0" looked ok to me, with the 3rd field being the filesystem, but I'm no expert.


JJ
 
Old 12-05-2004, 09:30 AM   #6
Chryzmo
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 10.1
Posts: 180

Original Poster
Rep: Reputation: 30
I tried changing my /etc/fstab, but that did not help. I can mount normal data CDs and music CDs play without a problem. It is only video DVDs that I cannot mount. When I try to mount the DVD it tells me:

$ mount /mnt/dvd
mount: No medium found

Even as root it says the same thing. This leads me to think there is a problem with how the drive is set up. I think I did have it working and playing DVDs in Slackware 9.1, so I don't think the problem is that my drive isn't supported.

Could it be something that was changed in the kernel config between the two releases of Slackware? I am willing to try compiling a 2.6.x kernel if it may help, I am still using the default kernel(2.4.26).

Thanks

edit:
I set xine to look at /dev/hdd instead of /dev/hdd and that did nothing.

Last edited by Chryzmo; 12-05-2004 at 09:38 AM.
 
Old 12-05-2004, 09:49 AM   #7
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
put in a data-udfformatted-dvd in your drive and do:

# mount -t udf /dev/hdd /mnt/dvd

try to access it. does it work?

i too don't think it's a prob with your drive. btw: for playing dvd's they don't have to be mounted. the player (likely xine or so) will take care for it. are your css recent (needed for decode the video data)? and check if your kernel is compiled with udf support:

$ dmesg | grep udf
udf: registering filesystem

sl mritch.
 
Old 12-05-2004, 10:48 AM   #8
Chryzmo
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 10.1
Posts: 180

Original Poster
Rep: Reputation: 30
OK, I think we found the problem. Your first suggestion didn't work:

# mount -t udf /dev/hdd /mnt/dvd
mount: block device /dev/hdd is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/hdd,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)

Then, I checked to see if udf is supported by my kernel:
$ dmesg | grep udf
$

It didn't say anything, which I think means it is not supported. So, to add it do I need to recompile the kernel or can I add it as a module?

Also, I was wondering is there a way to reload the /etc/fstab file without rebooting. There are times when all I need to do is change one small thing and a reboot just seemed kind of long when it's only the one file I need reloaded.

Thanks
 
Old 12-05-2004, 11:33 AM   #9
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
to be sure it really isn't in the kernel:

# grep UDF /boot/config-<kernel-version>
CONFIG_UDF_FS=y
CONFIG_UDF_RW=y (<- only needed for writing)
y .. compiled in
m .. as module

look in /lib/modules/<kernel-version>/kernel/fs ..driver/fs or somewhere there. the module may be called udf.o (?). if it's there do "# modprobe udf" to add it to your kernel. normally this should be inserted automatic when accessing a dvd.

if it's not: get a new precompiled kernel or roll your own.

sl mritch.
 
Old 12-05-2004, 12:02 PM   #10
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
well...i read that dvd-playing is only ok when this drive is master ( not slave ).
is hdd a slave-drive ?

egag
 
Old 12-05-2004, 12:46 PM   #11
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
that's not true. it doesn't make any difference if it's master or slave.

hdd is always slave.
hda = master at ide0 (primary, major 3, minor 0)
hdb = slave at ide0 (primary, major 3, minor 64)
hdc = master at ide1 (secondary, major 22, minor 0)
hdd = slave at ide1 (sec., major 22, minor 64)
hde = master at ide2 (tertiary, major 33.....
...

sl mritch.
 
Old 12-05-2004, 04:01 PM   #12
JunctaJuvant
Member
 
Registered: May 2003
Location: Wageningen, the Netherlands
Distribution: OS X
Posts: 488

Rep: Reputation: 31
Quote:
Also, I was wondering is there a way to reload the /etc/fstab file without rebooting.
I thought fstab changes work immediately, isn't the fstab file simply read instead of loaded? Just curious.

JJ
 
Old 12-05-2004, 05:12 PM   #13
hayesben
LQ Newbie
 
Registered: Jul 2004
Location: Peterborough, England
Distribution: Slackware 10 (moving from RHEL 3 WS)
Posts: 27

Rep: Reputation: 15
Another thing you could do is take the udf out of the fstab file and see if that works for you. I don't have this listed in my fstab and I've yet to have any issues/problems.

Ben
 
Old 12-05-2004, 05:17 PM   #14
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
@jj

you're right. it is. if the drive is already mounted and you can't unmount it because it's in use (ex. / ) and you want to remount it you can do something like this:

# mount -n -o remount,<options> /mountpoint

sl mritch.

Last edited by mritch; 12-05-2004 at 05:39 PM.
 
Old 12-06-2004, 09:17 AM   #15
WilliamS
Member
 
Registered: Nov 2003
Location: 46N 76W
Distribution: Slackware 14.1
Posts: 375

Rep: Reputation: 31
I could make both mplayer and xine work after I did something like:
ln -sf /dev/hdx /dev/dvd
where hdx is my dvdrw drive.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
suse 10 64 bit and playing dvd movies ? unionjak Suse/Novell 8 11-28-2005 11:41 AM
Suse 9.3 - playing dvd movies shazam27 Suse/Novell 18 08-22-2005 10:59 AM
playing dvd movies jappstam12345 Mandriva 10 03-29-2005 07:20 AM
Playing dvd movies off of remote computer? mrsolo Linux - Software 2 08-26-2004 09:19 PM
Playing DVD movies under RH9 Bateluer Linux - Software 6 09-13-2003 10:12 PM


All times are GMT -5. The time now is 11:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration