LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-15-2004, 03:57 AM   #1
taek
LQ Newbie
 
Registered: Aug 2004
Location: Seoul
Distribution: slackware
Posts: 10

Rep: Reputation: 0
Unhappy slackware 10 dhcpcd problem solved yet?


Hey, I'm really dying to know what is going on here. I have used slackware 9.1 without any problem for a while and recently I have upgraded to slackware 10, which gives me a dhcp problem.

I'm using RealTek RTL8139 card and configured the dhcp using netconfig. After reinstalling slackware three times and sleepless nights I found that rc.inet1 starts dhcpcd OK during booting process, but after I log in network just doesn't work. If I check the network with ifconfig, my eth0 looks OK. When I tried a new rc.inet1 file (short one from tldp.org's DHCP mini HOWTO), then it worked for a couple bootings and stopped working? I also tried to put dhcpcd in rc.local and almost everything I could think of, but it doesn't work.

The only way to use network is to do the following everytime I log in (which I don't want to):
> su
> dhcpcd -k (kill dhcpcd)
> dhcpcd

Then dhcpcd starts and works fine with no problem. I really don't understand how this is possible! I tried FC and Mandrake to check and they worked just fine (But, I want to use slackware!) I found the similar posts in this forum with no solution. If somebody knows what could be a problem, please let us know. I'm willing to try anything now.

Last edited by taek; 08-15-2004 at 06:14 AM.
 
Old 08-15-2004, 07:38 AM   #2
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,314

Rep: Reputation: 139Reputation: 139
Quote:
The only way to use network is to do the following everytime I log in (which I don't want to):
> su
> dhcpcd -k (kill dhcpcd)
> dhcpcd
You should be able to reproduce the above net effect of those commands by placing this in rc.local:

/sbin/dhcpcd -k
/sbin/dhcpcd

If that doesn't work(not clear whether you already tried it) then something starting after rc.local runs is causing the trouble. If your using kde you can make a little bash script to run those commands(dhcpcd -k and dhcpcd), have it run with suid root permissions and put the script in your ~/.kde/Autostart directory.
 
Old 08-15-2004, 07:59 AM   #3
taek
LQ Newbie
 
Registered: Aug 2004
Location: Seoul
Distribution: slackware
Posts: 10

Original Poster
Rep: Reputation: 0
Thanks for a quick reply. I tried to put those two lines in rc.local, but didn't work. I'm not sure what is starting after rc.local. When I didn't use X, it didn't work either (so not startx or gdm I'm using). I thought about writing a short script, but don't know how (and it's best if I didn't have to do that). I would appreciate if you could let me know how to write a script. Thanks again!
 
Old 08-15-2004, 08:22 AM   #4
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware-current
Posts: 1,244

Rep: Reputation: 47
I had a similar problem at one point. Hotplug wanted to load the wrong module for my nic card. It kept loading tulip rather than what mine actually needed. The symptoms were similar to yours. I would have to kill dhcpcd and restart. Sometimes it would just sort of die after a time period. I had to add tulip to the blacklist for hotplug. YMMV.
 
Old 08-15-2004, 10:08 AM   #5
taek
LQ Newbie
 
Registered: Aug 2004
Location: Seoul
Distribution: slackware
Posts: 10

Original Poster
Rep: Reputation: 0
Smile

Finally I found out my problem! It turns out that dhcpcd was not killed correctly (?) at shutdown. I commented the following second line and added the last line in /etc/rc.d/rc.6 and now it works just fine:

# Try to kill dhcpcd so the DHCP leases can be returned:
#killall -15 dhcpcd 1> /dev/null 2> /dev/null
/sbin/dhcpcd -k

I don't know why the second line doesn't do its job yet, but I don't really care anymore. Thank you for your help!
 
Old 08-15-2004, 10:44 AM   #6
cardak
LQ Newbie
 
Registered: Feb 2004
Location: Puebla, Mexico
Distribution: Fedora Core
Posts: 3

Rep: Reputation: 0
me too

i alredy installed slackware 10, but it appears a message that say, that appear i have not any ethernet adapter, i use two realtek 8139, and it doesn't work, what sould i do?,

one nic to internet via dhcp
and the another for home net

thanks....

(i have to use mandrake 10 CD, and it works perfect)
 
Old 08-15-2004, 07:01 PM   #7
taek
LQ Newbie
 
Registered: Aug 2004
Location: Seoul
Distribution: slackware
Posts: 10

Original Poster
Rep: Reputation: 0
I'm using hotplug (I installed hotplug package, and chmod a+x /etc/rc.d/rc.hotplug) and it is detecting network card correctly (8139too) during the booting process. Or, could it be tcpip package that may not be installed in your system? I'm not sure if this helps.
 
Old 08-16-2004, 12:55 AM   #8
waever
Member
 
Registered: Oct 2003
Location: Hamilton,ON
Distribution: LFS
Posts: 46

Rep: Reputation: 16
for dhcp, I use the kernel level autoconfiguration in kernel 2.6.7
Just check the network options.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slackware dhcpcd client? chbin Slackware 15 03-17-2005 08:28 AM
/sbin/dhcpcd: not running - Slackware 10 jtp51 Slackware 6 10-14-2004 12:40 PM
Slackware 8 and DHCPCD - Timed out likwid818 Linux - Networking 6 10-22-2003 10:45 PM
DHCPCD / Slackware 8.0 Problem romanivice Linux - Networking 3 02-15-2002 08:26 PM
DHCPCD in Slackware 8.0 Floppy Linux - Networking 3 02-10-2002 07:58 AM


All times are GMT -5. The time now is 05:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration