LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-12-2004, 03:40 PM   #1
jtp51
Member
 
Registered: Dec 2002
Location: Omaha, Nebraska
Distribution: Ubuntu 8.10
Posts: 79

Rep: Reputation: 15
Slackware 10 dhcpcd MAC address on a laptop questions


Trust me, I have been scanning all of the prior LQ dhcpcd posts and I still can't solve my issue. I have validated that my network card in the laptop does work, since it will work with a static IP address.

Therefore, I am sorry that I have to ask this question again..

I am running Slackware 10, kernel: 2.4.26. After selecting DHCP in netconfig:

1. If I run ifconfig, I only get the 'lo' entry. If I run ifconfig -a then I get my eth0 entry. As I understand, this means that my eth0 is not seen.

What are the steps to correct this?

I do have eth0 showing up at start up and eepro100.c is there as well.


2. During netconfig; should I choose DHCP or loopback?


3. I don't have a DHCP Hostname available to me, is this causing the issue?


4. When I type the following in the directory: /etc/rc.d/

./rc.inet1 stop

I get the message:

**** /sbin/dhcpcd: not running

If I type:

./rc.inet1 start

I get the message:

dhcpcd: MAC address = 00:d059:c5:1e:b5

What does all this mean?


5. I assume that I need to set-up the client daemon (dhcpcd), thus I followed DHCP mini-HOWTO at:

http://www.tldp.org/HOWTO/DHCP/x74.html#NAMESERVER

However, how do I setup my dhcpd.conf file? SiegeX post on LQ is really good, however this still is very confusing.

Any direction would be helpful, I like Slackware 10, everything runs great except DHCP as of right now...

Thank you for reading this post.

Last edited by jtp51; 10-12-2004 at 03:42 PM.
 
Old 10-12-2004, 03:53 PM   #2
Oderus
Member
 
Registered: Sep 2004
Posts: 52

Rep: Reputation: 15
It sounds like you may have the same problem I did.

If after you bootup and you see only your 'lo' then it's because it didn't init your eth0 network card properly.
Reasons could be, 1) failed negotiation, 2) bad cable 3) wrong driver or no driver loaded or 4) nothing.
I have a wireless card WP11 and I had to add a line to my /etc/rc.d/rc.local file to have dhcpcd load using my eth0 card as follows: /sbin/dhcpd eth0
that's all. I also had to add my ESSID and WEP Key but that's more than you need to worry about.

from the command line just type 'dhcpcd eth0' as root and see what happens..
Providing you could get it to work with just a static address, this hopefully will help.
 
Old 10-12-2004, 04:24 PM   #3
jtp51
Member
 
Registered: Dec 2002
Location: Omaha, Nebraska
Distribution: Ubuntu 8.10
Posts: 79

Original Poster
Rep: Reputation: 15
Thanks for the reply Oderus.

From the /sbin directory, I ran

./dhcpcd eth0

And I did not get anything returned, plus it took about 20 seconds for my shell prompt to return.

I typed ifconfig again and I still only saw the 'lo' entry.

I have tried googling this subject as well without much luck.
 
Old 10-12-2004, 05:14 PM   #4
Oderus
Member
 
Registered: Sep 2004
Posts: 52

Rep: Reputation: 15
Your 20 second delay tells me you have no support for your network card..

what network card have you got?
try dmesg and look for that card name if at all... dmseg | grep name of card works great.
i.e.: to check usb stuff, dmseg | grep usb

also check out /etc/inetd.conf and make sure you have eth0 setup for dhcp .. you can also enable debug mode there by saying YES to the last line... (cant remember the syntax off-hand)
 
Old 10-12-2004, 06:42 PM   #5
rotvogel
Member
 
Registered: Oct 2003
Posts: 534

Rep: Reputation: 30
I think the nic module is loaded and that the problem is more likely with the dhcp server/dhcp client communications. If the dhcpcd client doesn't see a nic to configure it starts complaining about that and not showing the MAC address of the card

man dhcpcd had a good suggestion : turn on logging to see what's happening.
Code:
 -d     With  this  flag  dhcpcd  will syslog(LOG_DEBUG,...) messages for about every step it does.  It's recom_
              mended to use this option since it doesn't really produce too much  output  but  will  greatly  help  in
              resolving  a problems if any.  dhcpcd uses LOCAL0 syslog facility for its output. To catch dhcpcd debug_
              ging output add the following line to /etc/syslog.conf file:

              local0.*     /var/log/dhcpcd.log

              and then refresh syslogd daemon:

              kill -1 `cat /var/run/syslogd.pid`
Do you have a firewall enabled ? Are your dhcp ports open for the dhcp server ?

Last edited by rotvogel; 10-12-2004 at 06:43 PM.
 
Old 10-12-2004, 09:55 PM   #6
jtp51
Member
 
Registered: Dec 2002
Location: Omaha, Nebraska
Distribution: Ubuntu 8.10
Posts: 79

Original Poster
Rep: Reputation: 15
No firewall enabled and ports are open on dhcp server. The only reason I know this is because the SuSE 9.1 Professional is using DHCP without any issues.

I will run the debugging first thing in the morning.

I guess the million dollar question is 'Do I setup my dhcpd.conf file?' Again, SiegeX post on LQ is really good, however this still is very confusing.

Thank you for reading this post.
 
Old 10-13-2004, 09:23 AM   #7
Oderus
Member
 
Registered: Sep 2004
Posts: 52

Rep: Reputation: 15
I wouldn't bother with the dhcpcd.conf file ..
You may want to check out the /etc/rc.d/rc.inet1.conf config and make you have a DHCP hostname and that DHCP is enabled for eth0. You can also enable debug mode for DHCP in the same file at the bottom, just say YES to the debug DHCP option.
 
Old 10-13-2004, 12:34 PM   #8
jtp51
Member
 
Registered: Dec 2002
Location: Omaha, Nebraska
Distribution: Ubuntu 8.10
Posts: 79

Original Poster
Rep: Reputation: 15
We don't use DHCP hostname at my office. I know, I have asked over and over. At home, I do have a DHCP hostname from my ISP Cable Modem provider and everything works fine.
 
Old 10-13-2004, 01:31 PM   #9
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
It may be that the kernel module your NIC needs has not been loaded. What exact NIC are you using, and what is the output from lsmod?

Also, have you tried manually bouncing your eth0 interface? Sometimes that's all it takes
Code:
ifconfig
ifconfig eth0 down
ifconfig eth0 up
ifconfig
The first command shows the current status, the next 2 steps bring the interface down and then up, and the last command again shows the status. If you see a value in the inet address field, you should be ready to surf. Good luck with it -- J.W.
 
Old 10-13-2004, 04:21 PM   #10
jtp51
Member
 
Registered: Dec 2002
Location: Omaha, Nebraska
Distribution: Ubuntu 8.10
Posts: 79

Original Poster
Rep: Reputation: 15
dhcpcd eth0 -d log results

I ran:

dhcpcd eth0 -d

and the log file came back with:


broadcasting DHCP_DISCOVER
timed out waiting for a valid DHCP server response


The NIC card I have is:


Module Size Used by

eepro100 19252 0
mii 2272 0 [eepro100]



Is this correct? Because my specs are: The Evo N400c comes with the following interface: 1 RJ-45 (NIC):
Ethernet - The integrated combo card NIC is an Intel EEPRO100 supported.

Yes, I have tried to manually shutdown and I get the following:


ifconfig

-> The lo listing only

ifconfig eth0 down
ifconfig eth0 up
ifconfig

-> The lo and eth0 listings



However, the eth0 does not have an IP address, but states:

UP BROADCAST NOTRAILERS RUNNING MULTICAST


Do I need to turn off Multicast? How would I do that?

Thank you for all of the responses so far... we're getting there....
 
Old 10-13-2004, 04:46 PM   #11
Oderus
Member
 
Registered: Sep 2004
Posts: 52

Rep: Reputation: 15
I think it's still autonegotiation failing ..
how is your home network setup?? One cable/dsl router or direct to the internet?

I would either try to force it to 10Mb or power off, then power back on with the network cable plugged in.
That helped for me on my server, but it's a little older then your system seems to be.
 
Old 10-13-2004, 05:48 PM   #12
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
Another thing to try would be to manually restart DHCP
Code:
dhcpcd -r eth0
If nothing happens after about 30 seconds, Ctl-C to break out of it. Then take eth0 down and up again, and run ifconfig to check the status. I can't say whether that will solve the problem or not but it's worth a try. -- J.W.
 
Old 10-14-2004, 12:38 PM   #13
jtp51
Member
 
Registered: Dec 2002
Location: Omaha, Nebraska
Distribution: Ubuntu 8.10
Posts: 79

Original Poster
Rep: Reputation: 15
Thread Closed

This turned out to be the subnet DHCP scope was out of addresses to distribute.

THANK YOU TO ALL WHOM HAVE TOOK THE TIME TO READ THIS!

Thread Closed
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MAC address filtering in Slackware? houler Linux - Networking 9 05-12-2006 07:34 AM
Questions on DHCP Filtering via MAC address brainee28 Linux - Networking 1 02-03-2005 02:11 PM
MAC address iptables questions scottman Linux - Security 2 10-01-2004 01:26 PM
couple C++ questions - mac address & last file access time. BrianK Programming 3 07-17-2002 03:17 AM
RH7.2 dhcpcd & MAC address Nairobi Linux - Networking 4 06-24-2002 03:39 PM


All times are GMT -5. The time now is 06:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration