LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-04-2006, 02:29 PM   #16
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 65

I know the feeling.....

You could try
Code:
lsmod > /somewhere/to/save.txt
and retreive that file...
 
Old 06-04-2006, 03:12 PM   #17
jmattshirey
LQ Newbie
 
Registered: Jun 2006
Posts: 29

Original Poster
Rep: Reputation: 15
I got all of the information but when I tried to post it the damn thing gave me an error and erased my message.... I will try to post it again in a bit.
 
Old 06-04-2006, 03:35 PM   #18
drlouis
Member
 
Registered: Aug 2004
Location: Ne
Distribution: slackware 12 on Dell XPS m1710
Posts: 90

Rep: Reputation: 15
Quote:
Originally Posted by jmattshirey
I got all of the information but when I tried to post it the damn thing gave me an error and erased my message.... I will try to post it again in a bit.
I've been burned by this phenomenon enough that if I have a long/complex post or email I select/copy the text prior to posting so if it gets lost, I can simply right click/past and I'm ready to post again.
 
Old 06-04-2006, 04:16 PM   #19
jmattshirey
LQ Newbie
 
Registered: Jun 2006
Posts: 29

Original Poster
Rep: Reputation: 15
lspci

00:00.0 Host bridge: nVidia Corporation nForce2 AGP (different version?) (rev c1)
00:00.1 RAM Memory: nVidia Corporation nForce2 Memory Controller 1 (rev c1)
00:00.2 RAM Memory: nVidia Corporation nForce2 Memory Controller 4 (rev c1)
00:00.3 RAM Memory: nVidia Corporation nForce2 Memory Controller 3 (rev c1)
00:00.4 RAM Memory: nVidia Corporation nForce2 Memory Controller 2 (rev c1)
00:00.5 RAM Memory: nVidia Corporation nForce2 Memory Controller 5 (rev c1)
00:01.0 ISA bridge: nVidia Corporation nForce2 ISA bridge (rev a4)
00:01.1 SMBus: nVidia Corporation nForce2 SMBus (MCP) (rev a2)
00:02.0 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:02.1 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:02.2 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:04.0 Ethernet Controller: nVidia Corporation nForce2 Ethernet Controller (rev a3)
00:05.0 Multimedia Audio Controller: nVidia Corporation nForce Audio Process Unit (rev a2)
00:06.0 Multimedia Audio Controller: nVidia Corporation nForce2 AC97 Audio Controller (MCP) (rev a1)
00:08.0 PCI bridge: nVidia Corporation nForce2 External PCI bridge (rev a3)
00:09.0 IDE interface: nVidia Corporation nForce2 IDE (rev a2)
00:0d.0 Firewire (IEEE 1394): nVidia Corporation nForce2 Firewire (IEEE 1394) Controller (rev a3)
00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev c1)
01:04.0 Ethernet Controller: Marvell Technology Group Ltd. 88E8001 Gig. Ethernet Controller (rev 13)
01:07.0 VGA Compatible Controller: nVidia Corporation NV18 [GeForce4 MX 4000 AGP 8x] (rev c1)
01:08.0 Ethernet Controller: D-Link System Inc. RTL8139 Ethernet (rev 10)
01.0b.0 Raid Bus Controller: Silicon Image, Inc. Sil 3112 [SATALink/SATARaid] Serial ATA Controller (rev 02)
 
Old 06-04-2006, 04:17 PM   #20
jmattshirey
LQ Newbie
 
Registered: Jun 2006
Posts: 29

Original Poster
Rep: Reputation: 15
lsmod

Module Size Used by Not Tainted
soundcore 3396 0 (autoclean)
8139too 13928 1
ii 2272 0 [8139too]
crc32 2880 0 [8139too]
pcacia_core 39172 0
ide-scsi 9392 0
agpgart 45508 0 (unused)
 
Old 06-04-2006, 04:18 PM   #21
jmattshirey
LQ Newbie
 
Registered: Jun 2006
Posts: 29

Original Poster
Rep: Reputation: 15
ifconfig –a

etho Link encap: Ethernet HWaddr: 00:13:46:3A:70:08
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:9 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
Collision:0 txqueuelen: 1000
RX bytes: 1509 (1.4 Kb) TX bytes: 0 (0 b)


lo Link encap: Local loopback
inet addr: 127.0.0.1 Mask: 255.0.0.0
UP LOOPBACK RUNNING MTU:26436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions: 0 txqueuelen:0
RX bytes: 7964 (7.7 Kb) TX bytes: 7964 (7.7 Kb)
 
Old 06-04-2006, 05:14 PM   #22
jmattshirey
LQ Newbie
 
Registered: Jun 2006
Posts: 29

Original Poster
Rep: Reputation: 15
any suggestions anyone?

 
Old 06-04-2006, 06:01 PM   #23
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,964
Blog Entries: 11

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
The driver for the gigabit thing isn't loaded, try
modprobe skge

Also, it's not quite clear which device was picked up as which
eth-interface. To make sure they are assigned correctly edit
/etc/modules.conf and add lines like
alias eth0 8139too
alias eth1 skge
or the other way round ...


If you don't have a gigabit switch the 8139 is probably the more
sensible choice, I'm not sure whether skge is even part of the
2.4 kernels at this stage.


Cheers,
Tink
 
Old 06-04-2006, 08:28 PM   #24
jmattshirey
LQ Newbie
 
Registered: Jun 2006
Posts: 29

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Tinkster
The driver for the gigabit thing isn't loaded, try
modprobe skge
Aigt... I tried running modprobe skge but it said Can't Locate the module skge


Quote:
Originally Posted by Tinkster
Also, it's not quite clear which device was picked up as which
eth-interface. To make sure they are assigned correctly edit
/etc/modules.conf and add lines like
alias eth0 8139too
alias eth1 skge
or the other way round ...
Im not sure how to edit /etc/modules.conf. How would I go about this?


Quote:
Originally Posted by Tinkster
If you don't have a gigabit switch the 8139 is probably the more
sensible choice, I'm not sure whether skge is even part of the
2.4 kernels at this stage.
 
Old 06-04-2006, 08:35 PM   #25
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,964
Blog Entries: 11

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
Quote:
Originally Posted by jmattshirey
Aigt... I tried running modprobe skge but it said Can't Locate the module skge

In that case you may have to recompile your kernel.
I checked later on, and 2.4.32 for instance knows the device.

Quote:
Originally Posted by jmattshirey
Im not sure how to edit /etc/modules.conf. How would I go about this?
Become root, pick your favourite text editor and edit it.
In the long run I highly recommend learning vi since you'd
be hard-pressed to find a distro or other unix that DOESN'T
have it install, in the interim you may want to use the
built-in editor of mc or nano (pico).


Cheers,
Tink

Last edited by Tinkster; 06-04-2006 at 08:36 PM.
 
Old 06-04-2006, 08:58 PM   #26
jmattshirey
LQ Newbie
 
Registered: Jun 2006
Posts: 29

Original Poster
Rep: Reputation: 15
I think im gonna give up on Linux cuz I'm sooooooo lost right now. I have no idea what you just said and I don't want to mess it up.... Thanks for all of the help.
 
Old 06-04-2006, 08:58 PM   #27
jmattshirey
LQ Newbie
 
Registered: Jun 2006
Posts: 29

Original Poster
Rep: Reputation: 15
I think im gonna give up on Linux cuz I'm sooooooo lost right now. I have no idea what you just said and I don't want to mess it up.... Thanks for all of the help.


 
Old 06-04-2006, 09:09 PM   #28
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,964
Blog Entries: 11

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
Sorry, didn't mean to confuse you.

Those are the names of editors.
Here comes a no-brain session for vi

Code:
vi /etc/modprobe.conf
i
alias eth0 8139too
alias eth1 skge
ESC
:wq
i puts vi into insert mode, you then type the text. ESC takes
you out of insert mode, :wq saves the file and quits vi.

Do exactly those, that will edit (or create if you don't have it) the
file with the right content.


Cheers,
Tink
 
Old 06-05-2006, 02:20 PM   #29
tobyl
Member
 
Registered: Apr 2003
Location: uk
Distribution: slackware current
Posts: 743

Rep: Reputation: 50
Don't give up just yet, it's quite common to have problems setting up networking at first.

Tinkster also mentioned pico, and I would recommend you use pico as a text editor, or use an editor such as kedit if you have kde installed and working. You can master the intricacies of vi later on (when you have a spare hour to kill :-))

To use pico, (its dead easy - honest!), and to become root (superuser) for editing config files in the /etc directory, do this:

first become root:
su
(enter your root password) then
pico /etc/modprobe.conf

then make your changes,
to save,
Ctrl-x
you will be prompted to enter y or n
that's it!

I would however consider getting just one ethernet card working first, you can add the others later if needed.
As the 8139too module is being loaded already (this is for your add-on pci nic) it would make sense to start with that. It would I think simplify things by disabling the onboard controllers (nforce & marvell), by turning them off in the bios for now. Then plug your ethernet RJ45 into the correct socket.
I would then go back into slackware, and run netconfig again. There is a pretty good chance you wont need to edit (by hand) any files at all this way.

tobyl
 
Old 06-05-2006, 04:49 PM   #30
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: Slackware®
Posts: 11,040
Blog Entries: 1

Rep: Reputation: 1366Reputation: 1366Reputation: 1366Reputation: 1366Reputation: 1366Reputation: 1366Reputation: 1366Reputation: 1366Reputation: 1366Reputation: 1366
Quote:
Originally Posted by jmattshirey
I think im gonna give up on Linux cuz I'm sooooooo lost right now. I have no idea what you just said and I don't want to mess it up.... Thanks for all of the help.


Hi,

Don't give up yet!

You could read some good online reference. Check out my sig for some good reads.

Sure, Linux can be overwhelming at first but if you get some background on the use you will get comfortable. Just like everything else in life you will need to invest a little time to get some achievements.

Now for the network configuration problem you are experiencing. You have been given some good advice to date.

I would have suggested to do the following;
Code:
#dmesg | grep eth             #see what was recognized
#lsppci -vv                   #get the full pci device info
#lsmod                        #show installed modules
Since you provided the information that the rtl8139 was recognized and that the 8139too is loaded. If you have not run netconfig then you could as root;

Code:
#ifconfig eth0 192.168.0.11       #set static IP
#ifconfig -a                      #check setting
#route -n                         #check routing table
#route add default gw 192.168.0.1 # set gateway IP
#ifconfig eth0 up                 #start eth0 device
#ping google.com                  #check dns OK, /etc/resolv.conf
#ping 72.14.207.99                #ping goggle IP address outside
The first command sets the IP for eth0.
The second command gets the information
The route -n get the routing table. If you don't have default gw then next command sets the IP.

The reason to ping the name is too make sure the DNS is working. If that ping fails then you will need to edit the /etc/resolv.conf file to point to your DNS server.

By using the IP for google.com you confirm that you have access outside your LAN.

If you have any problems then post the output of the above commands. You could cat the files to post into one post. Just do a;
#
Code:
#man cat
to find out how.

man will get you information for commands.

Again I recommend that you checkout the online references.

Last edited by onebuck; 06-05-2006 at 04:50 PM.
 
  


Reply

Tags
ifconfig, lsmod


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10.2 - Problem using Built-in NIC StevenCM Linux - Networking 1 06-03-2006 10:40 PM
nForce2 nic problem, slackware 10 Nan Slackware 1 09-19-2004 06:21 AM
slackware 9.0 sound/nic problem Peacedog Slackware 7 11-20-2003 03:22 PM
Slackware 2nd nic config problem NewbieUser Linux - Networking 3 02-17-2003 05:03 AM
Slackware 2nd nic config problem NewbieUser Linux - Networking 1 02-15-2003 01:03 PM


All times are GMT -5. The time now is 12:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration