LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 10.2 - a problem with keyboard layouts (http://www.linuxquestions.org/questions/slackware-14/slackware-10-2-a-problem-with-keyboard-layouts-426214/)

AndrewR 03-19-2006 03:55 AM

Slackware 10.2 - a problem with keyboard layouts
 
Specifically, I need to enable THREE keyboard layouts in X and switch between them using keyboard shortcut "alt+shift". When I enable just two keyboard layouts like this:

Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,ru"
Option "XkbVariant" ",winkeys"
Option "XkbOptions" "grp:alt_shift_toggle"
EndSection


Everything works just fine. But then I add a third layout (btw, precisely following the example given in xkb documentation):

Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,ru,ua"
Option "XkbVariant" ",winkeys,winkeys"
Option "XkbOptions" "grp:alt_shift_toggle"
EndSection


And the result is: I can't switch layouts with keyboard shortcut anymore.

Now, I'd be grateful if anyone could point out what I am doing wrong here.

320mb 03-20-2006 03:30 PM

Quote:

Originally Posted by AndrewR

Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,ru,ua"
Option "XkbVariant" ",winkeys"
Option "XkbOptions" "grp:alt_shift_toggle"
EndSection


did you try it with just ONE winkeys like you see above??

AndrewR 03-21-2006 03:22 AM

Quote:

Originally Posted by 320mb
did you try it with just ONE winkeys like you see above??

Nope, didn't occur to me. I'll try this and report if it works. Thanks :)


All times are GMT -5. The time now is 10:53 AM.