LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-08-2004, 04:37 PM   #1
bobacronius
LQ Newbie
 
Registered: Jul 2004
Posts: 3

Rep: Reputation: 0
Slackware 10.0 network config issues


I have recently installed Slackware 10.0. Everything went without a problem until I tried getting my network connection up and running. I am using a pretty basic setup: just a cable modem and router with DHCP through Comcast. To go ahead and rule out the physical connection, I know that works as I have windows 2000 installed on a seperate hd and I have a connection there. So, here's what I have configured thus far:

I have a Realtek 8139(a)-based nic.

During install, at netconfig, Slackware detected the card and assigned the module eepro100 (yeah, I thought it odd that it wasn't 8139too) to it.
I entered in the approriate information for DHCP and went ahead.

I checked modules.conf for the module and saw that it was uncommented as should be (the eepro100).

The resolv.conf file looks as such:
search nash01.tn.comcast.net ------>(my dns suffix)
nameserver 68.52.0.6
nameserver 68.52.0.5

I went into the rc.inet1.conf file and edited it for eth0 to have the approriate information (ipaddress, netmask, DHCP enabled, and default gateway). I didn't know what to put into the DHCP hostname entry so I left it blank, as I have never seen anything letting me know if or what my DHCP hostname is. I then restarted rc.inet1.

Still after this, nothing is happening.

So I manually start eth0 by typing:
ifconfig eth0 192.168.1.100 netmask 255.255.255.0 up

And after that if I do a ifconfig, eth0 is showing up now with the correct information there.

I can ping the ipaddress of 192.168.1.100 but not the gateway.

I'm sure I missed something in one of the conf files but I have scoured through forums searching for an answer to a similiar problem and I am at a loss. I had heard of typing dhcpcd eth0 but haven't had any luck using that either....don't know if I'm doing something wrong or what but I get a "stopped" message everytime I enter it, and then I have to exit the process. Everytime I come across someone with the exact same problem that is running Slackware I try the advice given, and still something is amiss. So I have to attribute it to user error as Slackware has been nothing but wonderful to me.

Any help to this Slack newbie is greatly appreciated. I'm pretty new to linux in general and decided to take on the daunting task of using Slackware as my Linux learning tool; talk about getting your feet wet. I've had many years of experience with Microsoft, but decided that I am too dependent on them. So there you go!

Thanks again all.


--------------------------------------
You leave Jack Burton alone!
-Eg Chen
 
Old 07-08-2004, 04:45 PM   #2
Fissional
Member
 
Registered: Jul 2004
Location: Harrison Township MI
Distribution: fluxbox-0.9.13 on Slackware 10.2 2.6.15.1 kernel
Posts: 48

Rep: Reputation: 15
Have you checked dmesg for errors? really it sounds like it should be fine, maybe try

ifconfig eth0 down
ifconfig eth0 up
dhcpcd eth0

I dont know if that would reset the config files you modified or not, but im just tryin to see if you got the config files back to how they came with slack and brought the device up and dhcpcd if it would work, incase you missed something in the config files or setting up manually.
 
Old 07-08-2004, 04:55 PM   #3
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Rep: Reputation: 49
I have Comcast cable internet, hooked to a router, hokked to my Slackware box. My /etc/resolv.conf is

nameserver 192.168.0.1 <-------------------------- IP address of my router
search is-a-geek.com <-------------------------- My computers domain name

Try something like that.
 
Old 07-08-2004, 10:21 PM   #4
bobacronius
LQ Newbie
 
Registered: Jul 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for the speedy reply.

I tried everything that was suggested to no avail.
I checked out the dmesg and everything seemed to initialize fine and nothing was out of the ordinary.

I'm not too familiar with dhcpcd, so maybe I am missing something there, but when I type dhcpcd eth0 it just starts a new line as if it is waiting for some input. When I ctrl-c out of it is when I get the "stopped" message. Is there something I should enter there?

Also, I have noticed that eth0 doesn't start at boot up. I have to manually start it. I know I can set it up for boot, I just have to research which conf file to edit for it.

I changed my resolv.conf file to what shilo suggested and it didn't seem to make any change.

Kind of frustrating as it could be any number of things I'm missing.

Slack recognizes my card, will ping the card itself, and loads the module at boot. I am officially lost.

Again, thank you for the quick reply.

Any further suggestions?
 
Old 07-09-2004, 04:43 AM   #5
rotvogel
Member
 
Registered: Oct 2003
Posts: 534

Rep: Reputation: 30
I would try the 8139too module instead of the eepro100 module.
Are you using hotplugging ? If so, add the eepro100 module to your blacklist.

If you are not using hotplug, comment the eepro100 line in rc.modules and add a line to load the 8139too module there by adding a line in the file /sbin/modprobe 8139too.

After that you could reboot or type commands following as root:
Code:
rmmod eepro100
modprobe 8139too
/etc/rc.d/rc.inet1
Then see what happens.
 
Old 07-09-2004, 06:51 PM   #6
bobacronius
LQ Newbie
 
Registered: Jul 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Well, to all that took the patience to respond, I just wanted you to know that I am currently posting this reply using Slackware 10.0 running Mozilla....so in a nutshell, it works now!

It was the combination of my resolv.conf being off as well as the wrong module being installed.

Again, thank you much for making this Slack newbie a very happy camper!

Till next time...
 
Old 07-10-2004, 11:45 AM   #7
AlexiaDeath
LQ Newbie
 
Registered: Jul 2004
Distribution: Gentoo, Slackware
Posts: 21

Rep: Reputation: 15
Looks like Im in the same boat as you guys... I have a 8139 based NIC and Its does not get an Ip at startup from my router for some reason. I found out this: On first attempt dhcpcd hangs. Ctrl-c and the command(dhcpcd eth1) again andi in a blink it recieves an IP.... Any Ideas?

Oh! Im runing properly uptated slack 9 on a machine with two nics First Is a 3Com NIC that gets loaded pefectly when incoming cable is attached to it...

Last edited by AlexiaDeath; 07-10-2004 at 11:51 AM.
 
Old 07-10-2004, 11:53 AM   #8
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,437

Rep: Reputation: 93
Maybe dhcpd need to be start in background process as mysqld and others.

I would do :
dhcpd eth1 &
 
Old 07-10-2004, 11:56 AM   #9
AlexiaDeath
LQ Newbie
 
Registered: Jul 2004
Distribution: Gentoo, Slackware
Posts: 21

Rep: Reputation: 15
It might be it, but 3com gets loaded perfectly every time. Im still aming to get it to load at startup...

EDIT: OKay.. ran a test... no difference. As long as one dhcpcd hasnt been aborted by ctrl-c it does not get an IP. But if one instance has been aborted it hapens in a blink...

Ill just give some more(in my mind) imortant inf about my system.

On installation only 3Com nic was detedted. At startup there apeared a conflict with two drivers both being atamted to load. 8139too and 8139cp. I tryed blacklisting them in turn. The too version works. Exept when getting an IP. I suspect its badly configured because it was not done during instalation but I have no clue what to fix or where. It apears as if there is not even attempt to get an IP for it during startup inspite the fact that
/etc/rc.d/rc.inet1.conf says to use dhcp.

More Edits:

Okay. Messed with the rc.inet1 and enabled DHCP from there. within the script. It works perfect if run again but on startup it tryes to get the ip BEFORE the drivers get loaded.... WTF! The script is run when the first NIC is loaded. any way of fixing this?

FINAL EDIT:

OKAY! Looks like I fixed it. Moved the adapters initzalization one step down in rc.M script right after hotplug call. That did the trick.

Last edited by AlexiaDeath; 07-10-2004 at 01:36 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sendmail - Config for IP Block's & Config Issues Thom_Redhat Linux - Software 1 04-07-2006 01:29 PM
Slackware 10.1 on Inspiron 6000 Network Issues Chryzmo Slackware 6 09-30-2005 02:59 PM
Slackware Network Config Aeiri Linux - Software 5 02-26-2004 06:15 PM
Slackware 9 network issues GreatHornDragon Slackware 9 05-12-2003 04:07 AM
Network config in Slackware 7.2 current chadm1967 Linux - Networking 2 05-30-2001 06:36 AM


All times are GMT -5. The time now is 04:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration