LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-20-2009, 11:48 AM   #16
Hannes Worst
Member
 
Registered: Jul 2008
Location: Tilburg, The Netherlands
Distribution: Antix, Slackware, NetBSD
Posts: 88

Rep: Reputation: 35
The same problem


Actually I'm experiencing the same problem overhere after the kernelupgrade with slackpkg. I can't get into my system anymore, nor with the huge nor with the generic kernel. I get the same message at boot as you Adriv: "ERROR: No /sbin/init found on dev (or not mounted). Trouble ahead." And then I get a kernel-panic
 
Old 08-20-2009, 11:49 AM   #17
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
Code:
chroot /wherever
mount /proc
mount /sys
mkinitrd ...
 
Old 08-20-2009, 01:32 PM   #18
Hannes Worst
Member
 
Registered: Jul 2008
Location: Tilburg, The Netherlands
Distribution: Antix, Slackware, NetBSD
Posts: 88

Rep: Reputation: 35
Succes with the huge kernel

In the meanwhile I made a succesfull entry to my slackware installation, and discovered that the file vmlinuz was linked to the generic kernel, and the initrd.gz to the huge kernel. (the list of my boot files is virtually the same as yours, Adriv).I don't know if this info is helpfull in this discussion, but I can now approach my Slackware using the huge kernel, by specifying vmlinuz. (I use grub by the way)

Last edited by Hannes Worst; 08-20-2009 at 01:50 PM.
 
Old 08-20-2009, 02:42 PM   #19
dwr1
Member
 
Registered: Aug 2009
Distribution: slack-current
Posts: 46

Rep: Reputation: 17
I just had this problem. I installed the security update (on current), and I also decided to start using the generic kernel with an initrd, instead of the "huge" kernel. So I'm not sure where the problem came from.

I remade the initrd with mkinitrd -F -c. I had my root partitions filesystem in mkinitrd.conf already, and so I assumed it was there. I also ran lilo and it seemed fine. But when I rebooted I came across the same init and unable to load modules error message you've all been getting. (I did later find out by looking at the modules in /boot/initrd-tree that my fs module wasn't there...)

I could, however, boot via the "huge" kernel, which I put in lilo via booting into my system with a rescue cd, chroot'ing into my root partition, making sure all hard disk devices are the same in /dev (i had to symlink sda to hda), and editing lilo.conf and running lilo.

To get the generic kernel working, however, things may be a little strange. Try mkinitrd -c -F -k YOURKERNELNUMBER -m YOURFSMODULEHERE. Then see /boot/initrd-tree/lib/modules/YOURKERNELNUMBER/kernel/fs/ contains your root filesystem module. Then run lilo. That all worked for me, but the error message on boot was still there.

I deleted /boot/initrd.gz and the /boot/initrd-tree ran the mkinitrd command again and it all worked. Lord knows why.

Let me know if you're still having problems.

Last edited by dwr1; 08-20-2009 at 02:44 PM.
 
Old 08-20-2009, 05:12 PM   #20
adriv
Member
 
Registered: Nov 2005
Location: Diessen, The Netherlands
Distribution: Slackware 14.1
Posts: 659

Original Poster
Rep: Reputation: 38
Thanks everyone, it's solved.
Made an extra stanza to lilo.conf, ran lilo and everything is OK now.

Code:
image = /boot/vmlinuz-generic-smp-2.6.27.31-smp
  initrd = /boot/initrd.gz
  root = /dev/sda3
  label = Slackware-smp
  read-only
 
Old 08-20-2009, 06:25 PM   #21
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
The biggest problem you had was not mounting everything you needed,
which is what Robby was trying to tell you in his post.

For future reference, when you boot with the Slackware CD/DVD, it has
a line that tells you a much easier way, which is what bgeddy was
telling you ... boot back into the installed Slackware system:
Code:
In a pinch, you can boot your system from here with a command like:

boot: hugesmp.s root=/dev/hda1 rdinit= ro

In the example above, /dev/hda1 is the / Linux partition.
So all you needed to do was enter "hugesmp.s root=/dev/sda3 rdinit= ro"
and you would have been into your Slackware system. That would have
saved you a lot of time and typing from another system. You're typing
rather than being able to paste also had incorrect data for us to read:
Code:
vmlinuz -> vmlinuz-generic-2.6.27.31
I have always used that, never had to chroot as Robby posted, and have
always been able to get back into an installed Slackware system.

Glad you got it fixed and can now use Slackware again.
 
Old 08-21-2009, 04:06 AM   #22
dwr1
Member
 
Registered: Aug 2009
Distribution: slack-current
Posts: 46

Rep: Reputation: 17
Quote:
Originally Posted by dwr1 View Post
To get the generic kernel working, however, things may be a little strange. Try mkinitrd -c -F -k YOURKERNELNUMBER -m YOURFSMODULEHERE. Then see /boot/initrd-tree/lib/modules/YOURKERNELNUMBER/kernel/fs/ contains your root filesystem module. Then run lilo. That all worked for me, but the error message on boot was still there.
The more I think about this, the more I think I did something stupid like running mkinitrd after I'd ran lilo. Aw, well.
 
Old 08-21-2009, 05:06 AM   #23
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Just noticed something and I'm curious ... and it's probably in
Website Suggestions & Stuff, but, oh well.

On the left under our nick are a few items. The last one down is
Tux on the right, but then some different icons on the right.
For instance, the OP has a Debian swirl icon and a Tux.

Mine has a Tux head on the left and Tux on the right.

dwr1 has a Windows logo (we'll beat him with a wet noodle later)
and a Tux.

I had thought maybe that was set by what we have in Distribution
until I saw dwr1 -- he has slack-current, mine has Slackware. So
that doesn't seem to be it; though LQ's spellchecker doesn't
have Slackware has an entry.

What must I do to change the Tux head to the Slackware logo?
Something like this, but I can supply a better image ... just
have little time atm.

__________________

Edit: That's spooky ... it's changed, and this threads OP
is not the Debian guy, either.
Attached Images
File Type: jpg bluepiSW.jpg (47.7 KB, 9 views)

Last edited by Bruce Hill; 08-21-2009 at 05:08 AM.
 
Old 08-21-2009, 05:39 AM   #24
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 6,963
Blog Entries: 52

Rep: Reputation: Disabled
See this thread, post #16, about the little logos:
http://www.linuxquestions.org/questi...-posts-749091/
 
Old 08-21-2009, 05:50 AM   #25
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
How you get the LQ Tux?
 
Old 08-21-2009, 06:13 AM   #26
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 6,963
Blog Entries: 52

Rep: Reputation: Disabled
What? The little Tux has been there for ages.
 
Old 08-21-2009, 06:33 AM   #27
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
You didn't read my message correctly ... the LQ (LinuxQuestions) Tux.

Yours has a ? on his belly.
 
Old 08-21-2009, 06:41 AM   #28
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 6,963
Blog Entries: 52

Rep: Reputation: Disabled
Yeah, I knew which one you meant. Can't you see yours? The ? means I'm online. Yours has no ?, and if I mouse-over it it says you're offline.

Last edited by brianL; 08-21-2009 at 06:42 AM.
 
Old 08-21-2009, 09:36 AM   #29
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Must have a bug, then, because I was online then (or else how would I have seen the Tuxes?).

At this moment, I am also online:
Code:
Fri Aug 21 22:36:22 CST 2009
and my Tux has no ? in his belly.

Neither does yours, or any other one in this thread.

Mine should always have a ?, because I never cut off my computers,
and am always logged on to LQ.
 
Old 08-21-2009, 10:11 AM   #30
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 6,963
Blog Entries: 52

Rep: Reputation: Disabled
Mmm, it is strange. I don't know the answer.
 
  


Reply

Tags
egrep


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slackpkg kernel upgrade has borked Tap-to-Click on Touchpad BobNutfield Slackware 9 07-18-2009 07:46 AM
upgrade > kernel panic solly Arch 5 12-24-2008 12:00 PM
Slackpkg + Kernel panic tntcoder Slackware 2 06-21-2006 02:13 AM
pacman -Su, kernel upgrade, kernel panic, change distro? jkh Arch 35 03-10-2006 01:14 AM


All times are GMT -5. The time now is 11:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration