LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-16-2009, 03:02 PM   #1
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
[SOLVED] Slackpkg kernel upgrade has borked Tap-to-Click on Touchpad [SOLVED]


Hello Everyone,

Had a kernel upgrade to 2.6.29.6 today and after restarting I no longer have tap-to-click on my laptop touchpad. I know this is the Synaptics driver and it has always worked right away with every version of Slack I have used. I understand that xorg.conf is no longer being read by the system (unless I am mistaken), so I am not sure how to restore this.

Can anyone help?

Thanks in advance,

Bob

Last edited by BobNutfield; 07-19-2009 at 01:54 PM.
 
Old 07-16-2009, 03:56 PM   #2
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Original Poster
Rep: Reputation: 51
SOLVED

I guess I was incorrect. Editing the xorg.conf does still work for this kind of problem and I was able to solve the problem. Sorry for posting so quick...

But I am curious, does synclient get all of its parameters from xorg, or is it possible to edit these parameters outside of xorg? I saw the problem right away from synclient -l, but couldn't edit it.

Thanks
Bob
 
Old 07-16-2009, 09:16 PM   #3
appzer0
LQ Newbie
 
Registered: Nov 2008
Location: France
Distribution: 0Linux, Slackware
Posts: 13

Rep: Reputation: 0
Have a look at the /usr/share/hal/fdi/policy/10osvendor/11-x11-synaptics.fdi file

What I added (then rebooted to make sure it is taken into account):
Code:
<merge key="input.x11_options.TapButton1" type="string">1</merge>
<merge key="input.x11_options.TapButton2" type="string">2</merge>
<merge key="input.x11_options.TapButton3" type="string">3</merge>
<!--Enable vertical scrolling when dragging with two fingers anywhere on the touchpad-->
<merge key="input.x11_options.VertTwoFingerScroll" type="string">false</merge>
 
Old 07-16-2009, 09:38 PM   #4
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Bob,

Mark [SOLVED] on the OP.
 
Old 07-17-2009, 08:56 AM   #5
sahko
Senior Member
 
Registered: Sep 2008
Distribution: Slackware
Posts: 1,041

Rep: Reputation: Disabled
Quote:
Originally Posted by appzer0 View Post
Have a look at the /usr/share/hal/fdi/policy/10osvendor/11-x11-synaptics.fdi file

What I added (then rebooted to make sure it is taken into account):
Code:
<merge key="input.x11_options.TapButton1" type="string">1</merge>
<merge key="input.x11_options.TapButton2" type="string">2</merge>
<merge key="input.x11_options.TapButton3" type="string">3</merge>
<!--Enable vertical scrolling when dragging with two fingers anywhere on the touchpad-->
<merge key="input.x11_options.VertTwoFingerScroll" type="string">false</merge>
You shouldn't edit the fdi files in /usr/share directly. It's preferable to copy them to /etc first and then edit those files.
That way you will have a backup of the original, in case anything goes wrong.
 
Old 07-17-2009, 03:41 PM   #6
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 214

Rep: Reputation: 44
I got this also i don't know how it happend but after the upgrade i had the file /etc/modprobe.d/psmouse~.conf that had the "options psmouse proto=imps" line uncommented.
So i needed to remove that file.
 
Old 07-17-2009, 06:29 PM   #7
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally Posted by Nille_kungen View Post
I got this also i don't know how it happend but after the upgrade i had the file /etc/modprobe.d/psmouse~.conf that had the "options psmouse proto=imps" line uncommented.
So i needed to remove that file.
If you're going to run -current, you're obligated to read the ChangeLog.txt:
Code:
mingdao@paul:~$ less /backup2/ftp/pub/Linux/Slackware/slackware-current/ChangeLog.txt
+--------------------------+
Wed Jul 15 20:51:29 CDT 2009
<snip>
a/udev-141-i486-3.txz:  Rebuilt.  Added aic94xx to /etc/modprobe.d/blacklist.
  Change config files in /etc/modprobe.d/ to use a .conf suffix in preparation
  for newer versions of module-init-tools.
  Let the psmouse module load with the default kernel configuration, rather
  than forcing proto=imps.  If this causes problems with your KVM, uncomment
  the line in /etc/modprobe.d/psmouse.
So now you know you should have commented that line, rather than removing the
entire file. What are you going to do when module-init-tools is updated?
 
Old 07-17-2009, 09:24 PM   #8
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 214

Rep: Reputation: 44
I did read the ChangeLog.txt and thats not the same thing as i described.
I had the /etc/modprobe.d/psmouse.conf thats correct but there was also an /etc/modprobe.d/psmouse~.conf that shouldn't be there that had the line uncommented.
The /etc/modprobe.d/psmouse.conf in current has "options psmouse proto=imps" commented out so there shouldn't be any need to comment out that line.
So i posted that i got an rubbish file when i updated current last time and someone else might have the same problem.
 
Old 07-17-2009, 11:40 PM   #9
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
You might have a "rubbish file" because you did something incorrectly in the upgrade.

Here are three boxen with the latest Slackware64 -current and Slackware -current
updates that you describe. None has a /etc/modprobe.d/psmouse~.conf file.

Code:
mahui@china:~$ ls -l /etc/modprobe.d/
total 20
-rw-r--r-- 1 root root 6251 2009-07-15 10:38 blacklist.conf
-rw-r--r-- 1 root root  443 2009-04-21 07:01 isapnp.conf
lrwxrwxrwx 1 root root   16 2009-07-10 21:37 modprobe.conf -> ../modprobe.conf
-rw-r--r-- 1 root root  265 2009-07-15 11:54 psmouse.conf
-rw-r--r-- 1 root root  244 2008-12-01 10:00 usb-controller.conf
mahui@china:~$ cat /etc/modprobe.d/psmouse.conf
# PS/2 mouse support:
# The default options when the psmouse module can cause problems with KVM
# switches.  If you experience this, you may want to uncomment the line
# below to use a more basic mouse protocol with the psmouse module:
#options psmouse proto=imps

mahui@china:~$
Code:
mingdao@silas64:~$ ls -l /etc/modprobe.d/
total 24
-rw-r--r-- 1 root root 6251 2009-07-15 10:38 blacklist.conf
-rw-r--r-- 1 root root  443 2009-04-21 07:01 isapnp.conf
lrwxrwxrwx 1 root root   16 2009-06-26 01:59 modprobe.conf -> ../modprobe.conf
-rw-r--r-- 1 root root  265 2009-07-15 11:54 psmouse.conf
-rw-r--r-- 1 root root   64 2009-06-26 19:40 sound.conf
-rw-r--r-- 1 root root  244 2008-12-01 10:00 usb-controller.conf
mingdao@silas64:~$ cat /etc/modprobe.d/psmouse.conf
# PS/2 mouse support:
# The default options when the psmouse module can cause problems with KVM
# switches.  If you experience this, you may want to uncomment the line
# below to use a more basic mouse protocol with the psmouse module:
#options psmouse proto=imps

mingdao@silas64:~$
Code:
mingdao@jeremiah:~$ ls -l /etc/modprobe.d/
total 32
-rw-r--r-- 1 root root 6250 2009-07-17 10:40 blacklist.conf
-rw-r--r-- 1 root root 6267 2009-07-17 10:32 blacklist.conf~
-rw-r--r-- 1 root root   39 2009-07-17 12:15 bluetooth.conf
-rw-r--r-- 1 root root  443 2009-04-21 07:01 isapnp.conf
lrwxrwxrwx 1 root root   16 2009-07-14 00:19 modprobe.conf -> ../modprobe.conf
-rw-r--r-- 1 root root  265 2009-07-15 11:54 psmouse.conf
-rw-r--r-- 1 root root  244 2008-12-01 10:00 usb-controller.conf
mingdao@jeremiah:~$ cat /etc/modprobe.d/psmouse.conf
# PS/2 mouse support:
# The default options when the psmouse module can cause problems with KVM
# switches.  If you experience this, you may want to uncomment the line
# below to use a more basic mouse protocol with the psmouse module:
#options psmouse proto=imps

mingdao@jeremiah:~$
 
Old 07-18-2009, 08:46 AM   #10
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 214

Rep: Reputation: 44
My box didn't have that "rubbish file" before i ran 'slackpkg update gpg' 'slackpkg update' and 'slackpkg upgrade-all'.
And this box isn't upgraded from 12.2 it's an relative fresh install of current.(2009-06-24)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
laptop touchpad - how to disable 'tap to click'?? Adrian Baker Linux - Laptop and Netbook 2 01-17-2006 06:15 PM
stop synaptics touchpad tap click easily Frank Leone Linux - Newbie 6 10-30-2005 06:44 PM
Touchpad won't tap-click Detour Linux - Laptop and Netbook 3 11-08-2004 09:57 PM
Make touchpad tap register as click drigz Linux - Software 8 10-15-2004 01:22 PM
post kernel upgrade lost tap click geomatt Linux - Hardware 4 09-30-2004 03:06 PM


All times are GMT -5. The time now is 10:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration