-   Slackware (
-   -   Slackpkg keeps asking for pgp (

samac 05-11-2006 03:01 PM

Slackpkg keeps asking for pgp
I read that there were security updates for all versions of slackware, so I fired up a terminal.

As root:

I issued the command slackpkg update

The files were refreshed.

Then I typed slackpkg upgrade-all

Slackpkg complained it wanted gpg, so I typed slackpkg update gpg

updated the tried to upgrade-all


It still wanted me to update the gpg.

Has anyone any ideas because I cannot upgrade using slackpkg at the moment.


Hangdog42 05-11-2006 03:08 PM

It probably wants you to set up the Slackware PGP key. Have a read through this how-to on how to configure Slackpkg to use this.

samac 05-11-2006 03:37 PM

Hi thanks for the reply.

The gpg key was set up, but on the off chance that something had gone wrong I tried to set it up again.

This identified the following problem:

It was looking for and the installedversion was 4.3, so I updated and all is now fixed.

Many thanks


All times are GMT -5. The time now is 02:30 AM.