LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-07-2011, 04:36 AM   #16
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293

No because /usr/bin/gpg is supplied by version 1. Version 2 supplies /usr/bin/gpgv2

Last edited by dive; 03-07-2011 at 04:39 AM.
 
Old 03-07-2011, 10:40 AM   #17
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
OK, so installing gnupg 1.4 works without needing the later version.

Why are there two seemingly stable versions in the repo?
 
Old 03-07-2011, 11:00 AM   #18
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293
Different apps use different versions. See GTK and GTK-2.
 
Old 03-07-2011, 12:18 PM   #19
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
installing 1.4.10 seems to remove the error but sbopkg still complains about gpg verification failing

I guess I can uninstall gnupg2 2.0.14 now?
 
Old 03-07-2011, 05:22 PM   #20
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 929

Rep: Reputation: 96
I recommend that you keep gpg2. Newer software uses it anyway. It is designed to coexist with the old version.
 
Old 03-08-2011, 12:23 AM   #21
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Quote:
Originally Posted by Josh000 View Post
installing 1.4.10 seems to remove the error but sbopkg still complains about gpg verification failing
sbopkg or slackpkg? What's the error? What gpg sig is being verified (i.e., what package(s) is it failing on)? Some errors indicate a problem but some errors just mean everything's working correctly on your end and something's wrong with the thing being verified.

(BTW, if you want to know why two gpgs and which or both of them, the manuals tell you.)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackpkg refuses to update - always claims a GPG error black hole sun Slackware 14 09-05-2011 12:30 PM
GPG: Bad session key gpg between gpg on linux and gpg gui on windows XP konqi Linux - Software 1 07-21-2009 09:37 AM
Slackpkg Broken: 'gpg error' skubik Slackware 7 07-06-2009 06:48 AM
problems after using slackpkg Twister512 Slackware 15 10-28-2007 10:41 PM
slackpkg problems dive Slackware 3 11-16-2005 04:08 PM


All times are GMT -5. The time now is 06:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration