LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   slackpkg gpg problems (http://www.linuxquestions.org/questions/slackware-14/slackpkg-gpg-problems-866767/)

Josh000 03-06-2011 10:24 AM

slackpkg gpg problems
 
I have gnupg installed, yet slackpkg always claims it cannot be found and thus gpg verification fails on packages.

Do I have to do anything special to get slackpkg to use gnupg?


I have tried reinstalling/updating from solutions in other threads, but they did not work for me.

wadsworth 03-06-2011 11:21 AM

Did you set your mirror and run
Code:

slackpkg update gpg

Josh000 03-06-2011 11:35 AM

Yes, I did this and it made no differece.

willysr 03-06-2011 12:55 PM

have you set the correct mirrors?

Josh000 03-06-2011 12:57 PM

yes

dive 03-06-2011 01:01 PM

What is the output of 'ls /var/log/packages/gnupg*' ?

repo 03-06-2011 01:02 PM

Perhaps try another mirror

Kind regards

Josh000 03-06-2011 02:06 PM

gnupg2-2.0.14-x86_64-2 is installed, I have tried several different mirrors.

hitest 03-06-2011 02:49 PM

Quote:

Originally Posted by Josh000 (Post 4280563)
I have tried reinstalling/updating from solutions in other threads, but they did not work for me.

Did you try reinstalling slackpkg?

Code:

# slackpkg reinstall slackpkg

Josh000 03-06-2011 03:17 PM

Tried that and also did slackpkg update, it still complains.

mRgOBLIN 03-06-2011 05:50 PM

Check that your time and date are correct.

Also make sure you don't have a slackpkg.conf.new that might need putting in it's correct place.

Josh000 03-06-2011 06:11 PM

Time and date are correct, already moved the .new file.

hitest 03-06-2011 06:58 PM

Is slackpkg pointing towards a 64 bit mirror?

dive 03-06-2011 10:39 PM

Quote:

Originally Posted by Josh000 (Post 4280732)
gnupg2-2.0.14-x86_64-2 is installed, I have tried several different mirrors.

There is also a gnupg-1.4.10

You should have that installed too.

Josh000 03-06-2011 11:40 PM

Yes, pointing towards the correct mirror.


Why do I need both versions of gnupg. Is that not redundant?


All times are GMT -5. The time now is 10:20 PM.