LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   slackpkg cannot find PACKAGES.TXT (http://www.linuxquestions.org/questions/slackware-14/slackpkg-cannot-find-packages-txt-4175426330/)

dc_eros 09-09-2012 02:55 AM

slackpkg cannot find PACKAGES.TXT
 
Slackware current - 64 bit

Here is the error I get:

Code:

root@darkstar:~# slackpkg update

Updating the package lists...
        Downloading...
                        Linking /opt/slackware-current/ChangeLog.txt...
Files /var/lib/slackpkg/ChangeLog.txt and /tmp/slackpkg.EK3qqA/ChangeLog.txt differ

                List of all files
                        Linking /opt/slackware-current/patches/MANIFEST.bz2...
                        Linking /opt/slackware-current/slackware64/MANIFEST.bz2...
                        Linking /opt/slackware-current/extra/MANIFEST.bz2...
                        Linking /opt/slackware-current/pasture/MANIFEST.bz2...
                        Linking /opt/slackware-current/testing/MANIFEST.bz2...
                Checksums
                        Linking /opt/slackware-current/CHECKSUMS.md5...
                        Linking /opt/slackware-current/CHECKSUMS.md5.asc...
                Package List
                        Linking /opt/slackware-current/FILELIST.TXT...
                Package descriptions
                        Linking /opt/slackware-current/patches/PACKAGES.TXT...
                        Linking /opt/slackware-current/slackware64/PACKAGES.TXT...
                        Linking /opt/slackware-current/extra/PACKAGES.TXT...
                        Linking /opt/slackware-current/pasture/PACKAGES.TXT...
                        Linking /opt/slackware-current/testing/PACKAGES.TXT...
        Formatting lists to slackpkg style...
                Package List: using CHECKSUMS.md5 as source
                Package descriptions
cat: /tmp/slackpkg.EK3qqA/slackware64-PACKAGES.TXT: No such file or directory

root@darkstar:~#

I have a synced current on /opt/slackware-current. It didn't happen on my 32 bit current.

Here is my blacklist config:

Code:

#
# aaa_elflibs can't be updated.
#
#aaa_elflibs

# You can blacklist using regular expressions.
#
# Don't use *full* regex here, because all of the following
# will be checked for the regex: series, name, version, arch,
# build and fullname.
#
# This one will blacklist all SBo packages:
[0-9]+_SBo
calligra

Updating works though. I have re-installed slackpkg several times already. Ex: remove it then install again, removing its config files.

ReaperX7 09-09-2012 04:23 AM

Run "netconfig" and have it set up your network.

Alien Bob 09-09-2012 05:03 AM

Quote:

Updating the package lists...
Downloading...
Linking /opt/slackware-current/ChangeLog.txt...
Apparently you have a local Slackware mirror setup in /opt/slackware-current . I would start looking there. If slackpg is having issues, it is because your local mirror is not correct.

Eric

dc_eros 09-09-2012 07:41 AM

Hmmm... I'll try having a fresh sync, but that would take a week :D . Here is my script.

Code:

lysender@darkstar:~$ cat ~/bin/rsync-slackware.sh
rsync -rvz --delete rsync://some-awsome-mirror.org/slackware/slackware64-current/ /opt/slackware-current/

lysender@darkstar:~$


Didier Spaier 09-09-2012 09:01 AM

Better use -avz than -rvz to have a real mirror.

willysr 09-09-2012 09:14 AM

even better, use -vazP

ruario 09-09-2012 09:46 AM

Some people might not even want -z, depending on your connection speed to the server you are rsyncing to. For those with a fast enough connection it could actually slow things down.

Quote:

Originally Posted by Petri Kaukasoina (Post 4774089)
rsync uses zlib for compression. Most files in slackware mirrors are already compressed with xz, and zlib can't compress them, it just eats some additional cpu cycles.

Quote:

Originally Posted by Petri Kaukasoina (Post 4774172)
ok, I measured it. I transferred the slackware64-current directory (5.4GB) from an rsync server to another machine. Default configuration in both ends. Without -z the client received 5684687767 bytes and with -z it received 5674708207 bytes. So -z helps but only 0.18 percent.

Without compression the rsyncd server process used 22s cpu time and with compression 184s. That's why compression actually slows down the transfer if the connection has a large bandwidth: I have a 1Gb/s connection and it took 93s real time without compression and 230s with compression.


dc_eros 09-09-2012 11:07 AM

So -vaP is the way to go?

dc_eros 09-09-2012 11:09 AM

I just run this:

Code:

rsync -rvz --delete rsync://some-awsome-mirror.org/slackware/slackware64-current/ /opt/slackware-current/
We'll see :D

Thanks everyone. Will update with the issue once I'm fully synced.

Didier Spaier 09-09-2012 04:45 PM

In any case you should really use the -a instead of the -r option. Else you don't copy symlinks as symlinks, you don't preserve permissions, owner, group, devices files, special files, modification times, so really you are not making a mirror.

dc_eros 09-10-2012 07:41 AM

Done with full sync for less than a day. And issue is indeed incorrect local copy.

Thanks for all that helps.


All times are GMT -5. The time now is 01:04 AM.