LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   slackbuilds rebuild needed 14.0->14.1 ? (http://www.linuxquestions.org/questions/slackware-14/slackbuilds-rebuild-needed-14-0-14-1-a-4175483859/)

Stuferus 11-08-2013 06:07 AM

slackbuilds rebuild needed 14.0->14.1 ?
 
hi,

the question may be stupid but ill ask it anyway - also for newbies to slack.

does one need to rebuild its slackbuilds programs on upgrade of slackware?

sry for my maybe bad english.. its not my native.
greatings.

jprzybylski 11-08-2013 07:14 AM

Maybe, depending on the program.

That is, programs who have dependencies from 14.0 that are not present in 14.1 (or have changed dramatically) will need a recompile.

It is probably safer to recompile all SlackBuilds on your system after upgrading.

solarfields 11-08-2013 07:24 AM

i always do a clean install of the new Slackware version and rebuild all I have from SlackBuilds.org

hitest 11-08-2013 09:26 AM

Quote:

Originally Posted by solarfields (Post 5060707)
i always do a clean install of the new Slackware version and rebuild all I have from SlackBuilds.org

I do that as well. Two of three Slackware 14.1 installs completed yesterday without a hitch. Will do the last install tonight. The good people at SBo will release new slackbuild scripts in the near future.

willysr 11-08-2013 10:04 AM

use the basic rule: If it's NOT broken, don't fix it :)

j_v 11-08-2013 11:07 PM

Quote:

Originally Posted by willysr (Post 5060798)
use the basic rule: If it's broken, don't fix it :)

'broken'?
s/broken/not broken/ ?

Daedra 11-08-2013 11:31 PM

Quote:

Originally Posted by willysr (Post 5060798)
use the basic rule: If it's broken, don't fix it :)

sed -i 's,broken,not broken,g' willysr

:D

kikinovak 11-09-2013 01:26 AM

Quote:

Originally Posted by Daedra (Post 5061149)
sed -i 's,broken,not broken,g' willysr

:D

:1,$s/broken/not broken/g :hattip:

ponce 11-09-2013 02:03 AM

Quote:

Originally Posted by willysr (Post 5060798)
use the basic rule: If it's broken, don't fix it :)

yup, good rule ;)

willysr 11-09-2013 02:19 AM

Must been too tired last night... :)

Stuferus 11-09-2013 06:35 AM

i know what he meant. SOLVED.

i hope this is helpful for others/newbies to slackware with the same question in mind.

ill wait for slackbuilds to go to 14.1 than i upgrade.

neymac 11-09-2013 08:44 AM

Quote:

Originally Posted by willysr (Post 5060798)
use the basic rule: If it's broken, don't fix it :)

It's a good motto for a demolition firm...:tisk:

Soderlund 12-31-2013 09:26 AM

Quote:

Originally Posted by jprzybylski (Post 5060697)
That is, programs who have dependencies from 14.0 that are not present in 14.1 (or have changed dramatically) will need a recompile.

Won't a new libc version also cause problems?

dimm0k 12-31-2013 02:27 PM

for those that rebuild SlackBuilds.org packages, do you have some sort of script that runs through all the packages to update from SlackBuilds.org and then builds them? some of the programs I have have a nightmare of dependencies that require too much manual work to rebuild.

willysr 12-31-2013 07:21 PM

Use sbopkg and the queue file


All times are GMT -5. The time now is 09:01 PM.