LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackbuild problem (http://www.linuxquestions.org/questions/slackware-14/slackbuild-problem-633649/)

http:// 04-07-2008 07:56 AM

Slackbuild problem
 
Hello,

I've tried installing some packages using slackbuild and I always get this error message...

checking whether build environment is sane... configure: error: newly created file is older than distributed files!
Check your system clock

when I check /tmp theres a folder for the software package but theres nothing in it

ummm... help (I guess)

Humbly,

mikel

agentc0re 04-07-2008 08:17 AM

when you run the build script are you doing it as root or sudo? If not, try one or the other.

hitest 04-07-2008 08:34 AM

1. Extract build script.
2. Put source package that you downloaded into the newly created directory that resulted from the build script being extracted. eg. mv nameofpackage /home/yourusername/downloads/nameofpackagedirectory
3. cd into that directory.
4. Issue su command
5. # chmod +x nameofpackage.SlackBuild
6. # ./nameofpackage.SlackBuild
7. # cd /tmp
8. # installpkg nameofpackage.tgz

Alien Bob 04-07-2008 08:38 AM

Check the clock on your PC. It looks like your computer is living in the past.

Eric

duryodhan 04-07-2008 09:13 AM

To check your clock do a command "date" from you shell and show/check the output.

http:// 04-07-2008 10:07 AM

Hello,

A. Did it as root

B.

1. Extract build script.
2. Put source package that you downloaded into the newly created directory that resulted from the build script being extracted. eg. mv nameofpackage /home/yourusername/downloads/nameofpackagedirectory
3. cd into that directory.
4. Issue su command
5. # chmod +x nameofpackage.SlackBuild
6. # ./nameofpackage.SlackBuild
=This is the point where I got the error message
7. # cd /tmp
8. # installpkg nameofpackage.tgz
=No .tgz package on /tm/SBo/packagename/packagename-package(or some other variant)

C.checked the date and this is what I got

Sun Jan 2 22:58:47 PHT 2005

:) . Oh God... My computer IS living in the past...

How do I correct this? in the BIOS?

Thank you for your time.

Humbly,

mikel

Alien Bob 04-07-2008 10:58 AM

In Slackware you can run a NTP program that will keep your computer time synchronized with the Internet Time servers.
Run
Code:

chmod +x /etc/rc.d/rc.ntpd
so that the NTP daemon will start on next boot.
You may have to check /etc/ntp.conf to see if there is a valid NTP server listed there. The hostname "pool.ntp.org" is a good one to use.

Eric

http:// 04-07-2008 11:16 AM

Hello,

Thanks. Is this the same with the synchronize time option in KDE? I used it a while back, but whenever I turn my PC off it would give the wrong date and time so switched back to manual time adjustment and still, whenever I turn my computer off the date and time would be wrong again... Its the same in XP...

I probably need a new battery for my board.(?)

Thank you for your time.

I didnt notice that my computers date was wrong... correct time though. Please forgive my carelesness.

Humbled, (once again)

mikel

shadowsnipes 04-07-2008 11:18 AM

If you decide to use ntp, make sure you aren't blocking ntp in your firewall (if you use one).

You might also be interested in Section 6.4.7. of the Slackbook: Setting the timezone

http:// 04-07-2008 11:32 AM

Hello,

Thank you for helping me out with this problem that I should have figured out on my own if I only had been more attentive to my computer.

When will I stop asking silly questions!!! :D

Once again, my gratitude for the assistance.

Thank you for your time.

Humbly,

mikel

PS. By the way, Slackbuilds is fine now. :)

T3slider 04-07-2008 10:40 PM

I have an offish topic question. How much of a security risk is using NTP to set the time? (I have refrained from using it thus far just in case, without doing much real research)

hitest 04-07-2008 10:46 PM

Quote:

Originally Posted by http:// (Post 3113639)
PS. By the way, Slackbuilds is fine now. :)

Awesome! Glad you figured it out:-)


All times are GMT -5. The time now is 02:10 AM.