LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackbuild of MiniTube 1.5 & 1.6 repeats same video on x86 Slackware 13.37 (http://www.linuxquestions.org/questions/slackware-14/slackbuild-of-minitube-1-5-and-1-6-repeats-same-video-on-x86-slackware-13-37-a-912403/)

rob adornato 11-07-2011 11:18 PM

Slackbuild of MiniTube 1.5 & 1.6 repeats same video on x86 Slackware 13.37
 
Hi,
I've looked through the forums and I'm hoping for some advice on what I can do next.

I've compiled MiniTube 1.5 from the Slackbuild at Slackbuilds.org. It worked except the videos repeat until I manual choose the next one.

The same occurs now that I upgraded to Minitube 1.6, by updating the version number on the Slackbuild.

The following is what appears when I run minitube from the terminal. The package doesn't appear to have any flags to make it more verbose.

GtkStyle was unable to detect the current GTK+ theme.
QAbstractItemModel::endInsertRows: Invalid index ( 1 , 0 ) in model ListModel(0x81c4218)
"http://gdata.youtube.com/feeds/api/videos/?max-results=10&start-index=1&q=elmo"
"http://i.ytimg.com/vi/YHROHJlU_Ng/0.jpg"
"http://i.ytimg.com/vi/vSYadh2xmcI/0.jpg"
"http://i.ytimg.com/vi/0LEYwoooVfw/0.jpg"
"http://i.ytimg.com/vi/ML8IL77gQ3k/0.jpg"
"http://i.ytimg.com/vi/Py2f38iPBeI/0.jpg"
"http://i.ytimg.com/vi/o4x-VW_rCSE/0.jpg"
Found format 18
"http://www.youtube.com/get_video_info?video_id=vSYadh2xmcI&el=embedded&ps=default&eurl=&gl=US&hl=en"
"http://i.ytimg.com/vi/Jc20vMz0V7Q/0.jpg"
"http://i.ytimg.com/vi/5BDVvB7Xx1w/0.jpg"
"http://i.ytimg.com/vi/v9nq-HUHpdY/0.jpg"
"http://i.ytimg.com/vi/mtDW8hxOrYk/0.jpg"
Playing "/tmp/minitube-259908416-kitchen"

buffering
buffering

Any recommendations for commands I can run to get a better idea of what's going wrong is appreciated.

My searches on the minitube site turned up a complaint of the same problem, mentions some stuff about the older 1.4 version not working with Xine, and recommending VLC. How does one switch backends on Slackware?

Thanks,
Rob

vharishankar 11-09-2011 07:55 AM

If you mean change the sound system in KDE, go to system settings in the KDE menu, double click on multimedia in the hardware section, and go to backend tab. Choose the appropriate backend. Or you can simply search for Phonon in the KDE start menu (the new style).

rob adornato 11-10-2011 07:33 AM

Solved by switch to gstreamer back-end
 
Just to finish this off, it now works.

The default phonon Xine-backend is not tested by Flavio, Minitube's creator. On the Minitube forum, he quickly answered my question and suggested trying the gstreamer-backend.

To get gstreamer working, briefly: using the Slackbuilds at slackbuild.org, I built ffmpeg with most of its options enabled (also all previously built) then I built gstreamer’s ffmpeg, bad and ugly plugins.

Probably more than just Minitube needs, but my Slack machine is my "learn and have fun" machine.

After that go to KDE’s System Settings —> Multimedia –> Phonon -> Backend > gstreamer, as per vharishankar's reply.

And now it works.


All times are GMT -5. The time now is 05:33 PM.