LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   slackbuild build errors? (http://www.linuxquestions.org/questions/slackware-14/slackbuild-build-errors-849383/)

trademark91 12-09-2010 06:06 PM

slackbuild build errors?
 
ive got two strange errors when compiling two unrelated packages in from slackbuilds.org. the first is audacity:

i get this error:
Code:

configure: WARNING: "Missing support in pa_mac_core.h"
configure: WARNING: "Missing support in pa_unix_oss.h"
configure: WARNING: "Missing support in portaudio.h"
configure: error: "Your version of portaudio does not include required functions"
configure: error: ./configure failed for lib-src/portmixer

i dont know what the problem could be, as im running a fully updated slackware -current, and installed ALL the dependencies for audacity, including the optional ones. after seeing this error, i installed the portaudio slackbuild, and i still get the same error.

the second is in the last.fm client.

when i run the slackbuild for this, i get the following:

Code:

patch unexpectedly ends in middle of line
patch: **** unexpected end of file in patch
patch unexpectedly ends in middle of line
patch: **** unexpected end of file in patch

i dont know what the issue is on either of these packages, and its irritating, because once i get these up and running, i can finally use slackware as my main OS.

any idea on how to fix these two?

trademark91 12-09-2010 06:34 PM

ok, i fixed the audacity problem, well not really fixed, but worked around.

i found this: http://forum.audacityteam.org/viewtopic.php?f=19&t=1577

and modified the slackbuild with the --without-portaudio option. that did the trick.

still clueless on the last.fm one though...

Daedra 12-09-2010 06:47 PM

I just compiled last.fm in -current using sbopkg and it compiled fine. Are you compiling manually? Cause it sounds like you didn't download all the patches or the patches didn't save correctly.

trademark91 12-09-2010 06:51 PM

i downloaded the slackbuild

untar'd it to a directory

put the source in the last.fm folder

ran last.fm.Slackbuild

and then i get that error...

Daedra 12-09-2010 07:00 PM

hhmmm, I just built it manually again just like you did above and I still have no problems. I would try either downloading each file by hand into the the last.fm directory then rerunning the slackbuild or try using sbopkg.

trademark91 12-09-2010 07:02 PM

Quote:

Originally Posted by Daedra (Post 4186532)
hhmmm, I just built it manually again just like you did above and I still have no problems. I would try either downloading each file by hand into the the last.fm directory then rerunning the slackbuild or try using sbopkg.

redownloaded, still didnt work :/

can you upload the tgz?

willysr 12-09-2010 07:03 PM

I compiled it on -Current (32 bit) and it's working just fine here

trademark91 12-09-2010 07:05 PM

so i redownloaded each individual file, and now it seems to be compiling. why didnt it work when i extracted the tar file though?

willysr 12-09-2010 07:06 PM

Quote:

Originally Posted by trademark91 (Post 4186538)
so i redownloaded each individual file, and now it seems to be compiling. why didnt it work when i extracted the tar file though?

strange, i downloaded the tar file and extract them and yes it's working fine :)


All times are GMT -5. The time now is 04:20 AM.