LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-11-2003, 07:22 PM   #1
SCarGo
LQ Newbie
 
Registered: Jun 2003
Location: Florida
Distribution: Redhat 7.3 and Slackware
Posts: 2

Rep: Reputation: 0
Slack9 Locks Loading firewire mod on inital boot


Here is my question I am trying to get Slackware 9 installed on my Laptop everything goes fine with the inital install then when I get the

Boot:

Prompt I hit enter it goes thorough loading everything and when it gets to loading:

ochi1394_0: OCHI-1394 1.1 (PCI): IRQ =[10] MMIO=[d00000000-d00007ff] Max Packet=[2048]

It just hangs and does not continue loading. Is there a command if any for me to put into the Boot: prompt to disable the firewire mod so that at least I can get in to the system to disable it for good?

Thanks in Advance
 
Old 07-13-2003, 10:05 AM   #2
quietguy47
Member
 
Registered: Mar 2003
Location: Everett
Distribution: Slackware 13.37
Posts: 785

Rep: Reputation: 31
If you have the 4 disc set for Slack, you can use disc 2 as a rescue disk. If you don't have the 4 disc set, you can d/l knoppix and use it as the rescue disk.
Instead of removing the module(#rmmod) you could change the irq(#setserial) that it is trying to access. #cat /proc/interrupts will show you which irq's are in use and by which device.
 
Old 07-13-2003, 09:27 PM   #3
Rodrin
Member
 
Registered: May 2003
Location: Upstate NY, U.S.
Distribution: Slackware
Posts: 247

Rep: Reputation: 31
Well since it would be difficult to rescue a system that has not yet been installed, I would suggest trying a parameter to stop firewire support from loading. Try the nousb option first. It might work since firewire depends on an ohci module. If it does not then try the noprobe option (then try both). If you use noprobe, you may have to load some modules you need manually with modprobe or insmod after you boot. It is entirely possible that a properly installed system will not hang, but load firewire support properly. If not you may have to also add nousb or noprobe to your Linux boot options in lilo.
 
Old 07-13-2003, 10:30 PM   #4
SCarGo
LQ Newbie
 
Registered: Jun 2003
Location: Florida
Distribution: Redhat 7.3 and Slackware
Posts: 2

Original Poster
Rep: Reputation: 0
I will give that a try tomarrow and let you know how it turns out. thanks guys for the advice
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apache2 + mod-ssl keeps loading the default localhost.xxxxxx cert STEBEL Linux - Newbie 3 11-26-2005 07:49 AM
WRT54G - Loading TUN mod but not showing..... The_JinJ Linux - Networking 1 11-24-2004 06:56 PM
Unable to open inital consol when trying to boot Arch Linux from lilo in Slack Part jimdaworm Slackware 7 03-01-2004 04:59 PM
Mandrake 9.2 locks up when installing firewire bdesenhada Linux - Laptop and Netbook 8 11-26-2003 08:06 AM
mod loading problem bandofmercy Linux - Hardware 3 03-25-2003 02:35 PM


All times are GMT -5. The time now is 01:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration