LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 09-16-2009, 03:22 PM   #1
Compile this
LQ Newbie
 
Registered: Sep 2009
Posts: 8

Rep: Reputation: 0
Post Slack64 multilib: Xfe "configure error: libFOX-1.6 not found"


I installed the fox-toolkit SlackBuild and tried to run the Xfe SlackBuild and get this error, even though I've clearly installed fox-toolkit beforehand.
Apparently I can't build either of these in a 64-bit environment ("C compiler cannot build executables") so I followed the multilib install guide from Alien's wiki (installing the compatibility packages, switching profile, changing the script's ARCH variable to x86_64, etc) and I get this error no matter what I do.

The exact error:
Code:
checking for fxfindfox in -lFOX-1.6... no
configure: error: "libFOX-1.6 not found"
Anyone know what the problem is? While it's not imperative that I use Xfe, I'd like to at least know why this error is showing and the preventive measures.

EDIT: as it would appear, every package I try to build does this unless I use . /etc/profile.d/32dev.sh beforehand... Pretty sure that should not be the case. Maybe I'm doing something wrong...

Last edited by Compile this; 09-16-2009 at 03:32 PM.
 
Old 09-16-2009, 03:54 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,111

Rep: Reputation: Disabled
You usually get the error "C compiler cannot build executables" on Slackware64 if you have the ARCH value inside the SlackBuild set to anything else than "x86_64".

Eric
 
Old 09-16-2009, 04:59 PM   #3
Compile this
LQ Newbie
 
Registered: Sep 2009
Posts: 8

Original Poster
Rep: Reputation: 0
I set the ARCH variable to x86_64, but didn't touch the rest of the script...
This, alone, actually fixed the problem!
I did not have to activate the separate 32dev.sh profile or change LIBDIRSUFFIX to "", which I'm assuming now is only necessary for certain packages, if at all?

Last edited by Compile this; 09-16-2009 at 05:00 PM.
 
Old 09-16-2009, 05:21 PM   #4
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,111

Rep: Reputation: Disabled
Quote:
Originally Posted by Compile this View Post
I set the ARCH variable to x86_64, but didn't touch the rest of the script...
This, alone, actually fixed the problem!
I did not have to activate the separate 32dev.sh profile or change LIBDIRSUFFIX to "", which I'm assuming now is only necessary for certain packages, if at all?
The whole circus of source-ing "/etc/profile.d/32dev.sh" and changing LIBDIRSUFFIX is only needed when you want to build 32bit software on a multilib Slackware64. So far, I have only needed to do this for one package: wine.
At some point, you may run into a library dependency that is not covered by the converted Slackware "-compat32" packages, in which case you will be forced to build a 32bit library. But I guess that will be a rare occasion.

The normal way of compiling on a Slackware64 system would be to create 64bit binaries. Why would you want to build 32bit binaries on a 64bit Slackware? Only if you are forced to use them (because of the need for some closed-source 32bit program whose developers are neglecting their user base).

In all cases (building either 64bit or 32bit binaries) you will have to set ARCH="x86_64".

Eric
 
Old 09-16-2009, 05:35 PM   #5
Compile this
LQ Newbie
 
Registered: Sep 2009
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Alien Bob View Post
The whole circus of source-ing "/etc/profile.d/32dev.sh" and changing LIBDIRSUFFIX is only needed when you want to build 32bit software on a multilib Slackware64. So far, I have only needed to do this for one package: wine.
Just to experiment around, I decided to try and see if I had to do this with wine.
I just downloaded the SlackBuild and only changed ARCH="x86_64" and it's building in the background!
Now, if it'll work or not, I don't know (since wine takes one year to compile, and could at any point see some kind of error...), but I didn't have to do the two aforementioned steps to get this far. Is my system just weird?
 
Old 09-16-2009, 05:59 PM   #6
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,111

Rep: Reputation: Disabled
If you only changed ARCH to "x86_64" you're now compiling "wine64" which is entirely possible.
However - this particular binary version of wine will only be able to run 64bit Windows applications. I don't know if that was your goal.

If you want to build the version of wine that is able to run 32bit Windows applications, you will have to use the
Code:
. /etc/profile.d/32dev.sh
command before you start the SlackBuild ...

Eric
 
Old 09-16-2009, 06:06 PM   #7
Compile this
LQ Newbie
 
Registered: Sep 2009
Posts: 8

Original Poster
Rep: Reputation: 0
Didn't know that.
Haha, I'm not that educated yet, but I'm learning!
Cleared some things up, though..
Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LFS6.3 - Ch5.4.1 "/bin/sh sort not found" error at "make bootstrap" ubyt3m3 Linux From Scratch 2 06-23-2008 12:09 AM
LFS6.3 livecd "ls : command not found" error after "su - lfs" rotu Linux From Scratch 2 06-19-2008 03:59 PM
Installing libFOX for XFE chaz_bro1972 Linux - Desktop 6 04-11-2007 04:41 PM
XFE + libFOX + fox/fx.h RaVilj Linux - Software 0 06-13-2004 05:28 PM
./configure error - "no acceptable cc found in #PATH" datawebcorp Linux - Newbie 3 01-03-2002 09:54 PM


All times are GMT -5. The time now is 07:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration