LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slack64-current - CTRL-ALT-BACKSPACE doesn't kill X (http://www.linuxquestions.org/questions/slackware-14/slack64-current-ctrl-alt-backspace-doesnt-kill-x-741714/)

GrapefruiTgirl 07-21-2009 10:12 AM

Slack64-current - CTRL-ALT-BACKSPACE doesn't kill X
 
I remember reading somewhere amongst the changelog that X or part thereof was being (re)built to continue offering the X-killing keystroke, but it doesn't work for me.
I'd like it to work though, if possible.

I tried disabling 'DontZap' in xorg.conf but no difference.

Anyone else find they can't kill X like this? Or did someone's mind change and the zapper is now NOT enabled?

Thanks.
Sasha

sahko 07-21-2009 10:41 AM

It works here. I just checked. I don't have DontZap or anything in my xorg.conf.
I noticed that the new 1.6.2 xorg-server doesnt have a patch to get back the default Ctrl-Alt-Backspace behaviour like the 1.6.1 did.
I don't know if they reverted that change from upstream. But like i said it works.

veeall 07-21-2009 12:16 PM

But Alt+PrintScr+k should do the same as i have found out from the internet. And it does on my slack64 box.

GrapefruiTgirl 07-21-2009 12:26 PM

Quote:

Originally Posted by veeall (Post 3615427)
But Alt+PrintScr+k should do the same as i have found out from the internet. And it does on my slack64 box.

Thank you :) but I'd rather not need to resort to SysRq magic to kill X when the usual method should work.

I probably have a wrong version of X installed; will need to investigate again.

Thanks!

Sasha

grissiom 07-21-2009 01:14 PM

In the ChangeLog:
Code:

Wed Jun 10 13:23:30 CDT 2009
This batch of updates includes a major overhaul of X.Org -- thanks to Robby
Workman for doing a huge amount of work updating the build scripts and testing
everything.  A large number of packages were recompiled or upgraded to drop
references to the now-obsolete libxcb-xlib and libXaw8 libraries.  We have
workarounds in place for old binaries so it wasn't strictly required, but
recompiling anyway gives a cleaner system.  Enjoy!
...
l/hal-0.5.11-x86_64-5.txz:  Rebuilt.  Patched 10-keymap.fdi to allow the
  Ctrl-Alt-Backspace key combination to continue to "zap" the X server as
  the default has been for decades.  Thanks to Robby Workman.
...

And hal never get update since then. So I think it should work... (At least on my box it works ;)

GrapefruiTgirl 07-21-2009 01:54 PM

AHA -- there's the part I neglected to remember/note! Thank you grissiom;

I have yet to 'deal with' anything HAL-related. HAL is entirely new to me, and since things are 'mostly' working as yet, I have not taken the time to do any research or configuration on HAL.

(This is assuming I actually have to put the key-combination into the HAL file; if I do not because it's already there, then it's still not working :p but if I actually need to add it myself, this thread can be considered [solved] until I learn otherwise.)

I do have the same HAL package as the changelog mentions, and Xorg-server is 1.6.2-build-1, so I'm ----


EDIT: OK, I have options in my xorg.conf which cause HAL to skip my input devices, and I think this is why it is ignoring my CTRL-ALT-BACKSPACE. I put the options so I wouldn't have to deal with HAL yet :D and lo and behold I've snaggled myself as a result!
The option(s) I am using are the bold ones(s):

Code:

Section "ServerFlags"
    Option        "Xinerama" "1"
#    Option        "AutoAddDevices" "False"
    Option        "AllowEmptyInput" "False"

EndSection

Looks like I will need to deal with HAL after all.

GazL 07-21-2009 03:01 PM

Quote:

Originally Posted by GrapefruiTgirl (Post 3615546)

EDIT: OK, I have options in my xorg.conf which cause HAL to skip my input devices, and I think this is why it is ignoring my CTRL-ALT-BACKSPACE. I put the options so I wouldn't have to deal with HAL yet :D and lo and behold I've snaggled myself as a result!
The option(s) I am using are the bold ones(s):

Code:

Section "ServerFlags"
    Option        "Xinerama" "1"
#    Option        "AutoAddDevices" "False"
    Option        "AllowEmptyInput" "False"

EndSection

Looks like I will need to deal with HAL after all.

Damn. That was exactly the approach I was planning to take as well. It looks like I'm gonna have to do some reading on the HAL/X.org interaction. I really hope that configuration statements aren't going to be spread all over the place.

sahko 07-21-2009 08:01 PM

Quote:

Originally Posted by grissiom (Post 3615491)
In the ChangeLog:
Code:

Wed Jun 10 13:23:30 CDT 2009
This batch of updates includes a major overhaul of X.Org -- thanks to Robby
Workman for doing a huge amount of work updating the build scripts and testing
everything.  A large number of packages were recompiled or upgraded to drop
references to the now-obsolete libxcb-xlib and libXaw8 libraries.  We have
workarounds in place for old binaries so it wasn't strictly required, but
recompiling anyway gives a cleaner system.  Enjoy!
...
l/hal-0.5.11-x86_64-5.txz:  Rebuilt.  Patched 10-keymap.fdi to allow the
  Ctrl-Alt-Backspace key combination to continue to "zap" the X server as
  the default has been for decades.  Thanks to Robby Workman.
...

And hal never get update since then. So I think it should work... (At least on my box it works ;)

Oh right, the patch was in HAL, not the server itself.

BGSLC 08-29-2009 09:32 AM

using ctrl-alt-backspace when keyboard layouts enabled in kde
 
in this case, the sequence ctrl-alt-backspace was not working until selected in the advanced tab of keyboard layout control module in kde.
took me a lot of time to discover this one!


All times are GMT -5. The time now is 12:28 AM.