LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-27-2012, 05:49 AM   #1
BashTin
Member
 
Registered: May 2003
Location: West Midlands, United Kingdom.
Distribution: Slackware 13.37
Posts: 249

Rep: Reputation: 32
Slack14, Kmail bug?? Will not send mail to Gmail


Hi, fresh install of Slackware 14. Kmail will receive my mail from Google (pop.gmail.com) but can I send out? No, regardless of whatever I ports and authentification methods I try.....

smtp.gmail.com
Use Authentication: Yes
Port for TLS/STARTTLS: 587
Port for SSL: 465

Interestingly enough Thunderbird has no such issues.

When I send via Kmail I get
Code:
Failed to transport message. Your SMTP server does not support PLAIN. Choose a different authentication method.
The server responded: 5.7.1 Username and Password not accepted.
Learn more at 5.7.1 http://support.google.com/mail/bin/answer.py?answer=14257 k4sm18307602paz.26
BUT it does not matter what authentication method I choose it still bitches about PLAIN.

If I start Kmail from the command line I get this......

Code:
$kmail
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
"/usr/bin/kmail(2738)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(2738)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(2738)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(2738)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(2738)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(2738)" Soprano: "Invalid iterator."
"/usr/bin/kmail(2738)" Soprano: "QLocalSocket::connectToServer: Invalid name"
kmail2(2738)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
kmail2(2738)/kdepimlibs (mailtransport): Could not access Outbox. 
[me@mine]-[07:42 PM Thu Dec 27]-[~]
$"/usr/bin/kmail(2738)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(2738)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(2738)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(2738)" Soprano: "Invalid iterator."
Seems alot of errors/messages there and the one about not being able to access the outbox sounds 'promising'.

Come on guys, help me out, desperate to flush my burgeoning out box.

Thanks, BashTin. PS, this is Kmail 4.8.5 and I have disabled nepomuk/anaconda stuff......

Last edited by BashTin; 12-27-2012 at 05:51 AM.
 
Old 12-27-2012, 12:33 PM   #2
bosth
Member
 
Registered: Apr 2011
Posts: 219

Rep: Reputation: 62
Did you delete your Local Folders resource?
 
Old 12-27-2012, 12:34 PM   #3
bosth
Member
 
Registered: Apr 2011
Posts: 219

Rep: Reputation: 62
Quote:
Originally Posted by BashTin View Post
I have disabled nepomuk/anaconda stuff......
If you've disabled Akonadi, then KMail is unlikely to work at all.
 
Old 12-28-2012, 08:19 AM   #4
BashTin
Member
 
Registered: May 2003
Location: West Midlands, United Kingdom.
Distribution: Slackware 13.37
Posts: 249

Original Poster
Rep: Reputation: 32
well thanks for trying to help. Looking more closely at system settings it appears I had only disabled nepomuk server but as it is still showing as alive and kicking by ps it obviously isn't very effective. What do you mean by my 'Local Resource Folders'? You mean my kmail dir and kmail2 dir? As they are still there.

BashTin.
 
Old 12-28-2012, 10:20 AM   #5
bosth
Member
 
Registered: Apr 2011
Posts: 219

Rep: Reputation: 62
You should always have a "Local Folders" amongst the list of mail accounts in KMail, and this is where the outbox folder is located. If you delete, "Local Folders" is should be recreated by Akonadi right away, but perhaps you modified it so that it is pointing to an unusable directory on your filesystem?

Not having Nepomuk won't stop you being able to use KMail, whereas having Akondai is a requirement.
 
Old 12-28-2012, 04:40 PM   #6
BashTin
Member
 
Registered: May 2003
Location: West Midlands, United Kingdom.
Distribution: Slackware 13.37
Posts: 249

Original Poster
Rep: Reputation: 32
Thanks, I've been digging around and found I have these files in my home dir

Code:
/home/mrt/.local/share/local-mail
/home/mrt/.local/share/local-mail/inbox
/home/mrt/.local/share/local-mail/inbox/cur
/home/mrt/.local/share/local-mail/inbox/new
/home/mrt/.local/share/local-mail/inbox/tmp
/home/mrt/.local/share/local-mail/trash
/home/mrt/.local/share/local-mail/trash/cur
/home/mrt/.local/share/local-mail/trash/new
/home/mrt/.local/share/local-mail/trash/tmp
/home/mrt/.local/share/local-mail/drafts
/home/mrt/.local/share/local-mail/drafts/cur
/home/mrt/.local/share/local-mail/drafts/new
/home/mrt/.local/share/local-mail/drafts/tmp
/home/mrt/.local/share/local-mail/sent-mail
/home/mrt/.local/share/local-mail/sent-mail/cur
/home/mrt/.local/share/local-mail/sent-mail/new
/home/mrt/.local/share/local-mail/sent-mail/tmp
/home/mrt/.local/share/local-mail/outbox
/home/mrt/.local/share/local-mail/outbox/cur
/home/mrt/.local/share/local-mail/outbox/new
/home/mrt/.local/share/local-mail/outbox/tmp
/home/mrt/.local/share/local-mail/templates
/home/mrt/.local/share/local-mail/templates/cur
/home/mrt/.local/share/local-mail/templates/new
/home/mrt/.local/share/local-mail/templates/tmp
But I have no folder called 'Local Folders'. Are the folders I listed what you mean or should there specifically be something named 'Local Folders' as there is with Thunderbird? If so where should it be and how should I create it?

Thanks again, BashTin.
 
Old 12-28-2012, 05:39 PM   #7
bosth
Member
 
Registered: Apr 2011
Posts: 219

Rep: Reputation: 62
KMail (well Akonadi) automatically creates a "Local Folders" account to handle 'local' mail. When you are using POP, I believe that downloaded mail goes directly to "Local Folders", but I don't use POP so I can say for sure. In any case, the Outbox folder amongst the "Local Folders" is where KMail keeps messages before they are sent by SMTP. Usually they go in and out very quickly, but if you are working offline, for example, this is where a 'sent' message sits before it is actually sent.

If you look at the list of accounts in the KMail's Settings>Configure KMail>Accounts you should see two accounts: your POP account and a second one called Local Folders. If you don't have Local Folders then something is wrong and you won't be able to send mail. The only configuration option for Local Folders is where to store the messages, and by default that is in your /home/mrt/.local/share/local-mail directory, but you might want to check to see what you have set it to. If you have changed it so that it is somewhere else that KMail can't access (or conflicts with your POP account?), then change it back to the default.

Incidentally, have you tried setting port 25 for outgoing mail (with TLS and PLAIN selected)?
 
Old 12-28-2012, 06:16 PM   #8
BashTin
Member
 
Registered: May 2003
Location: West Midlands, United Kingdom.
Distribution: Slackware 13.37
Posts: 249

Original Poster
Rep: Reputation: 32
In accounts, sending, I have my gmail accounts and a 'Maildir' account pointing to /home/mrt/.kde/share/apps/kmail/mail.

In accounts sending, I just have my gmail accounts, NO other accounts.

Is this right?

As for port 25, yes tried that with plain.

BashTin.
 
Old 12-28-2012, 06:34 PM   #9
bosth
Member
 
Registered: Apr 2011
Posts: 219

Rep: Reputation: 62
Quote:
Originally Posted by BashTin View Post
In accounts, sending, I have my gmail accounts and a 'Maildir' account pointing to /home/mrt/.kde/share/apps/kmail/mail.

In accounts sending, I just have my gmail accounts, NO other accounts.

Is this right?
From my experience, this is definitely not what you should have. As far as I know, you can't even delete your Local Folders - or rather if you do, it is automatically recreated.

You could try running akonadiconsole and looking at what accounts are set up there. Maybe your Local Folders is disabled? What you should probably do, though, is pop onto the forums at kde.org and ask for help there. This is unlikely a Slackware-specific issue and there may be someone there who can help. You might want to even try the suggestions in this thread: http://forum.kde.org/viewtopic.php?f=215&t=98985.
 
Old 12-28-2012, 07:33 PM   #10
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,141

Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
Do you have port 993 selected for IMAP4 port?
 
Old 12-28-2012, 09:43 PM   #11
bosth
Member
 
Registered: Apr 2011
Posts: 219

Rep: Reputation: 62
Quote:
Originally Posted by hitest View Post
Do you have port 993 selected for IMAP4 port?
He's using POP, so no IMAP.
 
Old 12-29-2012, 08:07 AM   #12
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,141

Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
Quote:
Originally Posted by bosth View Post
He's using POP, so no IMAP.
Ah, thanks, my bad. I read gmail, did not see POP.

BashTin,

Best of luck with the POP settings! If you ever feel like it I would encourage you to explore gmail and IMAP. Gmail works flawlessly with IMAP. It is wonderful having your e-mail synchronized across all of your devices.
 
Old 01-01-2013, 03:30 AM   #13
BashTin
Member
 
Registered: May 2003
Location: West Midlands, United Kingdom.
Distribution: Slackware 13.37
Posts: 249

Original Poster
Rep: Reputation: 32
Hi again guys, still struggling with this. I did some experimenting and found that if I add myself to the root group all works as should. 'Local Folders' was added under setting/account tab and I can send out mail. The only error message I receive is one solitary

Code:
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
Remove myself from root group and we are back to the previous state. So obviously a perms problem. But I am not smart enough to work this out by myself so some help would be greatly appreciated. Any offers??

Thanks in advance

Last edited by BashTin; 01-01-2013 at 03:31 AM. Reason: Can't type!
 
Old 01-01-2013, 03:12 PM   #14
bosth
Member
 
Registered: Apr 2011
Posts: 219

Rep: Reputation: 62
Perhaps you have run user programs as root in the past and you have root ownership on some of your user directories? You shouldn't be running KMail with elevated permissions.
 
Old 01-01-2013, 05:37 PM   #15
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,141

Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
Quote:
Originally Posted by bosth View Post
You shouldn't be running KMail with elevated permissions.
Agreed. It is safer to run programs as a regular user.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Sendmail to use Gmail's SMTP to send mail lpallard Linux - Software 12 05-01-2011 01:05 PM
how to send mail to my gmail account through sendmail shridhar005 Linux - Newbie 5 01-22-2009 05:52 AM
KMail can't send mail damaru Linux - Software 4 08-12-2004 12:57 PM
Can't send mail from KMail ?? glenn69 Linux - Newbie 6 05-16-2004 03:57 PM
Kmail Send mail Maurice Arthur Linux - General 3 12-05-2001 09:45 PM


All times are GMT -5. The time now is 06:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration