LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slack14, Kmail bug?? Will not send mail to Gmail (http://www.linuxquestions.org/questions/slackware-14/slack14-kmail-bug-will-not-send-mail-to-gmail-4175443096/)

BashTin 12-27-2012 05:49 AM

Slack14, Kmail bug?? Will not send mail to Gmail
 
Hi, fresh install of Slackware 14. Kmail will receive my mail from Google (pop.gmail.com) but can I send out? No, regardless of whatever I ports and authentification methods I try.....

smtp.gmail.com
Use Authentication: Yes
Port for TLS/STARTTLS: 587
Port for SSL: 465

Interestingly enough Thunderbird has no such issues.

When I send via Kmail I get
Code:

Failed to transport message. Your SMTP server does not support PLAIN. Choose a different authentication method.
The server responded: 5.7.1 Username and Password not accepted.
Learn more at 5.7.1 http://support.google.com/mail/bin/answer.py?answer=14257 k4sm18307602paz.26

BUT it does not matter what authentication method I choose it still bitches about PLAIN.

If I start Kmail from the command line I get this......

Code:

$kmail
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
"/usr/bin/kmail(2738)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(2738)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(2738)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(2738)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(2738)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(2738)" Soprano: "Invalid iterator."
"/usr/bin/kmail(2738)" Soprano: "QLocalSocket::connectToServer: Invalid name"
kmail2(2738)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
kmail2(2738)/kdepimlibs (mailtransport): Could not access Outbox.
[me@mine]-[07:42 PM Thu Dec 27]-[~]
$"/usr/bin/kmail(2738)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(2738)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(2738)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(2738)" Soprano: "Invalid iterator."

Seems alot of errors/messages there and the one about not being able to access the outbox sounds 'promising'.

Come on guys, help me out, desperate to flush my burgeoning out box.

Thanks, BashTin. PS, this is Kmail 4.8.5 and I have disabled nepomuk/anaconda stuff......

bosth 12-27-2012 12:33 PM

Did you delete your Local Folders resource?

bosth 12-27-2012 12:34 PM

Quote:

Originally Posted by BashTin (Post 4857622)
I have disabled nepomuk/anaconda stuff......

If you've disabled Akonadi, then KMail is unlikely to work at all.

BashTin 12-28-2012 08:19 AM

well thanks for trying to help. Looking more closely at system settings it appears I had only disabled nepomuk server but as it is still showing as alive and kicking by ps it obviously isn't very effective. What do you mean by my 'Local Resource Folders'? You mean my kmail dir and kmail2 dir? As they are still there.

BashTin.

bosth 12-28-2012 10:20 AM

You should always have a "Local Folders" amongst the list of mail accounts in KMail, and this is where the outbox folder is located. If you delete, "Local Folders" is should be recreated by Akonadi right away, but perhaps you modified it so that it is pointing to an unusable directory on your filesystem?

Not having Nepomuk won't stop you being able to use KMail, whereas having Akondai is a requirement.

BashTin 12-28-2012 04:40 PM

Thanks, I've been digging around and found I have these files in my home dir

Code:

/home/mrt/.local/share/local-mail
/home/mrt/.local/share/local-mail/inbox
/home/mrt/.local/share/local-mail/inbox/cur
/home/mrt/.local/share/local-mail/inbox/new
/home/mrt/.local/share/local-mail/inbox/tmp
/home/mrt/.local/share/local-mail/trash
/home/mrt/.local/share/local-mail/trash/cur
/home/mrt/.local/share/local-mail/trash/new
/home/mrt/.local/share/local-mail/trash/tmp
/home/mrt/.local/share/local-mail/drafts
/home/mrt/.local/share/local-mail/drafts/cur
/home/mrt/.local/share/local-mail/drafts/new
/home/mrt/.local/share/local-mail/drafts/tmp
/home/mrt/.local/share/local-mail/sent-mail
/home/mrt/.local/share/local-mail/sent-mail/cur
/home/mrt/.local/share/local-mail/sent-mail/new
/home/mrt/.local/share/local-mail/sent-mail/tmp
/home/mrt/.local/share/local-mail/outbox
/home/mrt/.local/share/local-mail/outbox/cur
/home/mrt/.local/share/local-mail/outbox/new
/home/mrt/.local/share/local-mail/outbox/tmp
/home/mrt/.local/share/local-mail/templates
/home/mrt/.local/share/local-mail/templates/cur
/home/mrt/.local/share/local-mail/templates/new
/home/mrt/.local/share/local-mail/templates/tmp

But I have no folder called 'Local Folders'. Are the folders I listed what you mean or should there specifically be something named 'Local Folders' as there is with Thunderbird? If so where should it be and how should I create it?

Thanks again, BashTin.

bosth 12-28-2012 05:39 PM

KMail (well Akonadi) automatically creates a "Local Folders" account to handle 'local' mail. When you are using POP, I believe that downloaded mail goes directly to "Local Folders", but I don't use POP so I can say for sure. In any case, the Outbox folder amongst the "Local Folders" is where KMail keeps messages before they are sent by SMTP. Usually they go in and out very quickly, but if you are working offline, for example, this is where a 'sent' message sits before it is actually sent.

If you look at the list of accounts in the KMail's Settings>Configure KMail>Accounts you should see two accounts: your POP account and a second one called Local Folders. If you don't have Local Folders then something is wrong and you won't be able to send mail. The only configuration option for Local Folders is where to store the messages, and by default that is in your /home/mrt/.local/share/local-mail directory, but you might want to check to see what you have set it to. If you have changed it so that it is somewhere else that KMail can't access (or conflicts with your POP account?), then change it back to the default.

Incidentally, have you tried setting port 25 for outgoing mail (with TLS and PLAIN selected)?

BashTin 12-28-2012 06:16 PM

In accounts, sending, I have my gmail accounts and a 'Maildir' account pointing to /home/mrt/.kde/share/apps/kmail/mail.

In accounts sending, I just have my gmail accounts, NO other accounts.

Is this right?

As for port 25, yes tried that with plain.

BashTin.

bosth 12-28-2012 06:34 PM

Quote:

Originally Posted by BashTin (Post 4858766)
In accounts, sending, I have my gmail accounts and a 'Maildir' account pointing to /home/mrt/.kde/share/apps/kmail/mail.

In accounts sending, I just have my gmail accounts, NO other accounts.

Is this right?

From my experience, this is definitely not what you should have. As far as I know, you can't even delete your Local Folders - or rather if you do, it is automatically recreated.

You could try running akonadiconsole and looking at what accounts are set up there. Maybe your Local Folders is disabled? What you should probably do, though, is pop onto the forums at kde.org and ask for help there. This is unlikely a Slackware-specific issue and there may be someone there who can help. You might want to even try the suggestions in this thread: http://forum.kde.org/viewtopic.php?f=215&t=98985.

hitest 12-28-2012 07:33 PM

Do you have port 993 selected for IMAP4 port?

bosth 12-28-2012 09:43 PM

Quote:

Originally Posted by hitest (Post 4858780)
Do you have port 993 selected for IMAP4 port?

He's using POP, so no IMAP.

hitest 12-29-2012 08:07 AM

Quote:

Originally Posted by bosth (Post 4858806)
He's using POP, so no IMAP.

Ah, thanks, my bad. I read gmail, did not see POP. :)

BashTin,

Best of luck with the POP settings! If you ever feel like it I would encourage you to explore gmail and IMAP. Gmail works flawlessly with IMAP. It is wonderful having your e-mail synchronized across all of your devices.

BashTin 01-01-2013 03:30 AM

Hi again guys, still struggling with this. I did some experimenting and found that if I add myself to the root group all works as should. 'Local Folders' was added under setting/account tab and I can send out mail. The only error message I receive is one solitary

Code:

QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
Remove myself from root group and we are back to the previous state. So obviously a perms problem. But I am not smart enough to work this out by myself so some help would be greatly appreciated. Any offers??

Thanks in advance

bosth 01-01-2013 03:12 PM

Perhaps you have run user programs as root in the past and you have root ownership on some of your user directories? You shouldn't be running KMail with elevated permissions.

hitest 01-01-2013 05:37 PM

Quote:

Originally Posted by bosth (Post 4860829)
You shouldn't be running KMail with elevated permissions.

Agreed. It is safer to run programs as a regular user.


All times are GMT -5. The time now is 05:54 AM.