LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slack14-current and VSFTPD... (http://www.linuxquestions.org/questions/slackware-14/slack14-current-and-vsftpd-4175430131/)

cooholio 10-02-2012 03:19 PM

Slack14-current and VSFTPD...
 
Upgraded my Slack14 RC4 to current today and somewhere in the process i managed to mess up my VSFTPD. I loaded my old vsftpd.conf and was hopping it would solve my problem but to no hope. Not all was lost but half of my folders i have made for my external ftp users are not longer able to upload to the folder they once where able too.

I will paste in my current vsftpd.conf file and also a directory listing of the folders. The rights on the folder are the same as it was before going to current.

Also looks like vsftpd might have gone from 3.0.0 to 3.0.2 from RC4 to current ? I could so be wrong on that but could have sworn the number where 3.0.0 in RC14.

anyway here is my config file.

Hopefully someone can point me in the right direction.

# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format.
# Note that the default log file location is /var/log/xferlog in this case.
xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
ftpd_banner=Welcome to FTP.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd.banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
# (Warning! chroot'ing can be very dangerous. If using chroot, make sure that
# the user does not have write access to the top level directory within the
# chroot)
chroot_local_user=YES
chroot_list_enable=YES
# (default follows)
chroot_list_file=/etc/vsftpd.chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
ls_recurse_enable=YES
#
# When "listen" directive is enabled, vsftpd runs in standalone mode (rather
# than from inetd) and listens on IPv4 sockets. To use vsftpd in standalone
# mode rather than with inetd, change the line below to 'listen=YES'
# This directive cannot be used in conjunction with the listen_ipv6 directive.
listen=NO
#
# This directive enables listening on IPv6 sockets. To listen on IPv4 and IPv6
# sockets, you must run two copies of vsftpd with two configuration files.
# Make sure, that one of the listen options is commented !!
#listen_ipv6=YES
allow_writeable_chroot=YES
~
~


[ installed ] - vsftpd-3.0.2-x86_64-1


Access to the directories as reported by ls -l 61,28 Top

drwx--x--x 2 myftp users 4096 Oct 2
drwxr-xr-x 6 myftp users 4096 Sep 19
drwx--x--x 2 myftp users 4096 Sep 10
drwxr-xr-x 10 myftp users 4096 Sep 12
drwxr-xr-x 25 myftp users 4096 Sep 12
drwx--x--x 2 myftp users 4096 Sep 18
drwx--x--x 2 myftp users 4096 Sep 10
drwx--x--x 2 myftp users 4096 Sep 10
drwx--x--x 2 myftp users 4096 Sep 10
drwx--x--x 2 myftp users 4096 Sep 10
drwx--x--x 3 test1 users 4096 Sep 11
drwx--x--x 2 myftp users 4096 Sep 10
drwxr-xr-x 7 myftp users 4096 Sep 12
drwx--x--x 2 myftp users 4096 Sep 10

any additional information needed please let me know and I will dig it out to my bes tof knowledge.

Thanks

/Joakim

Martinus2u 10-03-2012 03:32 AM

yes there was an upgrade to 3.0.2 in the last minute. Your problem is what exactly? can you provide a session log of an ftp session?

cooholio 10-03-2012 09:39 AM

I will get you some logs however when i try to enable log_ftp_protocol=YES and set xferlog_std_format=NO i dont get any logs at all...

any idea why ?

I think that the user that i am logging into only has read access to the folder is my problem.

The folder has execute rights but not the user.

Could that be my problem or am i thinking wrong here?

Still kind of new to all this linux commands. Been so long ago i messed with slack and never got deep into it like i am trying now.

/Joakim

dgrames 10-03-2012 11:07 AM

Did you enable vsftpd in inetd.conf, and are you using a vsftpd_user_list file?

cooholio 10-03-2012 11:11 AM

yes vsftpd is enable din the inetd.

And yes i am using a user list. Any name on the list are the ones allowed to write to the folders.

Something changed from 3.0.0 to 3.0.2 because it was working fine and now the users cant upload in to their folders no more.

And even when using my superuser to load files into the folders of the lower restricted users the files no longer shows up for them but prior to upgrade they where.


Weird if you ask me. I am using my old vsftpd.conf file to start the server with so i would think everything should stay the same and for most part it is except users can't upload into their home directory and the super user when uploading files the users cant see the files.

cooholio 10-03-2012 11:25 AM

update....


Its working now.

I reapplied the security settings for each folder and then took back owernship to my super user and its now working as it used to before the patch.

I appreciate your help but i will mark this thread as closed.


All times are GMT -5. The time now is 12:24 PM.