-   Slackware (
-   -   Slack14 and Dell Latitude 131l - ATI Radeon XPress 1150 (

telluricsummer 01-16-2013 11:26 AM

Slack14 and Dell Latitude 131l - ATI Radeon XPress 1150

just installed slackware 14, everything was fine except the fact that the environment graph presents only just a multitude of vertical stripes ...
any ideas?


tuxbg 01-16-2013 11:58 AM

Is your video card ok.

telluricsummer 01-16-2013 03:22 PM

it works cool in Trisquel GNU Linux ans XP Win, doesn't work in AntiX and Debian Squeeze too...

telluricsummer 01-17-2013 12:55 PM

one thing more:
after a time relatively soon, apparently the monitor off. then when we press enter the graphical environment is gone ... and is allowed to log the command startx and the desktop environment is loaded, and all things work well?
seems that the graphical environment rises before loading the driver of the video card, any ideas?

Tkx again

telluricsummer 01-17-2013 07:14 PM

I found it on debian wiki

"Radeon Xpress 200M (R300) on laptop

During a long time, on laptops with Radeon Xpress 200M (R300) you may get some random colored stripes (especially after suspending display power). This is problably due to a bug into free driver. A solution may be to switch off, then switch on the backlight with radeontool (eponymic package). "

how i do that in Slack?

tr4nshum4n 02-20-2016 04:12 PM

radeontool for Slackware
I realize this thread is a bit old, but I'll post the answer to the Slackware radeontool question in case anyone is looking for it.

The radeontool source and .SlackBuild file can be found at:

However, you may not need it. I've found I can turn the display off and then back on to clear my vertical lines by typing "xrandr --output LVDS --off" followed by "xrandr --output LVDS --auto" where LVDS is the name of my output device. This requires me to anticipate the colorful lines. Fortunately, they only seem to show up when I wake from hibernation, so I am able to do that.

It would be nice to find a better solution.

allend 02-20-2016 06:19 PM


It would be nice to find a better solution.
Have you tried creating a file in /etc/pm/config.d/ so that the video card is forced to do a POST when you resume from hibernate?

echo 'HIBERNATE_RESUME_POST_VIDEO="yes"' > /etc/pm/config.d/myvideoquirk
From /usr/lib(64)/pm-utils/defaults:

# Whether we need to post the video card when resuming from
# hibernate. You should not normally need to set this. 
# In the future pm-utils will get this setting from HAL.
# Valid values are "no" and "yes"

tr4nshum4n 02-20-2016 08:54 PM

Thanks for the quick response!

I tried your suggestion on forcing the video card to POST. It didn't seem to have any effect.

Are there any log files that might be helpful? I've been browsing the Xorg.0.log file, but I'm really not sure what I'm looking for.

allend 02-20-2016 10:24 PM

I have looked at this a bit more.
First, the use of radeontool is now deprecated. You are encouraged to use xrandr instead.

I would be tempted to try copying /usr/lib(64)/pm-utils/sleep.d/99video to /etc/pm/sleep.d/99video and then editing these lines in /etc/pm/sleep.d/99video

# turn critical bits of radeon cards off/on
radeon_off() { radeon dac off; radeon light off; }
radeon_on() { radeon dac on; radeon light on; }

to read

# turn critical bits of radeon cards off/on
radeon_off() { xrandr --output LVDS --off; }
radeon_on() { xrandr --output LVDS --auto; }

You can turn on the debugging in pm-utils to get a log.

echo 'PM_DEBUG="true"' > /etc/pm/config.d/debug
Either delete the file or comment the line in /etc/pm/config.d/debug to turn off the debugging.

All times are GMT -5. The time now is 03:29 AM.