LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-29-2004, 04:29 PM   #1
jymbo
Member
 
Registered: Jan 2003
Posts: 217

Rep: Reputation: 30
Slack to replace Windows2000 DHCP/DNS server


I built a DHCPD + DDNS box with Slack10 to replace a Windows 2000 DHCP/DNS server.

The DDNS updates are happening for all the WIndows 2000/XP and RH9 clients in the office, but not for my sole Slackware workstation. In an attempt to figure-out why, I had a look at the dhclient.conf-eth0 file from one of the RH9 clients named "sarg":

Code:
send-host "sarg"
I edited the /etc/dhclient.conf file on my Slack client with the same syntax, but still no joy.

Question: what does RH9 do differently to send it's hostname for DDNS to update? How can I mimic this behavior on my Slack box?

It's really not a huge deal, being that all my Windows and RH9 clients are playing nice with the Slackware DHCP/DDNS server (no more Windows2000 Server! Woohoo!). It would just be gravy if I could get my personal Slack workstation in on the game as well.

Thanks!

Last edited by jymbo; 07-31-2004 at 10:36 AM.
 
Old 07-29-2004, 09:07 PM   #2
jymbo
Member
 
Registered: Jan 2003
Posts: 217

Original Poster
Rep: Reputation: 30
More proof of concept: I just got in a Dell Lattitude laptop (XP Pro)...plugged it in to the LAN. Again, DDNS is working.

Still scratching my head, though, on getting this Slackware workstation to only be as cooperative...


Last edited by jymbo; 07-29-2004 at 11:04 PM.
 
Old 07-29-2004, 10:08 PM   #3
Schrambo
Member
 
Registered: Mar 2004
Location: Western Australia
Distribution: Debian Slackware CentOS
Posts: 102

Rep: Reputation: 15
I've been meaning to find some good documentation on how to setup DHCP, DNS and other netsork services for Slackware. Would you know of any sources?, cheers.
 
Old 07-29-2004, 11:02 PM   #4
suslik
Member
 
Registered: Jul 2004
Distribution: OpenSuse 10.x
Posts: 262

Rep: Reputation: 30
Quote:
Originally posted by jymbo
I just got in a Dell Lattitude laptop (XP Pro)...plugged it in to the LAN and it's hostname (looks like some funky factory default serial number) was pulled from DHCP and updated in the DNS record. Perfect execution by my Slackware server (aka, "Windows2000 DHCP/DNS server killer".)

Still scratching my head on getting this Slackware workstation to only be as cooperative...
You might be a little ahead of majority's curve... Just giving you a friendly bump, wanna se an answer too.
 
Old 07-29-2004, 11:07 PM   #5
jymbo
Member
 
Registered: Jan 2003
Posts: 217

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by suslik
You might be a little ahead of majority's curve... Just giving you a friendly bump, wanna se an answer too.
I've been googling on this like a madman for hours now. I just can't figure out how/why RH9 can trigger the DDNS update but Slackware cannot.
 
Old 07-29-2004, 11:10 PM   #6
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
By default Slackware doesn't report it's hostname to the DNS server.

If you are using Slackware 10 on the desktop, you have to open up "/etc/rc.d/rc.inet1.conf" and edit the following line:

Code:
DHCP_HOSTNAME[0]=""
Insert your hostname there, and the next time you get a lease from the DHCP server, your hostname should show up.

If you are running Slackware 9.0 (possibly 9.1, I forget) then the file is "/etc/rc.d/rc.inet1". The line you have to change is:

Code:
DHCP_HOSTNAME=""
 
Old 07-30-2004, 12:06 AM   #7
jymbo
Member
 
Registered: Jan 2003
Posts: 217

Original Poster
Rep: Reputation: 30
Thanks, but I already tried that. I think that option is more for DHCP servers that REQUIRE a hostname before a lease will be given, i.e. many dsl services.

It must be something more along the line of the dhclient.conf file, cuz that's what the RH boxen use, probably in addition to the RH dhclient-script.
 
Old 07-30-2004, 12:16 AM   #8
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Odd, that is what I have always used for DHCP servers and it has always worked for me. Though I haven't tired it with Slackware 10.
 
Old 07-30-2004, 04:40 AM   #9
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
Try using dhcpcd command by itself.

Try looking in man dhcpcd. You may find the thing you need in there. And you can edit rc.inet1 once you tested it out.

I know that dhcpcd used by Slackware is kinda advance, it can even change your client ID (-I) (default to MAC Address).

maybe you are interested with dhcpcd -h

-h <hostname>
specifies a string used for the hostname option
field when dhcpcd sends DHCP messages. Some DHCP
servers, notably those used by @Home Networks,
require the hostname option field containing a spe_
cific string in the DHCP messages from clients.

Anyway, just have a look in man dhcpcd since that is all that you have.
 
Old 07-30-2004, 11:25 AM   #10
jymbo
Member
 
Registered: Jan 2003
Posts: 217

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by carboncopy
Try using dhcpcd command by itself.

Try looking in man dhcpcd. You may find the thing you need in there. And you can edit rc.inet1 once you tested it out.

I know that dhcpcd used by Slackware is kinda advance, it can even change your client ID (-I) (default to MAC Address).

maybe you are interested with dhcpcd -h

-h <hostname>
specifies a string used for the hostname option
field when dhcpcd sends DHCP messages. Some DHCP
servers, notably those used by @Home Networks,
require the hostname option field containing a spe_
cific string in the DHCP messages from clients.

Anyway, just have a look in man dhcpcd since that is all that you have.
You're awesome, carboncopy...it worked. Thanks a bazillion for pointing-out the obvious.

(I added "dhcpcd -h host" to /etc/rc.d/rc.M)
 
Old 07-30-2004, 10:17 PM   #11
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
Welcome.

But why /etc/rc.d/rc.M? Shouldn't you modify /etc/rc.d/rc.inet1 somewhere along line 75.

But (again) it is already been configured to -h in it with $DHCP_NAME taken from /etc/rc.d/rc.inet1.conf.


Anyhow, glad that it works.
 
Old 07-30-2004, 11:28 PM   #12
Joseph_M
Member
 
Registered: May 2004
Posts: 71

Rep: Reputation: 15
Quote:
Originally posted by jymbo
(I added "dhcpcd -h host" to /etc/rc.d/rc.M)
This isn't the best way to do it. You should properly setup /etc/rc.d/rc.inet1.conf

You need to set DHCP_HOSTNAME[0]="" to your hostname and set USE_DHCP[0]="" to yes.

If that does not work then you have hosed your init scripts and you need to use your backup copy. You have a backup copy right??
 
Old 07-31-2004, 12:14 AM   #13
jymbo
Member
 
Registered: Jan 2003
Posts: 217

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by Joseph_M
This isn't the best way to do it. You should properly setup /etc/rc.d/rc.inet1.conf

You need to set DHCP_HOSTNAME[0]="" to your hostname and set USE_DHCP[0]="" to yes.

If that does not work then you have hosed your init scripts and you need to use your backup copy. You have a backup copy right??
This was actually the first logical thing I could think of, but the sendhostname never worked to begin with...hosed init scripts or not. That's when I started poking-around the RH9 init scripts looking for a pattern.
 
Old 08-04-2004, 07:22 PM   #14
Joseph_M
Member
 
Registered: May 2004
Posts: 71

Rep: Reputation: 15
Quote:
Originally posted by jymbo
This was actually the first logical thing I could think of, but the sendhostname never worked to begin with...hosed init scripts or not. That's when I started poking-around the RH9 init scripts looking for a pattern.
If the problem is with your slack machine why are you looking at Red Hat init scripts? The way that Slack and RedHat handle init is totally differrent.
 
Old 08-05-2004, 09:52 AM   #15
jymbo
Member
 
Registered: Jan 2003
Posts: 217

Original Poster
Rep: Reputation: 30
Like I said:

1.) The RH9 machines in my office were getting DDNS updates
2.) The Slackware machine wasn't

My options were this:

1.) Check and see what the RH9 machines were doing differently from the Slackware machine and try to adapt.

2.) Post on Linuxquestions

Logical enough, wouldn't you say?

If there were a BSD machine on the network, I would've looked to that first.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DHCP, Gateway and DNS server depam Linux - Networking 3 10-05-2005 08:33 PM
Suse 9.2 won't get DNS numbers from DHCP server LinuxOnEarth Linux - Networking 2 02-23-2005 12:03 PM
configuring dns server on dhcp client ydpk Linux - Networking 3 11-04-2004 11:23 PM
DNS from DHCP server not working mikegorb Linux - Networking 1 10-25-2004 04:02 AM
How do you make the ip masquerade server/dhcp server broadcast dns to lan cmisip Linux - Networking 6 01-25-2003 11:43 PM


All times are GMT -5. The time now is 10:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration