LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-03-2011, 07:41 PM   #1
Transhour
LQ Newbie
 
Registered: Jan 2011
Distribution: Slackware-Current
Posts: 3

Rep: Reputation: 0
slack-desc: not working?


I'm building a slackpackage for TeamSpeak3, i got everything to build and link correctly, but the problem i'm having to me seems rather minor, but it is annoying, i can't get the description when i install it using pkgtool to show up, even tho i do have a slack-desc in the install folder of the pkg itself, and i believe it to be properly formatted.

any suggestions as to why it wont show up?

i've attached the slackbuild and slack-desc to see if i'm missing a step.

thanks in advance,
Transhour
Attached Files
File Type: txt slack-desc.txt (723 Bytes, 31 views)
File Type: txt teamspeak3.SlackBuild.txt (2.8 KB, 21 views)
 
Old 02-03-2011, 09:02 PM   #2
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Rep: Reputation: 67
Try VERSION=${VERSION:-3.0.0_beta36} instead of VERSION=3.0.0-beta35. Makepkg etc are sensitive when it comes to hyphens.
 
1 members found this post helpful.
Old 02-03-2011, 09:06 PM   #3
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Also maybe instead of
Code:
mkdir -p $TMP
cd $TMP

rm -rf $PKG
cp $CWD/$PRGNAM-Client-linux_$CHOICE-$VERSION.run $TMP 
chmod +x $PRGNAM-Client-linux_$CHOICE-$VERSION.run
./$PRGNAM-Client-linux_$CHOICE-$VERSION.run --noexec --target $PKG/opt/$PRGNAM

mkdir $PKG/install
mkdir $PKG/usr
mkdir $PKG/usr/share
mkdir $PKG/usr/share/icons
mkdir $PKG/usr/share/icons/hicolor
mkdir $PKG/usr/share/icons/hicolor/48x48
mkdir $PKG/usr/share/icons/hicolor/48x48/apps
mkdir $PKG/usr/share/applications
mkdir $PKG/usr/share/licenses/$PRGNAM/LICENSE
mkdir $PKG/usr/bin

cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
You could try
Code:
rm -rf $PKG 
mkdir -p $TMP $PKG $OUTPUT
cd $TMP


cp $CWD/$PRGNAM-Client-linux_$CHOICE-$VERSION.run $TMP 
chmod +x $PRGNAM-Client-linux_$CHOICE-$VERSION.run
./$PRGNAM-Client-linux_$CHOICE-$VERSION.run --noexec --target $PKG/opt/$PRGNAM

mkdir $PKG/install
mkdir -p $PKG/usr/share/icons/hicolor/48x48/apps
mkdir $PKG/usr/share/applications
mkdir -p $PKG/usr/share/licenses/$PRGNAM/LICENSE
mkdir $PKG/usr/bin

cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
 
Old 02-04-2011, 07:02 AM   #4
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado
Distribution: Slackware
Posts: 421

Rep: Reputation: 58
You need to perfectly match package name inside the slack-desc file and the slackbuild file name.

http://www.slackwiki.org/Slack-desc

"TeamSpeak3" inside the slack-desc file does not match "teamspeak.SlackBuild" in the file name
 
Old 02-04-2011, 07:39 AM   #5
GazL
Senior Member
 
Registered: May 2008
Posts: 3,392

Rep: Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917
Quote:
Originally Posted by Chuck56 View Post
You need to perfectly match package name inside the slack-desc file and the slackbuild file name.
"TeamSpeak3" inside the slack-desc file does not match "teamspeak.SlackBuild" in the file name
The name of the slackbuild script doesn't matter. The name inside the slack-desc should match $PRGNAM if you're using a standardised slackbuild script.

Brixton' is on the money. Because of the hyphen in the version number, instead of seeing
"TeamSpeak3", version "3.0.0-beta36"
the package tools are probably interpreting the package name as
"TeamSpeak3-3.0.0", version "beta36"

Swap it for an underscore, or another dot or any other valid character and all should be fine.
 
Old 02-04-2011, 01:02 PM   #6
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,755

Rep: Reputation: 466Reputation: 466Reputation: 466Reputation: 466Reputation: 466
As brixtoncalling mentioned, package names are sensitive to the presence of '-' characters. The package tools parse the name from right to left, withe hyphen as the separator. So, if you put an extra hyphen in one of the fields, it confuses installpkg. Names should look like this:
NAME-VERSION-ARCH-BUILD
NAME can include one or more hyphens, but not any of the other fields.
 
Old 02-04-2011, 10:46 PM   #7
chrisretusn
Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware
Posts: 479

Rep: Reputation: Disabled
As already mentioned, I bet getting rid of the '-' in 3.0.0-beta36 will take care of it. Just make it 3.0.0beta36
 
Old 02-05-2011, 02:51 AM   #8
Transhour
LQ Newbie
 
Registered: Jan 2011
Distribution: Slackware-Current
Posts: 3

Original Poster
Rep: Reputation: 0
yep the problem was with the 3.0.0-beta36 in the filename, i've altered the slackbuild to change the file name to TeamSpeak3-3.0.0beta6, works now.

thanks everyone, i appreciate the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackpkg and slack-desc Panci Slackware 9 04-05-2009 06:15 AM
slack-desc requirements/expectations Woodsman Slackware 4 10-18-2008 10:26 AM
package creation and slack-desc file mobilemonkey Slackware 6 07-02-2007 10:53 AM
Makepkg and slack-desc mirto Slackware 7 10-15-2005 03:17 PM
Format of slack-desc file Azmeen Slackware 6 07-11-2003 02:36 AM


All times are GMT -5. The time now is 05:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration